Quote Originally Posted by Awesomeness View Post
Flash is the sole reason I have to use PulseAudio. Flash is hardcoded to use the first sound card. Too bad on my Lenovo laptop the first output is HDMI, not the internal PCH.
I don't know if you can do this on your laptop without killing your video driver, but in many cases you can get around a "wrong soundcard" default by blacklisting the driver for it. I had that problem on a Pentium 4 in which I had dropped an Nvidia GT520 with the blob to play 1080p video in VDPAU, causing the sound to default to an Intel device that did not work. Blacklisting that driver made the installed sound card come up first. On a laptop with AMD and open AMD drivers, HDMI sound can be disabled in the video driver itself. Don't know what the Nouveau situation is on that.

Pull up the output of dmesg, look for your soundcard drivers. If the HDMI shows any driver other than your video driver, blacklist it in /etc/modprobe.d and reboot. Now the sound you want to use is the only soundcard and should come right up