Page 10 of 10 FirstFirst ... 8910
Results 91 to 95 of 95

Thread: RS480/RS690 OSS Compiz Achieved

  1. #91
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    givemesugar, I haven't waded through all the info in detail but at first glance I'm wondering if you still have an old smelly drm for some reason, maybe new one built but didn't get installed properly ?

    Your CPU shows clock of 800 MHz vs 2 GHz for countdown's, but IIRC the TK-57 runs at ~1.9 GHz when at full speed. Could be yours is just running slow all the time; might be interesting to pull clock info while glxgears is running.

  2. #92
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by bridgman View Post
    givemesugar, I haven't waded through all the info in detail but at first glance I'm wondering if you still have an old smelly drm for some reason, maybe new one built but didn't get installed properly ?

    Your CPU shows clock of 800 MHz vs 2 GHz for countdown's, but IIRC the TK-57 runs at ~1.9 GHz when at full speed. Could be yours is just running slow all the time; might be interesting to pull clock info while glxgears is running.
    nope... the procinfo was taken when the processor was in low requirements so that it was running at lowest speed. when glxgears starts the processor goes up to max speed (i've verified it with htop). i was able to get out some more speed after removing enablepageflip (sincerely i don't know why i was using it) but it's still slow (400fps). the old x200 with half ram was running more than rs690 (about 600-700 fps).
    as for drm and so on, i've just finished reinstalling today's packages after removing old ones manually. so there aren't old packages on my system. i was also able to run compiz for about 30 seconds but it was so unstable that i had to kill xorg server. the log now has only one failure (it cannot find the type1 extension that was removed from newer servers). well, i think i'll try out looking at the options in xorg.conf since i think that in the end are them that are causing problems.
    might be that enabling mtrr would slow down the board?! with the old x200 i had nearly 85fps increase in performance after enabling it so i had enabled it also for the rs690 and haven't removed it anymore.

  3. #93
    Join Date
    Sep 2007
    Posts
    54

    Default

    Actually the clockscaling is on. I am using ondemand governor.

    glxgears @800mhz: ~24% cpu usage
    Code:
    $ glxgears 
    2497 frames in 5.0 seconds = 499.386 FPS
    2640 frames in 5.0 seconds = 527.863 FPS
    2600 frames in 5.0 seconds = 519.892 FPS
    2623 frames in 5.0 seconds = 524.598 FPS
    glxgears @2gig: ~15% cpu usage
    Code:
    $ glxgears 
    3422 frames in 5.0 seconds = 684.355 FPS
    3599 frames in 5.0 seconds = 719.718 FPS
    3616 frames in 5.0 seconds = 723.072 FPS
    3601 frames in 5.0 seconds = 720.198 FPS
    btw, i have stopped building from git, instead i'm using xorg-edgers ppa on hardy amd64. The only difference with hand built git i see is lower mem usage.
    Last edited by c0un7d0wn; 06-29-2008 at 06:11 PM.

  4. #94
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by c0un7d0wn View Post
    Actually the clockscaling is on. I am using ondemand governor.

    glxgears @800mhz: ~24% cpu usage
    Code:
    $ glxgears 
    2497 frames in 5.0 seconds = 499.386 FPS
    2640 frames in 5.0 seconds = 527.863 FPS
    2600 frames in 5.0 seconds = 519.892 FPS
    2623 frames in 5.0 seconds = 524.598 FPS
    glxgears @2gig: ~15% cpu usage
    Code:
    $ glxgears 
    3422 frames in 5.0 seconds = 684.355 FPS
    3599 frames in 5.0 seconds = 719.718 FPS
    3616 frames in 5.0 seconds = 723.072 FPS
    3601 frames in 5.0 seconds = 720.198 FPS
    btw, i have stopped building from git, instead i'm using xorg-edgers ppa on hardy amd64. The only difference with hand built git i see is lower mem usage.

    i've finally made it....

    kde4 + compiz and kde4-window-decorator + render accel + 8 compilation threads i've been able to get about 500fps in glxgears with one processor at 24% load and the other at 5%...

    i've removed completely xorg packages and rebuild everything from git (including libraries, server, drivers) and then rebuild entirely kde4 and compiz and now the performance is about as i was expecting. the only issues are with kaffeine when running on compiz to be a very big resource sucker and thus not allowing me to do other stuff while trying to watch videos on compiz and firefox behaving a little slow with scrolling.
    the performance without compiz is exactly the same (and this is a real surprise to me) but this time the video playback and the firefox scrolling is quite fluid and i can also do some compiling at the same time.

    thanks to all who have tried to help me out and especially to the ones that have made this possible, amd and all the devs that are working on the driver.
    thanks very much for the work you've done in the last months.

  5. #95
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,155

    Default

    Yeah, if you're not playing high-end 3D games, the radeon 6.9.0 + Xserver 1.5 + Mesa 7.1 combination is already a good replace for (and sometimes [2D for example] even better than) fglrx if you're having R5xx in my opinion. Compiz, KDE4, Videos, basic 3D stuff, it all runs wonderful!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •