Results 1 to 4 of 4

Thread: R290x sound problems

  1. #1
    Join Date
    Oct 2013
    Posts
    7

    Default R290x sound problems

    Hi everyone,

    do you also experience problems with your R290x( or r'series card ) when trying to use HDMI audio out?
    Played sound mostly arrives "disturbed" at my speakers most of the time.
    But there are also some rare moments where everything seems to work just fine.
    My HD5870 had no such problems.

    I tested it with catalyst 14.1 and xf86-video-radeon under gentoo and with xf86-video-radeon using fedora 20.
    Same behaviour on both distros.

    Any suggestions?

    Regards,
    Thomas

  2. #2
    Join Date
    Oct 2013
    Posts
    7

    Default

    Seems as if the discribed case has something to do with the cpu running idle.
    Under heavy load, like compiling packages for gentoo, played sound sounds perfect.

    google-search: linux crackling sound idle .. comes up with some results.

    But setting processor.max_cstate=3 or less does not have the desired effect.

    I even disabled C3/C6 in bios... no effect.

  3. #3
    Join Date
    Apr 2013
    Posts
    65

    Default

    Do 'lspci -vv'

    You will see your pci devices and their corresponding kernel drivers.

    AMD cards have at least 2 pci devices.

    1. graphic adapter
    2. HDMI Sound device

    Most likely the sound device is a HD Audio controller from Intel. There is very little interaction between the graphic and the audio device.

    your problem sound like a good candidate for reporting on the alsa-dev mailing list. Just check the doc on how to submit problem (either on the net or in the kernel source code documentation).

  4. #4
    Join Date
    Oct 2013
    Posts
    7

    Default

    First of all: I am sorry for the very late reply.

    Thanks for the info lano1106.
    Until now i did not file a bug at alsa but found a working solution for my system's problem.

    To make it short:

    /etc/pulse/daemon.conf
    Code:
    default-fragment-size-msec = 125
    did the trick.

    I do not know if i missed this when reading the previous search results but i just accidently found it when doing a new search.

    So i think pulseaudio is to blame.
    Two weeks ago i also tested alsa successfully using the
    Code:
    $ speaker-test
    and directly adressing it to my hdmi out.

    My systems current configuration: gentoo-kernel-3.14, pulseaudio 5.0, ati-drivers-14.3_beta

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •