Page 6 of 6 FirstFirst ... 456
Results 51 to 53 of 53

Thread: Say Hello To The "KDE Leaks" Team

  1. #51
    Join Date
    Jul 2009
    Location
    Serbia
    Posts
    47

    Cool

    Quote Originally Posted by Baconmon View Post
    If would be like: Imagine if you created wayland, and when it was finally 100% completed, aaron comes in and tells you "We are going to name it 'X'"......wouldn't that piss you off?..
    Of what if you worked really hard to created systemd.......and then when you get done, aaron comes in and tells you "Good job, but we are going to still call it "sysV"..
    Or what if you bore a new child, and you wanted to name him "Bob", but then aaron comes in to the hospital and tells you "NO..You have to name him rumplestilskin", like wtf, wouldn't that piss you off?!?.. grrrrrrr Like, go away! You didn't create this child, *I* did......god......seriously....

    If some one takes a screen-shot of a KDE desktop, you instantly know they are using KDE because of that stupid useless cashew that is permanently stuck to your desktop wallpaper..
    ROFLMAO is what best describes the situation I'm in after reading your post. Thanks, I haven't had so much laughs in months.

  2. #52
    Join Date
    Nov 2013
    Posts
    223

    Default

    Quote Originally Posted by edgar_wibeau View Post
    So I set ~/.config/akonadi/akonadiserverrc -> StartServer=false (defaults to "true")
    That does not tell Akonadi server not to start, that tells Akonadi server that you want to use an already running database, .e.g a system wide MySQL or PostgreSQL instance.

    You are incidentally getting the effect of Akonadi not starting (actually crashing) because you probably have not configured the database connection accordingly.

    Quote Originally Posted by edgar_wibeau View Post
    Yet now, when I start kmail or kontact, it tries to trigger akonadi, waits for like a minute ... and then fails! When I look at akonadi, it says it couldn't be started.
    You created a configuration that makes it impossible for Akonadi server to start successfully. It is not allowed to start its own MySQL instance, neither have you provided the connection settings for contacting an already running one.
    Providing contradictory rules to a machine will alway result in it failing. See some of the old Star Trek episodes if you want to have fun examples

    Quote Originally Posted by edgar_wibeau View Post
    couldn't there be a StartServer Option like "auto" or "ondemand"?
    On Demand is the default behavior. There are neither autostart hooks nor session restore hooks that would launch Akonadi without any client needing it.
    Only applications that want to access data provided through Akonadi are starting it (if not yet running) as part of establishing a session.
    That of course only under the assumption that neither distributor nor system administrator have change that.

    Quote Originally Posted by edgar_wibeau View Post
    I think, back in the days (or some predecessor framework) worked just like this.
    The predecessor framework did not use a daemon to arbitrate data access.

    Cheers,
    _

  3. #53
    Join Date
    Nov 2009
    Posts
    111

    Default

    I've been using KDE 1.1.x since 1999 or 2000 or so (occasionally working with other desktops and window managers), and I've never felt Michael was biased one way or the other in regards to KDE.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •