Results 1 to 7 of 7

Thread: Many tests fail without any error message

  1. #1

    Default Many tests fail without any error message

    I am running Xubuntu 13.10 (all up to date) on an i5-4670k system just running the stock i915 intel driver and or whatever ubuntu installs by default and valley, sanctuary, and heaven don't run. Prey also doesn't run. Why is there no useful information why they don't run?

    Here's the system info per steam
    Processor Information:
    Vendor: GenuineIntel
    CPU Family: 0x6
    CPU Model: 0x3c
    CPU Stepping: 0x3
    CPU Type: 0x0
    Speed: 4001 Mhz
    4 logical processors
    4 physical processors
    HyperThreading: Unsupported
    FCMOV: Supported
    SSE2: Supported
    SSE3: Supported
    SSSE3: Supported
    SSE4a: Unsupported
    SSE41: Supported
    SSE42: Supported

    Network Information:
    Network Speed:

    Operating System Version:
    Ubuntu 13.10 (64 bit)
    Kernel Name: Linux
    Kernel Version: 3.11.0-17-generic
    X Server Vendor: The X.Org Foundation
    X Server Release: 11405000
    X Window Manager: Xfwm4
    Steam Runtime Version: steam-runtime-release_2013-10-23

    Video Card:
    Driver: Intel Open Source Technology Center Mesa DRI Intel(R) Haswell Desktop x86/MMX/SSE2

    Driver Version: 3.0 Mesa 9.2.1
    OpenGL Version: 3.0
    Desktop Color Depth: 24 bits per pixel
    Monitor Refresh Rate: 59 Hz
    VendorID: 0x1002
    DeviceID: 0x683d
    Number of Monitors: 1
    Number of Logical Video Cards: 2
    Primary Display Resolution: 1440 x 900
    Desktop Resolution: 1440 x 900
    Primary Display Size: 16.06" x 10.04" (18.94" diag)
    40.8cm x 25.5cm (48.1cm diag)
    Primary VRAM Not Detected

    Sound card:
    Audio device: Intel Haswell HDMI

    Memory:
    RAM: 7863 Mb

    Miscellaneous:
    UI Language: English
    LANG: en_US.UTF-8
    Microphone: Not set
    Total Hard Disk Space Available: 168792 Mb
    Largest Free Hard Disk Block: 66645 Mb

  2. #2

    Default

    Quote Originally Posted by ubuntuaddicted View Post
    I am running Xubuntu 13.10 (all up to date) on an i5-4670k system just running the stock i915 intel driver and or whatever ubuntu installs by default and valley, sanctuary, and heaven don't run. Prey also doesn't run. Why is there no useful information why they don't run?

    Here's the system info per steam
    Valley / Heaven don't work well for the open-source drivers... For Prey you need the retail game data. For Sanctuary / Tropics you probably have a graphics driver issue.

  3. #3
    Join Date
    Feb 2014
    Posts
    15

    Default Having similar non-gfx driver related issues with most tests

    Quote Originally Posted by Michael View Post
    Valley / Heaven don't work well for the open-source drivers... For Prey you need the retail game data. For Sanctuary / Tropics you probably have a graphics driver issue.
    Gigabyte Brix Pro i5 with Intel Iris Pro 5200 running Kubuntu 13.10 with x11-edgers 10.2 MesaGL. Nearly all the tests that failed as part of pts run independently just fine when manually installed.


    Actually I find Heaven 3 works great with Intel MesaGL 9.2.1, and Heaven 4.x works great with MesaGL 10.x. I am having similar issues with a lot of the tests in the pts/* Graphics. Here is the list I've compiled:


    pts/video-cpu-usage : download big_buck_bunny fails, no other files attempted
    pts/viennacl : The test run did not produce a result
    pts/cstrike : runs fine, no results
    pts/tf2 : runs fine, no results
    pts/lightsmark : E: ./backend: error while loading shared libraries: libGLEW.so.1.5: cannot open shared object file: No such file or directory
    pts/trislam : The test run did not produce a result
    pts/etqw-demo : E: ./etqw.x86: error while loading shared libraries: libjpeg.so.62: cannot open shared object file: No such file or directory
    pts/lightsmark : E: ./backend: error while loading shared libraries: libGLEW.so.1.5: cannot open shared object file: No such file or directory
    pts/qvdpautest : ERROR: Missing Header File: vdpau/vdpau_x11.h
    pts/doom3 : E; Sys_Error: Couldn't load default.cfg

    pts/apitrace : The installer exited with a non-zero exit status.
    ERROR: apitrace_/cli/cli_dump.cpp:166:25: error: 'isatty' was not declared in this scope
    LOG: ~/.phoronix-test-suite/installed-tests/pts/apitrace-1.0.1/install-failed.log

    pts/gluxmark : E: ./gluxmark: 3: ./gluxmark: ./bin/bench: not found
    pts/vdrivt : The test run did not produce a result. E: ./vdrift: 40: ./vdrift: ./build/vdrift: not found
    pts/unigine-sactuary : Runs great (may have to "export MESA_EXTENSION_OVERRIDE=-GL_ARB_sample_shading")
    pts/unigine-tropics : Runs great (may have to "export MESA_EXTENSION_OVERRIDE=-GL_ARB_sample_shading")
    pts/unigine-valley : Runs great (may have to "export MESA_EXTENSION_OVERRIDE=-GL_ARB_sample_shading")

    pts/unigine-heaven : Runs great (DEFINITELY have to "export MESA_EXTENSION_OVERRIDE=-GL_ARB_sample_shading"). Heaven3.0 works with Mesa 9.2.1, Heaven4.0 requires Mesa 10.x for Intel Iris Pro 5200

    pts/quake4 : Was missing i386 libraries (libsdl1.2debian), fixed this now it just brings up what appears to be a console splash screen and exits.
    pts/unvanquished : Just never starts, sits at "Started Run 1 @ 15:46:38" forever. Tried to look into it and can't get it to manually run either. Runs fine from offical Unvanquished.

  4. #4
    Join Date
    Feb 2014
    Posts
    15

    Default

    Other issues after running all the tests that do work to completion:

    pts/et : Doesn't enter fps measurement mode
    pts/etxreal : Doesn't enter fps measurement mode
    pts/padman : Sits at main menu, doesn't enter fps measurement mode
    pts/tremulous : brings up game console with lots of load errors for UI/MENDDEF.H not found, and lots of .MENU files not found, have to type quit to exit

  5. #5
    Join Date
    Feb 2014
    Posts
    15

    Default

    Quote Originally Posted by tebruno99 View Post
    Other issues after running all the tests that do work to completion:

    pts/et : Doesn't enter fps measurement mode
    pts/etxreal : Doesn't enter fps measurement mode
    pts/padman : Sits at main menu, doesn't enter fps measurement mode
    pts/tremulous : brings up game console with lots of load errors for UI/MENDDEF.H not found, and lots of .MENU files not found, have to type quit to exit
    Nevermind, I fixed these. They were argument errors in my custom test-suite

  6. #6

    Default

    i don't really understand what the answer to my question is. I am using a stock Xubuntu installation with the Intel HD 4600 and I want to run heaven and valley for an article I am writing. I am going to compare the performance of a stock xubuntu install, then using kernel 3.13, then using kernel 3.13 but with oibaf's ppa so I get the latest git mesa etc etc. Can anyone please figure out why I can't get valley and heaven to run.

  7. #7
    Join Date
    Feb 2014
    Posts
    15

    Default

    Quote Originally Posted by ubuntuaddicted View Post
    i don't really understand what the answer to my question is. I am using a stock Xubuntu installation with the Intel HD 4600 and I want to run heaven and valley for an article I am writing. I am going to compare the performance of a stock xubuntu install, then using kernel 3.13, then using kernel 3.13 but with oibaf's ppa so I get the latest git mesa etc etc. Can anyone please figure out why I can't get valley and heaven to run.
    As Michael said MesaGL that comes stock with Xubuntu is not going to support Unigine Heaven 4.0. You will need to upgrade to the x11 edgers ubuntu ppa to get MesaGL 10.x inorder to run Heaven. I don't have any info about Valley. However, from the notes in my post, even if you get MesaGL 10.x you will still need to run:

    export MESA_EXTENSION_OVERRIDE=-GL_ARB_sample_shading

    Before attempting to run the benchmark. Heaven 3.0 will work find with MesaGL 9.2.1 that is in your Xubuntu. You can run both Valley and Heaven outside of Phoronix Test Suite just download Heaven 3.0 from an archive site like: http://www.techpowerup.com/downloads...3-0-for-linux/ You will still need the export line to be executed in your env before running it though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •