Page 5 of 5 FirstFirst ... 345
Results 41 to 43 of 43

Thread: NVIDIA 334.16 Beta Supports 64-bit EGL / OpenGL ES

  1. #41
    Join Date
    Jan 2009
    Posts
    1,401

    Default

    Quote Originally Posted by gens View Post
    subsurfaces + alpha channel should cover that, no ?
    For image uploading? They'd probably use texture from pixmap but, yeah, subsurface is exactly what'll be used for things like video. You'd still need an accelerated 2d rendering to replace xrender.
    Check out the skia bug in Firefox for more info.
    Skia mostly works now in the latest ff and it is FAST with far lower CPU usage than Cairo.


  2. #42
    Join Date
    May 2012
    Posts
    453

    Default

    Quote Originally Posted by liam View Post
    For image uploading? They'd probably use texture from pixmap but, yeah, subsurface is exactly what'll be used for things like video. You'd still need an accelerated 2d rendering to replace xrender.
    Check out the skia bug in Firefox for more info.
    Skia mostly works now in the latest ff and it is FAST with far lower CPU usage than Cairo.

    oh, i thought you meant just alpha blending and such
    ye doing text in openGL can be way faster with better results
    idk about 3x3 matrices thou
    guess you dont have to use them for flat text

  3. #43
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,791

    Default

    I tried the GLES version of KWin (4.11.6) with this driver. It works. But there's some junk rendered behind transparencies/blur and KWin says that eglPostSubBufferNV is not supported.

    The whole output of kwin_gles is:

    Code:
    OpenGL vendor string:                   NVIDIA Corporation
    OpenGL renderer string:                 GeForce GTX 780/PCIe/SSE2
    OpenGL version string:                  OpenGL ES 2.0 334.16
    OpenGL shading language version string: OpenGL ES GLSL ES 1.00
    Driver:                                 NVIDIA
    Driver version:                         0.0
    GPU class:                              Unknown
    OpenGL version:                         2.0
    GLSL version:                           1.0
    X server version:                       1.15
    Linux kernel version:                   3.10.28
    Direct rendering:                       yes
    Requires strict binding:                no
    GLSL shaders:                           yes
    Texture NPOT support:                   yes
    Virtual Machine:                        no
    kwin(3039) KWin::EglOnXBackend::init: eglPostSubBufferNV not supported, have to enable buffer preservation - which breaks v-sync and performance
    QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
    QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
    kwin(3039) KWin::checkGLError: GL error ( PostPaint ):  "GL_INVALID_OPERATION"
    kwin(3039) KWin::checkGLError: GL error ( PostPaint ):  "GL_INVALID_OPERATION"
    kwin(3039) KWin::checkGLError: GL error ( PostPaint ):  "GL_INVALID_OPERATION"
    The GL_INVALID_OPERATION errors repeats over and over whenever you do something on the desktop.
    Last edited by RealNC; 02-10-2014 at 04:30 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •