Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Horrible Tearing With Radeon HD 5750

  1. #1
    Join Date
    Feb 2014
    Location
    Paris
    Posts
    8

    Angry Horrible Tearing With Radeon HD 5750

    I just installed the latest Fedora (XFCE spin) and have horrible tearing when I move windows over the screen or when I browse the internet with Firefox or Google Chrome.
    My configuration :
    • Fedora 20 XFCE Spin
    • Kernel is 3.12.9
    • My Graphic Card is Radeon HD 5750 (with Open Source drivers)


    I didn't configure anything special and don't use any compositing system.

    I noticed some 3D applications (like blender) don't have any tearing issues. I know it's a VSync related problem but don't know what to do...

    Any help would be appreciated

  2. #2
    Join Date
    Feb 2009
    Location
    France
    Posts
    31

    Default

    Try enabling OpenGL compositing with vsync.

    I have a HD 5650 Mobility and there's absolutely no tearing and almost everything in my KDE desktop is mighty fluid.

  3. #3
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    438

    Default

    What could also help is setting the correct display as the primary one with xrandr:

    Code:
    xrandr --output DVI-0 --primary
    you obviously have to replace DVI-0 with the correct one for your setup.

  4. #4
    Join Date
    Feb 2014
    Location
    Paris
    Posts
    8

    Default

    Thanks for your help.

    Unfortunately
    Code:
    xrandr --output DVI-0 --primary
    doesn't change anything.

    I searched for an OpenGL compositing for Fedora 20 but the only one I found in my repositories was Compiz and I would really want to avoid it.

    A lot of people seem to use Compton but I couldn't find any package for Fedora 20

    BTW, I just noticed that Google Chrome seems to have almost no tearing (maybe because it uses OpenGL to render content ?)
    Last edited by quincampoix; 02-06-2014 at 02:51 PM.

  5. #5
    Join Date
    Feb 2014
    Location
    Paris
    Posts
    8

    Default

    Actually Google Chrome has some flickering/tearing, but it's not as visible as with Firefox.

  6. #6
    Join Date
    Jul 2013
    Posts
    66

    Default

    You need to enable the composition in the configuration of xfce, but better is use the privative drivers and enable tearing free in catalyst control center.

  7. #7

    Default

    I have the free drivers (built myself from git) and have no tearing with 1 monitor in opengl or hardware accelerated rendering/playback (vdpau). Make sure you have everything installed as it should. NO xorg.conf is needed.

    Browser related:

    Chrome is ABSOLUTELY CRAP right now (i use the latest git mesa and all). For some older versions i could force to use opengl acceleration for playback and webgl and was working fine, but newer versions have horribly high CPU usage. Maybe its related to some recent mesa changes?

    Firefox/Seamonkey on the other hand perform very well, especially after i enabled the layer acceleration.

    Quote Originally Posted by felipe View Post
    You need to enable the composition in the configuration of xfce, but better is use the privative drivers and enable tearing free in catalyst control center.
    Well that feature does prevent tearing, but it also reduces the playback fps visibly sometimes. Not to mention you cannot use vdpau playback which is tear-free and lightweight (the "tear free" option eats additional video memory).

  8. #8
    Join Date
    Dec 2007
    Posts
    2,275

    Default

    Quote Originally Posted by felipe View Post
    You need to enable the composition in the configuration of xfce, but better is use the privative drivers and enable tearing free in catalyst control center.
    It has to be OpenGL compositing for vsync support. I'm not sure if xfce supports GL compositing.

  9. #9
    Join Date
    Feb 2014
    Location
    Paris
    Posts
    8

    Default

    Quote Originally Posted by felipe View Post
    You need to enable the composition in the configuration of xfce, but better is use the privative drivers and enable tearing free in catalyst control center.
    When I enable compositing in xfce control panel, I still have tearing! And I do not want to use proprietary drivers.

    I have to use Chrome to have the lastest version of Flash player (which is unfortunately still used a lot on the web )

    Quote Originally Posted by gradinaruvasile
    I have the free drivers (built myself from git) and have no tearing with 1 monitor in opengl or hardware accelerated rendering/playback (vdpau)
    I don't have tearing in opengl or hardware accelerated rendering either! I only have tearing on windows and web browsers. Flash videos do not have tearing BUT HTML 5 videos in firefox HAVE tearing!

  10. #10
    Join Date
    Feb 2014
    Location
    Paris
    Posts
    8

    Default

    Quote Originally Posted by felipe View Post
    You need to enable the composition in the configuration of xfce, but better is use the privative drivers and enable tearing free in catalyst control center.
    When I enable compositing in xfce control panel, I still have tearing! And I do not want to use proprietary drivers.

    I have to use Chrome to have the lastest version of Flash player (which is unfortunately still used a lot on the web )

    Quote Originally Posted by gradinaruvasile
    I have the free drivers (built myself from git) and have no tearing with 1 monitor in opengl or hardware accelerated rendering/playback (vdpau)
    I don't have tearing in opengl or hardware accelerated rendering either! I only have tearing on windows and web browsers. Flash videos do not have tearing BUT HTML 5 videos in firefox HAVE tearing!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •