Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: EdgeBSD Born Out Of NetBSD Operating System

  1. #21
    Join Date
    Nov 2011
    Posts
    276

    Default

    Let's see how the libc versions affect binary compatability...
    glibc (libc6): 2.x is likely to not run stuff compiled with 2.x+1; 2.x+1 can run stuff compiled with 2.x.
    eglibc: same, except you can turn off support for features. If you turn off a feature, anything that uses it won't work.
    Compatible with glibc.
    (the above two are fairly widely used, but there are several versions in use. LSB ABI is a subset of glibc.)
    musl: compatible with a subset of glibc ABI. Usually backwards and forwards compatible.
    uclibc: No compatability with anything, including stuff compiled with older or newer versions.
    (Both used in a few distros, with occasional use in parallel with the main libc.)
    dietlibc: "Unofficially" compatible with older and newer versions; not ABI compatible with any other library
    klibc: not compatible with anything else; no documentation I could find on backwards/forwards compatability.
    (Both almost always used in parallel with glibc, to create static binaries)
    bionic: Incompatible ABI, based on a mix of BSD libcs. Also full of stubs. (Android.)
    olibc: bionic ABI, but with the stubs filled out. Aimed at embedded systems, AFAICT.
    newlib: incompatible ABI; embedded or parallel.
    And then there are at least three other ANSI libcs (ccaprice, pdlibc, PDClib) that aim at static linking, so the binaries might be portable. ISTR some also support shared binaries...

    Long story short:
    If you build it on an old glibc-based distro, it will run on most Linux distros.
    If you build it static, it will run on all Linux distros that have a properly configured kernel and filesystem.
    If you use uclibc shared, it's for one distro release.

  2. #22
    Join Date
    Aug 2013
    Posts
    113

    Default

    Quote Originally Posted by beetreetime View Post
    EdgeBSD: BSD is getting more and more fragmentated. More versions appearing that are incompatible with each other. Unlike Linux in which all distros are binary compatitble. The number of BSD versions and BSD fragments are converging. Soon there be an average of one user per BSD version and then the number of BSD versions will decrease to zero and the world would be a better place.
    I have ignored the first statement as it is entirely subjective (and laughable in the extreme). Following is a sentence-by-sentence refutation of your claims.

    EdgeBSD is essentially functioning as a NetBSD 'unstable branch', a grounds for exciting new additions to be pushed upstream to NetBSD.

    Linux and binary compatibility in the same sentence is dubious.

    Do you know what converging means? You would be sort-of right with 'diverging', but not including variants and extremely fringe projects, there are only 4 BSDs (and all 4 have a measure of binary compatibility - with each other! and their prior releases, as well! and even with other OSes (including Linux)!)

    And no.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •