Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: Mozilla Firefox 27 Is Coming Today With New Features

  1. #21
    Join Date
    May 2008
    Posts
    98

    Default

    Quote Originally Posted by shmerl View Post
    Just tested, changing that to skia in about:config makes this demo much faster: http://js1k.com/2013-spring/demo/1555
    Really noticeable difference. Why isn't that the default then?
    This is answered in the bug report that you quoted one post above this...

    The issue is that skia draws in process whereas cairo draws predominantly in the X server. The issue is that the gtk2 widgets live in the X server. If we use skia for content then we need to read back the gtk2 widgets from the X server to composite them with skia. This adds a big overhead to every composite cycle.

    The net result is that regular browsing is slower with skia but benchmarks may show a faster result.

  2. #22
    Join Date
    Apr 2010
    Posts
    716

    Default

    Quote Originally Posted by OneTimeShot View Post
    Sadly this is my experience too. For me, performance took a major hit ages ago when they (or at last at the same time as) introduced MySql to store browser history and bookmarks.
    Firefox doesn't, and never has, used MySQL - the very idea would be absurd. I suspect you're thinking of SQLite, which is a simple embedded SQL database.

    Quote Originally Posted by OneTimeShot View Post
    Maybe I should download Firefox 3.5, and re-live what things were like in the good ol' days. I remember Mozilla being pretty fast when a 233Mhz PII was mid-range...
    Nostalgia is a wonderful thing, but often misguided. Firefox 3 might have faster startup times, but in terms of page rendering performance, it's notably slower. It's also lacking in support for a lot of new CSS and Javascript operations...

  3. #23
    Join Date
    Nov 2011
    Posts
    271

    Default

    Quote Originally Posted by plonoma View Post
    @finalzone
    Could you give a link to the bug in the issue tracker?
    I don't have the bug #. I currently use GTK3 build Nightly release Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0
    for Fedora 20 and noticed no issue with scrollbar using default setting.

  4. #24

    Default

    I just need to know how to disable the anti-social API completely.

  5. #25
    Join Date
    Jan 2011
    Posts
    1,287

    Default

    Quote Originally Posted by Kivada View Post
    I just need to know how to disable the anti-social API completely.
    I don't know if that's an option, but to disable REALLY completely an API, the obvious choice would be make it in build time.

    Anyway, my guess is that setting social.enabled to false in about:config. It's false by default in my nightly install, so I'm not sure.

  6. #26
    Join Date
    May 2013
    Posts
    5

    Default

    I really don't like Chrome at all and last but not least for privacy concerns.

    If you like Firefox but it's sluggish on your system, then I'm here to help. To be positive Firefox (26) runs blazingly fast on my rather old system (AMD San Diego, Single Core 2.2GHz, ondemand, 2GB RAM, Nvidia GT 520 with nouveau driver). Running on ubuntu 13.10 saucy 64bit.

    But you need to tweak it a little bit in about:config

    gfx.canvas.azure.backends = skia,cairo
    gfx.content.azure.backends = skia,cairo
    gfx.content.azure.enabled = true
    gfx.canvas.azure.enabled = true (<== you don't need this one explicitly, because it's automatically set)
    gfx.work-around-driver-bugs = false
    gfx.xrender.enabled = false (important!)

    webgl.prefer-native-gl = true

    layers.acceleration.force-enabled = true
    layers.async-video.enabled = true
    layers.offmainthreadcomposition.async-animations = true
    layers.offmainthreadcomposition.enabled = true
    layers.offmainthreadcomposition.testing.enabled = true (optional, try on/off)
    layers.use-deprecated-textures = false (important!)

    and
    browser.sessionstore.interval = 900000 (something very high. I have my setting at 900000)


    environmental variables
    (put them in your ~/.bashrc or in /etc/environment)
    Important!
    MOZ_GLX_IGNORE_BLACKLIST=1
    MOZ_USE_OMTC=1
    MOZILLA_X11_XINITTHREADS=1
    MOX_X_THREADSAFE=1 ("MOX" is not a typo)
    MOZ_ACCELERATED=1 (needed in Debian, not necessarily in ubuntu, but it can do no harm)
    MOZ_DISABLE_CRASHREPORTER=1 (this does make a difference for me, but maybe it's just subjective)
    MOZ_DISABLE_PANGO=1 (optional, not so sure if it still gives some benefit)


    The output in the Graphics section in about:support should be something like the following now:
    Graphics
    Adapter Description: nouveau -- Gallium 0.4 on NVD9
    Device ID: Gallium 0.4 on NVD9
    Driver Version: 3.0 Mesa 10.1.0-devel
    GPU Accelerated: Windows 1/1 OpenGL (OMTC)
    Vendor ID: nouveau
    WebGL Renderer: nouveau -- Gallium 0.4 on NVD9
    windowLayerManagerRemote: true
    AzureCanvasBackend: skia
    AzureContentBackend: none
    AzureFallbackCanvasBackend: cairo
    AzureSkiaAccelerated: 0

    My xorg.conf for nouveau driver (Firefox still is fast if you enable Compositing and AIGLX, but I just use openbox)
    Section "ServerFlags"
    Option "DRI2" "1"
    Option "AIGLX" "0"
    EndSection

    Section "Device"
    Identifier "NVD9"
    Driver "nouveau"
    Option "GLXVBlank" "1"
    Option "SwapLimit" "2"
    Option "PageFlip" "1"
    EndSection

    Section "Extensions"
    Option "Composite" "0"
    EndSection
    -------

    my glxinfo:
    direct rendering: Yes
    [...]
    OpenGL vendor string: nouveau
    OpenGL renderer string: Gallium 0.4 on NVD9
    OpenGL version string: 3.0 Mesa 10.1.0-devel
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)


    Resources
    :
    man nouveau http://linux.die.net/man/4/nouveau
    http://www.bsdforen.de/threads/firef...eunigen.30645/ (most of the env variables)
    http://blogs.fsfe.org/the_unconventi...ring-problems/ (very nice!)
    https://bugzilla.mozilla.org/show_bug.cgi?id=722012
    http://mozillagfx.wordpress.com/2013...opengl-layers/
    http://mozillagfx.wordpress.com/2012...d-compositing/
    http://kb.mozillazine.org/Breakpad


    Hope that helps! And it can happen that you're driver is making problems. Or Firefox crashes. But I have no problems.
    If so:
    instead of
    gfx.canvas.azure.backends = skia,cairo
    gfx.content.azure.backends = skia,cairo
    do:
    gfx.canvas.azure.backends = skia,cairo
    gfx.content.azure.backends = cairo

    PS: This is all yet on Firefox *26*!

  7. #27
    Join Date
    Dec 2009
    Posts
    334

    Default

    Quote Originally Posted by Vash63 View Post
    This is answered in the bug report that you quoted one post above this...
    Yep, they answered when I asked the same question there

  8. #28
    Join Date
    Jan 2011
    Posts
    84

    Default

    Quote Originally Posted by stqn View Post
    Firefox needs 8-10 s to start here, and can stop responding during 1-2 s repeatedly while loading heavy pages (with many pictures IIRC), which is really annoying. I have a 3.2*GHz Core i3 with plenty of free RAM, swap is unused, firefox cache is disabled, so there is no obvious reason for Firefox to be so slow. Do I have plenty of extensions? Sure! But I need themÖ

    I recently tried Chromium again but it stinks of Google marketing and is not usable as far as Iím concerned.
    Yeah that bothered me quite a bit (responsiveness of new tabs while loading) but I found a tweak that works beautifully. Just go to about:config and create 'content.switch.threshold' and give it a value of '1000000'.

  9. #29
    Join Date
    Jan 2014
    Posts
    29

    Default

    With this, it means that the Holly Nightly builds are no longer supported and I'm forced to use Australis. Shame.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •