Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Pre-3.0 Intel X.Org Driver Gets More Fixings

  1. #1
    Join Date
    Jan 2007
    Posts
    13,474

    Default Pre-3.0 Intel X.Org Driver Gets More Fixings

    Phoronix: Pre-3.0 Intel X.Org Driver Gets More Fixings

    Chris Wilson ended up releasing xf86-video-intel 2.99.908 today although he had hoped the previous release candidate would have been the last prior to the official xf86-video-intel 3.0 X.Org driver release...

    http://www.phoronix.com/vr.php?view=MTU4OTI

  2. #2
    Join Date
    Jul 2010
    Posts
    59

  3. #3
    Join Date
    Jul 2012
    Location
    SuperUserLand
    Posts
    526

    Default

    I fear these updates...

    back in march 2013 they had SNA working fine and fast on gen4... then it was regression after regression until icons, bars and fonts were all corrupted

    2:2.99.904-0 using this version right now and I gotta be honest and say that, apart from the occasional garbled font in firefox, everything is pretty much ok.

    I tried some other vers. and they seem so fixated and OCD on stamping that minor font glitch that they are willing to sacrifice performance.

    these thinkpads aren't getting any newer and you really shouldn't be so willing to sacrifice any performance
    Last edited by Pallidus; 02-01-2014 at 02:10 PM.

  4. #4
    Join Date
    Nov 2011
    Posts
    257

    Question

    Quote Originally Posted by Pallidus View Post
    I fear these updates...

    back in march 2013 they had SNA working fine and fast on gen4... then it was regression after regression until icons, bars and fonts were all corrupted

    2:2.99.904-0 using this version right now and I gotta be honest and say that, apart from the occasional garbled font in firefox, everything is pretty much ok.

    I tried some other vers. and they seem so fixated and OCD on stamping that minor font glitch that they are willing to sacrifice performance.

    these thinkpads aren't getting any newer and you really shouldn't be so willing to sacrifice any performance
    GM45 / gen4 on thinkpad here as well. Graphics tearing is all I've seen for the last 12 months. I can only go for the clutter disable culling + vblank workaround. Do you say I should downgrade? Is there any tutorial on how to proceed with this?

  5. #5
    Join Date
    Jul 2012
    Location
    SuperUserLand
    Posts
    526

    Default

    W500? I never experienced any graphics tearing in any version of the drivers, but I don't really use games or opengl.

    A quick google search for gm45 bugs mentions the font/icon glitches but I can't find anything about screen tearing... try reverting back to UXA and if tearing persists then you have an hardware failure

    for SNA I would say try this version> "2:2.99.904"

    905 or 906 I think is the one the scroll speed, overall performance, really suffers... I am yet to try this new one.

  6. #6
    Join Date
    Apr 2013
    Posts
    12

    Default

    Looks like 2.99.909 has already been released

    http://cgit.freedesktop.org/xorg/dri...l-2.99.909.zip

  7. #7
    Join Date
    Dec 2008
    Location
    San Bernardino, CA
    Posts
    225

    Default

    Same here.. nothing but corrupted buttons in Chromium on my Ivy Bridge (HD4000) for the past six months using SNA. Was forced to switch back to UXA.

  8. #8
    Join Date
    Nov 2011
    Posts
    257

    Default

    Quote Originally Posted by Pallidus View Post
    W500? I never experienced any graphics tearing in any version of the drivers, but I don't really use games or opengl.

    A quick google search for gm45 bugs mentions the font/icon glitches but I can't find anything about screen tearing... try reverting back to UXA and if tearing persists then you have an hardware failure

    for SNA I would say try this version> "2:2.99.904"

    905 or 906 I think is the one the scroll speed, overall performance, really suffers... I am yet to try this new one.
    T500.
    https://bugzilla.gnome.org/show_bug.cgi?id=711028
    No games. Just Gnome desktop.
    I tried both uxa and sna. Doesn't make a difference.
    Hardware failure ruled out.

  9. #9
    Join Date
    Jul 2012
    Location
    SuperUserLand
    Posts
    526

    Default

    that's really strange.... I can tell you that fedora 20 (gnome3 with uxa by default) is working perfectly here. slow but glitch free...

    there is g45 and g45hd I think, that could be it, not sure... I'm just surprised at the ammount of people who own these gfx chips, at least intel will be forced to look into this

  10. #10
    Join Date
    Jul 2012
    Location
    SuperUserLand
    Posts
    526

    Default

    I can't edit my previous post but I couldn't not say this:

    I've gotta eat my own words and give credit to where it's due...

    I've just upgraded to 2:2.99.907 and I hope they didn't change nothing in .909 because this is, without a doubt, THE BEST DIVER I'VE HAD ON THIS HERE THINKPAD.

    FUCKING HELL OF A GOOD JOB MAN, everything is butter smooth, sna is working flawlessly and I am yet to see a single garbled font on firefox.

    I may be known for trolling and bitching but for what it's worth I appreciate the hell out of this work

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •