Page 8 of 8 FirstFirst ... 678
Results 71 to 73 of 73

Thread: Gallium3D Direct3D 9 For Wine Revived, Again

  1. #71
    Join Date
    Nov 2010
    Posts
    342

    Default

    Quote Originally Posted by curaga View Post
    Certainly, but SGI graphics cards were made 6-7 years before the first consumer 3d cards such as the ones you listed. Saying that they are not graphics cards because of their target market is kind of weird, wouldn't you say?
    You're interpreting what I'm saying wrong. Not saying they're not graphic cards, just not something you can order off Newegg.com. When we deal with graphic cards, we deal with consumer cards like Radeons and Geforces. Those cards are purpose built for gaming, and only gaming. They also evolved with a lot of ID software games, specifically the Quake games up until Doom 3.

    My point is, that's how much gaming drives computing. You don't need a Quad core processor with a heavy duty graphics card to type documents and send Email. Not many people are doing graphics related work, or video encoding either.

  2. #72
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,024

    Default

    Quote Originally Posted by dffx View Post
    No reason I can see that it wouldn't, so long as it's using an up-to-date Mesa stack. As this state tracker looks to be Mesa 10 I would imagine that you would get everything you get from Mesa 10 (including all radeonsi improvements) plus the D3D9 st.
    Code:
    configure: error: LLVM 3.3 or newer is required for r600g and radeonsi.
    With --enable-gallium-llvm it builds, but...

    Code:
    /build/lib32-llvm-svn/src/llvm/include/llvm/Support/CommandLine.h:675: void llvm::cl::parser<DataType>::addLiteralOption(const char*, const DT&, const char*) [with DT = llvm::ScheduleDAGInstrs* (*)(llvm::MachineSchedContext*); DataType = llvm::ScheduleDAGInstrs* (*)(llvm::MachineSchedContext*)]: Assertion `findOption(Name) == Values.size() && "Option already exists!"' failed.

  3. #73
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,024

    Default

    Oh right, found this bugreport: http://llvm.org/bugs/show_bug.cgi?id=15410
    and had the idea to build with --with-llvm-shared-libs. It actually works with this.

    steam starts, skyrim starts, but skyrim is only black. I can resume the game and hear walking around, so I'm pretty sure it works, but it doesn't display anything, not even the gallium hud.

    I also tried unigine sanctuary and it shows the window with the Unigine written at the bottom, but the rest of the window is black too.

    I'm not sure of the reason: Either radeonsi doesn't work or it is because it is hybrid graphics and I'm running it with DRI_PRIME=1

    edit: Or that my wine is the git with csmt patches.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •