I have a laptop (Asus N55SF) with NVIDIA GT555M GPU, with Elementary OS installed (based on Ubuntu). I have Bumblebee installed, with NVIDIA drivers, which works. (optirun glxspheres has higher fps than just glxspheres)

When I connect a display to the VGA adapter, everything works fine. However, when I try to connect a HDMI device, nothing happens. The HDMI port works on Windows 7 and 8, so hardware failure can't be it.

The weird thing is, when I run xrandr, I get the following output:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192 LVDS1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm 1920x1080 60.0*+ 59.9
1680x1050 60.0 59.9
1600x1024 60.2
1400x1050 60.0
1280x1024 60.0
1440x900 59.9
1280x960 60.0
1360x768 59.8 60.0
1152x864 60.0
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)

There is no HDMI device listed using xrandr! I searched the web, tried some other drivers, but I really have no clue what to do next.

Someone who might know what the problem is here?