Results 1 to 5 of 5

Thread: having issues running Ubuntu on an Acer c720

  1. #1

    Default having issues running Ubuntu on an Acer c720

    I recently purchased an Acer c720 chrome book due to its low cost, long battery life and portaiility. I know its not a powerhouse but I don't intend to be playing games or anything incredibly graphically intensive, primarily just for finishing up work that would otherwise keep me at the office longer than I have any desire to be. My intention was to install linux and reading up on it it appeared that Ubuntu worked the best. I was able to put it into recovery, developer and seaBIOS, when I attempted to do an ubuntu install, it appeard to work correctly until it restarted to finalize the install. Upon restart it brings me to a Chrome screen stating the bios are not found and to insert a recovery flash drive. I was not able to use any of the key combinations specifically the "ctrl-L" to allow the legacy boot.

    Ok so to my question:
    Does anyone know if on the c720, there is a way to either auto boot from thumb drive when one is inserted or to successfully install an alternate OS. Specifically to run for example, ubuntu exclusively, I dont plan on using chrome at all.

    Any thoughts will be much appreciated.

    -Wanderer

  2. #2
    Join Date
    Jan 2013
    Posts
    966

    Default

    Helena, since "any thoughts appreciated", did you try to ask google about "chrome book ubuntu howto"?...
    Your issue might have been long solved.

  3. #3

    Default

    It wasn't that I couldn't install Ubuntu, it was more that it locked up on the chrome screen after reset. I was also not planning on running dual boot, as my hard drive is only the 16gb one. If it has to dual boot I will have to do that I guess. Thanks.

  4. #4
    Join Date
    Jan 2013
    Posts
    966

    Default

    Helena, from what I understand you have missed the step of enabling SeaBIOS payload of Coreboot.
    Please read here for details. Because chromebook's coreboot (there are three boot methods to date for x86: legacy bios, UEFI and Coreboot(the best)) loads chromeos as payload directly, one should either use ubuntu (or any linux distro) as coreboot payload, or install a seabios payload instead - a usual BIOS emulator, that will then scan for regular MBRs (as any BIOS does). Because you forgot to enable SeaBIOS, the system is not bootable as ChromeOS is gone replaced with MBR-structured Ubuntu, and Coreboot does not understand how to load this configuration.

    The recovery media should be created before you try to manipulate the OS,
    other method is to get a google recovery tool to run that will automatically download and burn the correct recovery image to the USB drive from the host OS of your choice (as far as I understand that). Here is the link with instructions.

    As such, I recommend you to create or get a recovery USB stick of your chromeos model, then proceed as described here.

    I wish you success.

  5. #5

    Default

    Ok, so my second attempt to install Ubuntu on the Acer C720 (2802 to be specific) was successful. On my first run I must have disabled the sea bios/developer mode after the restart. Thanks for your time Brosis!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •