Results 1 to 5 of 5

Thread: Cannot overclock card.

Hybrid View

  1. #1
    Join Date
    Apr 2009
    Posts
    9

    Unhappy Cannot overclock card.

    Hi!

    I'm trying to overlclock my ATI card which's mostly used for OpenCL applications.

    The following steps were taken --

    aticonfig --od-enable

    aticonfig --od-setclocks 960,1445

    aticonfig --od-commitclocks

    After a reboot this's the result --

    Default Adapter - AMD Radeon HD 6700 Series
    Core (MHz) Memory (MHz)
    Current Clocks : 850 1200
    Current Peak : 960 1445
    Configurable Peak Range : [850-960] [1200-1445]
    GPU load : 100%



    Regardless of how less I overclock I get the same results.

  2. #2
    Join Date
    Aug 2012
    Posts
    434

    Default

    I don't think those settings are saved in a manner that can be preserved across reboots. If you are using Ubuntu, for example, maybe you can try applying it in /etc/rc.local like

    Code:
    #!/bin/sh -e
    amdconfig --od-enable
    amdconfig --od-setclocks <core>,<memory>
    amdconfig --od-commitclocks
    
    exit 0
    When running those on my HD 7950 I get

    Code:
    AMD Overdrive(TM) enabled
    
    Default Adapter - AMD Radeon HD 7900 Series 
                      New Core Peak   : 1100
                      New Memory Peak : 1375
    Code:
    Default Adapter - AMD Radeon HD 7900 Series 
                                Core (MHz)    Memory (MHz)
               Current Clocks :    1100           1375
                 Current Peak :    1100           1375
      Configurable Peak Range : [300-1200]     [150-1575]
                     GPU load :    97%

  3. #3
    Join Date
    Apr 2009
    Posts
    9

    Default

    7950 works well in Linux?
    Code:
    AMD Overdrive(TM) enabled
    
    Default Adapter - AMD Radeon HD 7900 Series 
                      New Core Peak   : 1100
                      New Memory Peak : 1375
    Yeah, I get that too. Except for my clocks of course.

    I asked in the official forums also. Someone got any other way? Maybe a bug tracker?

    Running 13.11_beta6

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,540

    Default

    Try running the aticonfig commands before X is started (rather than from a terminal within X).

    I remember reading somewhere that the configuration settings get over-written when X shuts down, presumably to try and catch changes you made via something other than aticonfig.

    No promises but worth a try.

  5. #5
    Join Date
    Apr 2009
    Posts
    9

    Default

    Quote Originally Posted by bridgman View Post
    Try running the aticonfig commands before X is started (rather than from a terminal within X).

    I remember reading somewhere that the configuration settings get over-written when X shuts down, presumably to try and catch changes you made via something other than aticonfig.

    No promises but worth a try.
    Those overdrive commands require X to be running. That's why I've a multiseat setup in the 1st place.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •