Note that once the gstreamer 1.0 support is available in Firefox you'll need gstreamer-vaapi 0.5.3 or later, which is currently not available in any Ubuntu version.