Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: How have opengl 3.1 with Mesa 10.1?

  1. #11
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,332

    Default

    You also need to enable the patented float support in mesa, if you didn't.

  2. #12
    Join Date
    Jan 2013
    Posts
    1,116

    Default

    Quote Originally Posted by siavashserver View Post
    You are probably using an old mesa-demos package (which provides glxinfo). Make sure running latest version (8.1) to detect OpenGL 3.x support correctly.
    I am using 8.1.0, so that seems not to be the problem.


    You also need to enable the patented float support in mesa, if you didn't.
    Do you mean the --enable-texture-float option? I will give that a try.

  3. #13
    Join Date
    Jan 2013
    Posts
    1,116

    Default

    Compiled Mesa with the --enable-texture-float option and now this is what I get:
    Code:
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD BARTS
    OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.0.0
    OpenGL core profile shading language version string: 1.40
    OpenGL core profile context flags: (none)
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 10.0.0
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    Thanks for your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •