Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: DRI3 Support Merged Into Mesa 10.0

  1. #11
    Join Date
    Aug 2011


    Quote Originally Posted by Ericg View Post
    One thing that I would love the developers to clarify is... Drivers need support for DRI(X) but do Toolkits? Like do Qt or GTK need specific support for DRI3 or are things just going to automatically get better when Xorg 1.15 and Mesa 10 come out?
    Isn't this kind of stuff hidden behind the X API?

  2. #12
    Join Date
    Jul 2007

    Angry Mesa trunk now comprehensively broken in Fedora

    So I've just tried to Build Mesa on Fedora 19. First it complained about the missing dri3proto extension, and so I downloaded it from here:

    Then it complained about a missing presentproto extension, which I dutifully downloaded from here:

    And now it is complaining about:
    configure: error: Package requirements (x11 xext xdamage xfixes x11-xcb xcb-glx >= 1.8.1 xcb-dri2 >= 1.8 xcb-dri3 xcb-present xcb-sync xshmfence xxf86vm) were not met:
    No package 'xcb-dri3' found
    No package 'xcb-present' found
    No package 'xshmfence' found
    And so I've given up. So much for "backwards compatibility". How is anyone expected to perform a "git bisect" now, with the tree in this state?

  3. #13
    Join Date
    Jul 2007

    Red face Heh, looks like I'm not the only one with this problem!

    Quote Originally Posted by chrisr View Post
    So I've just tried to Build Mesa on Fedora 19...
    Somone has raised - and fixed - this as

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts