Results 1 to 2 of 2

Thread: Archlinux broken install -- advice requested for a fix

  1. #1
    Join Date
    Oct 2013
    Posts
    1

    Default Archlinux broken install -- advice requested for a fix

    Hello,

    I thought I'd see how my system does on the test suite, but the default package for arch leaves the test suite in a broken state. When I run "phoronix-test-suite" I get the following error message(s):

    PHP Warning: require(): open_basedir restriction in effect. File(/usr/share/phoronix-test-suite/pts-core/pts-core.php) is not within the allowed path(s): (/srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/) in /usr/share/phoronix-test-suite/pts-core/phoronix-test-suite.php on line 39
    PHP Warning: require(/usr/share/phoronix-test-suite/pts-core/pts-core.php): failed to open stream: Operation not permitted in /usr/share/phoronix-test-suite/pts-core/phoronix-test-suite.php on line 39
    PHP Fatal error: require(): Failed opening required '/usr/share/phoronix-test-suite/pts-core/pts-core.php' (include_path='.:/usr/share/pear') in /usr/share/phoronix-test-suite/pts-core/phoronix-test-suite.php on line 39

    How would I go about fixing this?

  2. #2

    Default

    The issue is covered by many other threads and in the documentation, etc. Arch's PHP package ships with a php.ini configuration file that uses the open_basedir restriction. You simply need to disable that from the php.ini configuration file and it will work. See the other threads or documentation for more details. The install itself is fine.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •