Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Kernel 3.11 + radeon.dpm=1 results in extremely slow performance

  1. #11
    Join Date
    Aug 2013
    Posts
    45

    Default

    Quote Originally Posted by AnonymousCoward View Post
    yes .
    Done, and it works.

    Wow, the open source driver is awesome! Now only if the power level switch is fixed! (I am stuck on power level 2. Its a known bug for dual screen setups). Well done open source devs!

    I have also turned on GLAMOR 2D acceleration but even without that everything feels so much smoother than catalyst! Flightgear shows the textures correctly!!! (that NEVER happened with catalyst)!! There is no more lag and spikes with firefox page scrolling, or the animations with gnome 3!

    Radeon opensource driver kicks the crapalyst drivers butt day and night and makes catalyst maintainers look very immature!
    Last edited by xtachx; 09-22-2013 at 05:52 PM.

  2. #12
    Join Date
    Jul 2013
    Posts
    1

    Default

    Quote Originally Posted by xtachx View Post
    Done, and it works.

    Wow, the open source driver is awesome! Now only if the power level switch is fixed! (I am stuck on power level 2. Its a known bug for dual screen setups). Well done open source devs!

    I have also turned on GLAMOR 2D acceleration but even without that everything feels so much smoother than catalyst! Flightgear shows the textures correctly!!! (that NEVER happened with catalyst)!! There is no more lag and spikes with firefox page scrolling, or the animations with gnome 3!

    Radeon opensource driver kicks the crapalyst drivers butt day and night and makes catalyst maintainers look very immature!
    Which desktop environment are you using on Fedora 19? I'm using KDE 4.11 along with kernel 3.11 and as soon as I'm logged in and the desktop loads, the screen shows bars and becomes unusable. Not sure if I'm doing something wrong or if it's a KDE bug.

    Also, how do you turn on GLAMOR 2D acceleration? I'm interested in getting every ounce of performance I can.

  3. #13
    Join Date
    Aug 2013
    Posts
    45

    Default

    Quote Originally Posted by dmaxel View Post
    Which desktop environment are you using on Fedora 19? I'm using KDE 4.11 along with kernel 3.11 and as soon as I'm logged in and the desktop loads, the screen shows bars and becomes unusable. Not sure if I'm doing something wrong or if it's a KDE bug.

    Also, how do you turn on GLAMOR 2D acceleration? I'm interested in getting every ounce of performance I can.
    Well, unfortunately I am back to catalyst because the fan speed is too loud. I will wait till that bug is fixed. The noise drives me crazy. However, once that is fixed, catalyst can be replaced with the opensource drivers. They are just as good for single screen setups.

    I am using Gnome 3.


    To turn on Glamor, add this to xorg.conf:

    Code:
     Option	"AccelMethod"           "glamor"
    However, you need to add the following section before the other one:

    Code:
    Section "Module"
    	Load "dri2"
    	Load "glamoregl" 
    EndSection

  4. #14
    Join Date
    Nov 2009
    Location
    Italy
    Posts
    932

    Default

    DON'T use glamor on kde, it's bugged: https://bugs.freedesktop.org/show_bug.cgi?id=69341

  5. #15
    Join Date
    Nov 2011
    Location
    Orange County, CA
    Posts
    77

    Default

    Quote Originally Posted by darkbasic View Post
    DON'T use glamor on kde, it's bugged: https://bugs.freedesktop.org/show_bug.cgi?id=69341
    It works fine for me with XRender/Native. There's only one minor glitch left: Window title bars aren't displayed 100% correctly with the default theme. But I needed the latest glamor patch, see https://bugs.freedesktop.org/show_bug.cgi?id=64912.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •