Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: How to contact MESA devs on some pesky performance bug?

  1. #11
    Join Date
    Nov 2011
    Posts
    280

  2. #12
    Join Date
    Nov 2011
    Posts
    280

    Default

    Still same. Gnome isolated as the culprit.
    https://bugs.freedesktop.org/show_bug.cgi?id=77372#c5

  3. #13
    Join Date
    Jul 2013
    Posts
    204

    Default

    I already explained what you need to do. Install Fedora 19 or 20 and downgrade Mesa to 9.1 and see if you still have a problem.

    Here is a step by step guide:
    ------------------------------------------------------------------
    Install git:
    $ yum install git

    Clone the Mesa repository:
    $ git clone git://anongit.freedesktop.org/mesa/mesa

    Chekout the 9.1 branch:
    $ git checkout 9.1

    You may need to install some build dependencies. I needed to install this:
    $ sudo yum-builddep mesa

    Rather than overwrite your distros Mesa install it is recommended you create a new directory. The one we will be using is /opt/xorg this way you can switch back to a stable version of Mesa.

    Configure and build Mesa
    $ ./autogen.sh --prefix=/opt/xorg --enable-texture-float --with-dri-drivers="i965" --with-llvm-shared-libs --enable-debug --with-gallium-drivers=""
    $ make

    Install Mesa to the new directory you have created:
    $ make install

    Now configure your system to use the 9.1 version of Mesa you just built:

    First create a new text file:
    $ sudo gedit /etc/ld.so.conf.d/a-local-xorg.conf

    Add your mesa direcory (the line below) to the text file and save it:
    /opt/xorg/lib

    Then update /etc/environment to add new environment variable that tells libgl where to look for dri driver:
    $ sudo gedit /etc/environment

    Add the following line:
    LIBGL_DRIVERS_PATH=/opt/xorg/lib/dri/

    Then run ldconfig as root to update the linker cache to point to the version of mesa you just built.
    $ sudo ldconfig

    You can then check the version of Mesa using glxinfo
    $ glxinfo

    Now it it says you are using Mesa 9.1 restart your computer and tell us if you still see the issue with Gnome.
    --------------------------------------------------------------------------------------------------------------------------------------------------------------

    To switch back to the default version of Mesa just delete /etc/ld.so.conf.d/a-local-xorg.conf
    $ sudo rm /etc/ld.so.conf.d/a-local-xorg.conf

    and remove the line you added to the environment file and rerun ldconfig as root

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •