Results 1 to 5 of 5

Thread: WebKitGTK+ 2.1.91 Supports Wayland As A Target

  1. #1
    Join Date
    Jan 2007
    Posts
    15,649

    Default WebKitGTK+ 2.1.91 Supports Wayland As A Target

    Phoronix: WebKitGTK+ 2.1.91 Supports Wayland As A Target

    WebKitGTK+ 2.1.91 was released earlier this week by Igalia and among its changes include support for building this GNOME port of the WebKit rendering engine with Wayland as a target...

    http://www.phoronix.com/vr.php?view=MTQ2MjY

  2. #2
    Join Date
    Jul 2012
    Posts
    830

    Default

    Nice I hope this clears up some of the applications that are reported as "Crashes on Start" with Note "WebKit".
    https://wiki.gnome.org/Wayland/Applications

  3. #3
    Join Date
    Feb 2013
    Posts
    89

    Default

    Quote Originally Posted by blackout23 View Post
    Nice I hope this clears up some of the applications that are reported as "Crashes on Start" with Note "WebKit".
    https://wiki.gnome.org/Wayland/Applications
    Empathy and Evolution worked on Weston X11 backend, while only Evolution worked on DRM backend but Empathy failed with some scary error message.

    Epiphany, Devhelp and Yelp don't work at all for me.

  4. #4
    Join Date
    Jul 2012
    Posts
    287

    Default

    Quote Originally Posted by Krejzi View Post
    Empathy and Evolution worked on Weston X11 backend, while only Evolution worked on DRM backend but Empathy failed with some scary error message.

    Epiphany, Devhelp and Yelp don't work at all for me.
    Clutter things need an environment variable to be set at the moment. Did you try those Webkit using applications using this version of webkit with Wayland enabled?

  5. #5
    Join Date
    Feb 2013
    Posts
    89

    Default

    Quote Originally Posted by bkor View Post
    Clutter things need an environment variable to be set at the moment. Did you try those Webkit using applications using this version of webkit with Wayland enabled?
    It's WebKit *GTK+*, it doesn't use Clutter. I found the problem. I've managed to fix Epiphany, Yelp and Devhelp. Empathy has hidden X11 deps which need to be sorted out.

    Long story short, you have to disable accelerated compositing with a configure switch, but that is fixed and in svn for 2.1.92 release. Yelp had some hidden X11 deps too, but it was easy to patch it.

    On the other hand, Rhythmbox is listed as working on the wiki page, but I can't get it to work at all.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •