I've only discovered this because of an ALSA bug was making my life miserable. That article was written about a month or two before before OSS4 (Open Sound System v4) was released under GPL and CDDL. This past January, it was released under BSD as well. Unfortunately for the author, he does not understand open source very well. He is now reporting that his revenue went significantly down..

OSS4 does not equal to the crap OSS in Linux 2.4 kernels. Even OSS3 != OSS3 in linux former linux kernels. He was neglecting the open source version in favour of the commercial one. Instead of improving it, someone forked it. And, the fork became popular. Unfortunately, the original author had no interest in working on the fork. So, he only focused on the commercial version. Now, many years later, the commercial version is fully open source. There is no more commercial version.

I've tried it, and I really like it. Music sounds much better than on ALSA. For example, screaming in alternative rock is more legible. It's like enabling enhanced voice on a phone. It supports higher PCM values without noise.

The mixer is capable of 18 channels. It can also do per application volume control (like PulseAudio).

It totally make sense that it gets back into the kernel because it works on almost every UNIX and UNIX-like, except OS X. ALSA only works on Linux, and according to that article, developers still prefer the OSS API, even on ALSA. However, the ALSA OSS API is lacking according to an ALSA developer.

It worked without any configuration besides muting some channels to kill the noise. The ALSA bug I experienced was fixed in version 1.0.16. So, now I'm back on ALSA for the following reasons.

ossmix and ossxmix are totally unusable because they do not name the channels properly.
I had to figure out WTF ossxmix.codec1.connector.jack14.jack 54:54 means.
It's best to use ossxmix (GTK+ mixer) and playing with all the jacks to figure out what each one does. ossxmix also uses 100CPU for some reason.
One interesting control is how OSS4 should behave (Fast, Proessional, etc.). It's probably a latency control. ossxmix is a demo app on how you can control the mixer from GTK. It needs to be made usable.

If you only use Media Player Daemon and MPlayer, OSS4 works beautifully. They use OSS directly. Others have problems.
Xine uses 100% CPU. If you try to seek, it freezes. In terminal I noticed some output from oss mixer control saying it received bad arguments. OSS4 is backwards compatible with OSS3, but xine-lib seems to be using the API badly.

The progress bar (seeker) in GStreamer based applications (Rhythmbox, Banshee) does not work. Sound in Totem does not seem to work at all. The gStreamer developer responsible for OSS claims that it does on his system. I have noticed this after I have applied this patched gstreamer to make volume control in GNOME work.

Gentoo ebuild
Arch Linux (Read Wiki)[/url]

Check Configuring Applications for OSSv4 after you install it. I just found it. So, I did not do what it said for xine. Maybe, it does not use 100% CPU with those settings. I also did not do what it says to do for MPlayer, but it worked with no problems as I mentioned above.

Overall, I think it's a million times better than ALSA. It's cross platform, and it's stable. It was released a year ago on 15th of March 2007. Since he does not have a marketing department, no one has heard of it.