Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: AMD Catalyst 13.8 Beta

  1. #1

    Default AMD Catalyst 13.8 Beta

    Here it is:

    http://support.amd.com/us/kbarticles...etaDriver.aspx
    It also supports kernel 3.10 OOTB. Finally.

    Now, i installed it and i have some permission issues - if i run anything as my regular user, i cant use all OpenGl functions, i assume i have only the Mesa 2.1 support. But if i run as root, everything seems to be working.

    For example, running fglrxinfo as user:

    Code:
    $ fglrxinfo
    Setting of real/effective user Id to 0/0 failed
    libGL error: open uki failed (Operation not permitted)
    libGL error: reverting to (slow) indirect rendering
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: AMD Radeon HD 7560D
    OpenGL version string: 2.1 (4.3.12438 Compatibility Profile Context 13.20.5)
    running it as root:

    Code:
    $ sudo fglrxinfo
    display: :0.0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon HD 7560D
    OpenGL version string: 4.3.12438 Compatibility Profile Context 13.20.5
    Same with games - slow as hell as user, fine as root.
    Previously i had the 13.6 installed, all was fine.
    I am part of the video group. Restarted countless times, reinstalled driver.
    xorg.conf is the default created.

    What should i check?

  2. #2
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    969

    Default

    Ah, so it's not related to bumblebee.

    This is the same problem: http://phoronix.com/forums/showthrea...984#post347984

  3. #3

    Default

    Definitely not - i have a desktop A8-5500.
    I now reinstall the 13.6 see if the issue persists.

    BTW i noticed that in the xorg logs the driver version was 13.20.4 whereas the OpenGl string is
    OpenGL version string: 4.3.12438 Compatibility Profile Context 13.20.5
    Maybe its not important.
    Last edited by gradinaruvasile; 08-01-2013 at 05:57 PM.

  4. #4

    Default

    So, back with 13.6.

    As user:
    Code:
    $ glxgears -info
    GL_RENDERER   = AMD Radeon HD 7560D
    GL_VERSION    = 4.2.12337 Compatibility Profile Context 13.101
    GL_VENDOR     = ATI Technologies Inc.
    Its definitely something wrong with the 13.8 version.

  5. #5
    Join Date
    Aug 2013
    Posts
    40

    Default

    Like the other thread, can you try:

    Code:
    chmod -R 777 /proc/ati
    and see if this improves the thing? I havent tested it yet, but will go home and test it today.

  6. #6

    Default

    So, is this permission issue specifically restricted to the 3.10 kernel and/or architecture?

    I have Debian Testing with kernel 3.10.4 64-bit, AMD 7560D IGP on A8-5500 APU.

  7. #7
    Join Date
    Aug 2013
    Posts
    40

    Default Solved

    I can confirm that the problem is solved by changing the /proc/ati permissions.

    Code:
    chmod -R 777 /proc/ati/

    On another note, the driver fixed no issues from the previous one. In flightgear, the clouds are still black! (Wasnt so in beta3)

  8. #8
    Join Date
    Sep 2009
    Posts
    173

    Default

    Quote Originally Posted by xtachx View Post
    I can confirm that the problem is solved by changing the /proc/ati permissions.

    Code:
    chmod -R 777 /proc/ati/

    On another note, the driver fixed no issues from the previous one. In flightgear, the clouds are still black! (Wasnt so in beta3)
    Well, thanks very much for that fix. I was having the same problem running kernel 3.10.5 and Catalyst 13.8 beta.

  9. #9
    Join Date
    Oct 2010
    Location
    Amsterdam
    Posts
    287

    Default

    OpenSUSE 12.3 64 bit Catalyst 13.8

    As user

    Code:
    XXXX@linux-n2go:~> fglrxinfo
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: ATI Radeon HD 5700 Series 
    OpenGL version string: 4.3.12438 Compatibility Profile Context 13.20.5
    $ fglrxinfo is something openSUSE does not understand

    sudu fgrlxinfo

    Code:
    XXXX@linux-n2go:~> sudo fglrxinfo
    root's password:
    Error: unable to open display (null)

  10. #10
    Join Date
    Aug 2013
    Posts
    2

    Default Same Here

    Quote Originally Posted by Gps4l View Post
    OpenSUSE 12.3 64 bit Catalyst 13.8

    As user

    Code:
    XXXX@linux-n2go:~> fglrxinfo
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: ATI Radeon HD 5700 Series 
    OpenGL version string: 4.3.12438 Compatibility Profile Context 13.20.5
    $ fglrxinfo is something openSUSE does not understand

    sudu fgrlxinfo

    Code:
    XXXX@linux-n2go:~> sudo fglrxinfo
    root's password:
    Error: unable to open display (null)
    Code:
    michal@linux-85f9:~> fglrxinfo
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon HD 7660D
    OpenGL version string: 4.3.12438 Compatibility Profile Context 13.20.5
    
    michal@linux-85f9:~> sudo fglrxinfo
    Error: unable to open display (null)
    [/QUOTE]

    As you can see i have same problem on my 12.3 64bit, the fact that its my first day on opensuse is not helping. (13.8 worked just fine on Mint 15 kernel3.8)

    Code:
    OpenGL GLX Context is not using direct rendering, which may cause performance problems.
    [/QUOTE]

    Message i get while launching steam.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •