Results 1 to 10 of 11

Thread: How to get dpm, accel, sb back end, working on Ubu 13.04 (ppa preferably..)

Hybrid View

  1. #1
    Join Date
    Sep 2010
    Posts
    701

    Default How to get dpm, accel, sb back end, working on Ubu 13.04 (ppa preferably..)

    How to easily test all those new changes in r600g? (video acceleration, dpm, sb, etc.)

    On Ubu 13.04, perferably with just ppa's (installing from source is not fun )?

    And if there are no such ready. Then could someone provide me with list of things I must remember when configuring at compile time to get all those bells working?

    (I have 5730m)
    Last edited by przemoli; 07-27-2013 at 06:25 AM.

  2. #2
    Join Date
    Sep 2010
    Posts
    701

    Default

    I will partially replay to myself:

    SB backend seam to be merged, and can be turned on by R600_DEBUG=sb. (Require Mesa 9.2, LLVM back end if I want it also)

    DPM require kernel 3.11 or higher + updated firmware for gpus.

    UVD require kernel 3.10, vdpau, firmware, and mesa compilation config.

    (Will remove fglrx now, and test if its clean removal)

  3. #3
    Join Date
    Sep 2010
    Posts
    701

    Default

    Here is some nice how to, about removing fglrx, that works just fine:

    http://askubuntu.com/questions/68306...ry-ati-drivers

    (Now, daily ubuntu kernel for 3.11)
    (Since articles at phoronix use Ubu 13.10 as base, I will upgrade to 13.10 too)
    Last edited by przemoli; 07-27-2013 at 08:14 AM.

  4. #4
    Join Date
    Sep 2010
    Posts
    701

    Default

    Ubu 13.10, with kernel 3.10, Mesa 9.1, and no vdpau, no dpm, and I have no idea how to check if SB back end is enabled (last resort solution would be to get PTS just to check if sb works ).

    (Now time to update to 3.11 kernel since I will need it anyway)
    Last edited by przemoli; 07-27-2013 at 10:01 AM.

  5. #5
    Join Date
    Sep 2010
    Posts
    701

    Default

    3.11 rc2 installed from ubuntu mainland kernel "ppa"...

    And radeon acceleration is disabled, falback to llvm. (Which works , fast enough for normal work, like editing this message)
    dmesg indicate that I have some missing firmware.

    (That may be DPM firmware so I will install it from here next)
    PS Firmware should land in /lib/firmware/radeon ..
    Last edited by przemoli; 07-27-2013 at 10:06 AM.

  6. #6
    Join Date
    Sep 2010
    Posts
    701

    Default

    With firmware, I have r600g working again.

    DPM should be easiest to set (and check if it works):
    I just add radeon.dpm=1 to grub linux line.
    And veryfied with cat /sys/class/drm/card0/device/power_method.

    And here are some info about sysfs entires for setting/reading dpm state.

    (Now Mesa 9.2 and SB back end, courtesy of xorg-edgers if they support SB back end..)
    Last edited by przemoli; 07-27-2013 at 11:01 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •