Results 1 to 4 of 4

Thread: Can't run most graphics tests (multiple monitor)

  1. #1
    Join Date
    Jul 2013
    Posts
    15

    Default Can't run most graphics tests (multiple monitor)

    Most of the graphics tests I've tried (eg nexuiz) won't run.

    The benchmark kicks off, I get a splash screen (distributed across 2 monitors in a multi-monitor setup) and then "The test run ended prematurely"

    This is almost certainly related to the multiple monitor setup. There needs to be an option somewhere to tell the benchmark to run on a specific screen rather than trying to span multiple monitors.

    Code:
    $ phoronix-test-suite detailed-system-info
    
    Phoronix Test Suite v4.6.1
    System Information
    
    Hardware:
    Processor: AMD Phenom II X4 940 @ 3.00GHz (4 Cores), Motherboard: Gigabyte GA-MA780G-UD3H, Chipset: AMD RS780 + SB7x0/SB8x0/SB9x0, Memory: 8192MB, Disk: 2 x 1000GB Western Digital WD1001FALS-0 + 3001GB Seagate ST3000DM001-9YN1 + 3001GB Seagate ST3000DM001-1CH1, Graphics: AMD Radeon HD 7800 2048MB (1000/1200MHz), Audio: Realtek ALC889A, Monitor: P244W, Network: Realtek RTL8111/8168B
    
    Software:
    OS: Ubuntu 12.04, Kernel: 3.2.0-48-generic-pae (i686), Desktop: GNOME 3.2.1, Display Server: X Server 1.11.3, Display Driver: fglrx 13.10.10, OpenGL: 4.2.12337, Compiler: GCC 4.6, File-System: ext4, Screen Resolution: 1920x1080
    
    
    PROCESSOR:
    
    Core Count: 4
    Thread Count: 4
    Cache Size: 512 KB
    Instruction Set Extensions: SSE 4a
    AES Encryption: NO
    Energy Performance Bias: NO
    Virtualization: AMD-V
    Compiler Configuration: --build=i686-linux-gnu --disable-werror --enable-checking=release --enable-clocale=gnu --enable-gnu-unique-object --enable-languages=c,c++,fortran,objc,obj-c++ --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-nls --enable-objc-gc --enable-plugin --enable-shared --enable-targets=all --enable-threads=posix --host=i686-linux-gnu --target=i686-linux-gnu --with-arch-32=i686 --with-tune=generic -v
    Disk Mount Options: barrier=1,data=ordered,relatime,rw,user_xattr
    Cpu Scaling Governor: powernow-k8 ondemand
    How do I make this work?

  2. #2

    Default

    Quote Originally Posted by RecceDG View Post
    Most of the graphics tests I've tried (eg nexuiz) won't run.

    The benchmark kicks off, I get a splash screen (distributed across 2 monitors in a multi-monitor setup) and then "The test run ended prematurely"

    This is almost certainly related to the multiple monitor setup. There needs to be an option somewhere to tell the benchmark to run on a specific screen rather than trying to span multiple monitors.

    Code:
    $ phoronix-test-suite detailed-system-info
    
    Phoronix Test Suite v4.6.1
    System Information
    
    Hardware:
    Processor: AMD Phenom II X4 940 @ 3.00GHz (4 Cores), Motherboard: Gigabyte GA-MA780G-UD3H, Chipset: AMD RS780 + SB7x0/SB8x0/SB9x0, Memory: 8192MB, Disk: 2 x 1000GB Western Digital WD1001FALS-0 + 3001GB Seagate ST3000DM001-9YN1 + 3001GB Seagate ST3000DM001-1CH1, Graphics: AMD Radeon HD 7800 2048MB (1000/1200MHz), Audio: Realtek ALC889A, Monitor: P244W, Network: Realtek RTL8111/8168B
    
    Software:
    OS: Ubuntu 12.04, Kernel: 3.2.0-48-generic-pae (i686), Desktop: GNOME 3.2.1, Display Server: X Server 1.11.3, Display Driver: fglrx 13.10.10, OpenGL: 4.2.12337, Compiler: GCC 4.6, File-System: ext4, Screen Resolution: 1920x1080
    
    
    PROCESSOR:
    
    Core Count: 4
    Thread Count: 4
    Cache Size: 512 KB
    Instruction Set Extensions: SSE 4a
    AES Encryption: NO
    Energy Performance Bias: NO
    Virtualization: AMD-V
    Compiler Configuration: --build=i686-linux-gnu --disable-werror --enable-checking=release --enable-clocale=gnu --enable-gnu-unique-object --enable-languages=c,c++,fortran,objc,obj-c++ --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-nls --enable-objc-gc --enable-plugin --enable-shared --enable-targets=all --enable-threads=posix --host=i686-linux-gnu --target=i686-linux-gnu --with-arch-32=i686 --with-tune=generic -v
    Disk Mount Options: barrier=1,data=ordered,relatime,rw,user_xattr
    Cpu Scaling Governor: powernow-k8 ondemand
    How do I make this work?
    Sounds like it's some awkward graphics driver bug with your Catalyst setup and/or hardware combination. I've run PTS tests multiple times and they have always work as intended. What graphics tests specifically are you trying?

  3. #3
    Join Date
    Jul 2013
    Posts
    15

    Default

    Code:
    Nexuiz 2.5.2:
        pts/nexuiz-1.6.1 [Resolution: 1920 x 1080 - HDR: Yes - Sound: Off]
        Test 1 of 1
        Estimated Trial Run Count:    3
        Estimated Time To Completion: 3 Minutes
            Started Run 1 @ 09:05:16
            The test run ended prematurely.
            Started Run 2 @ 09:05:19
            The test run ended prematurely.
            Started Run 3 @ 09:05:22
            The test run ended prematurely.
    
        Test Results:
    
        Average: 0 Frames Per Second
        This test failed to run properly.
    
    
    The following tests failed to properly run:
    
    	- pts/nexuiz-1.6.1: Resolution: 1920 x 1080 - HDR: Yes - Sound: Off
    The Quake4 test and at least one other does this.

    Oddly, the ut2004 benchmark works as expected.

    Multiple monitors. Leftmost monitor is rotated to portrait via AMD Control Center

  4. #4
    Join Date
    Jul 2013
    Posts
    15

    Default

    No other responses?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •