Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 47

Thread: AMD Catalyst 13.6 Linux Graphics Driver Beta Released

  1. #31
    Join Date
    Jun 2012
    Location
    Kraków, Polska
    Posts
    44

    Default

    Quote Originally Posted by PsynoKhi0 View Post
    Sounds like a typical vsync problem, have you made sure it's disabled in-game and in CCC? (also did you delete /etc/ati/amdpcsdb with Xorg shut down before upgrading?)

    No such issue here, although FPS tank in WINE with vsync on.

    (I've also noticed that I can't click on buttons in TF2's menu, actually I can only navigate with the arrow keys, but then again a quick googling points towards a TF2/old code bug.)
    No it is not. Always before the installation new one I uninstalled older one by sudo dpkg -P ... so there is no chance to have the configuration files associated with this packages in /etc. This is not a matter of vsync ... how could I have vsync enabled and such that showed me Xonotic 270 FPS [60 Hz monitor refresh] ... maximum standard on E-350 it was 120 [all effects except AA turned on to maximum and I've got full liquidity - here is 'my kernel' - line Brazos - specially optimized for the newer AMD - config level and already in the process of compilation]. By the way, builds four lines of kernels: K8, atom, i7 and Brazos - look in goggles: ext73, NeteXt'73 and my youtube channel: ext73.
    Last edited by ext73; 05-30-2013 at 06:52 AM.

  2. #32
    Join Date
    Feb 2010
    Posts
    519

    Default

    Quote Originally Posted by ext73 View Post
    how could I have vsync enabled and such that showed me Xonotic 270 FPS [60 Hz monitor refresh]
    How could I know that from the info you provided in your previous pst?
    Has the bug been reported yet? I did a seearch for "mouse", "input" and "delay" on the Bugzilla and nothing turned up.

  3. #33
    Join Date
    Mar 2011
    Posts
    92

    Default

    Anyone had any luck with compiling against kernel 3.10?

    Patches for 3.9 & 3.10 are not enough as compile fails with an error

    any hints?

  4. #34
    Join Date
    Nov 2008
    Location
    Old Europe
    Posts
    917

    Default

    This is a truly great release for me!

    An annoying bug I filed has been finally fixed*.
    http://ati.cchtml.com/show_bug.cgi?id=733

    Thank you!

    [*] There is a slight chance the bug has simply gone with XServer 1.14,
    but I don't think so as the issue was not present with XServer 1.13 with intel IGPs.
    So I can't tell for sure if it has been actively fixed.
    Anyhow, great to see it's gone.

  5. #35
    Join Date
    Oct 2012
    Posts
    106

    Default Sleep Broken

    Just updated to the beta drivers (w/ Xorg 1.14 finally) in Arch Linux (using the catalyst-test package), and sleep is now totally broken for me in KDE. Basically, if I close my laptop lid, it goes into sleep mode, but when I open it again, I just get a blank back lit screen. Didn't happen with any of the previous drivers...

  6. #36
    Join Date
    Dec 2009
    Posts
    49

    Default

    Quote Originally Posted by ryszardzonk View Post
    Anyone had any luck with compiling against kernel 3.10?

    Patches for 3.9 & 3.10 are not enough as compile fails with an error

    any hints?
    ATM on Arch we are using the patch for kernel 3.10 made by kolasa: https://github.com/kolasa

    Due to changes in kernel 3.10 (like removed create_proc_entry) this patch is only a workaround that will let You to build fglrx module successfully (proper procfs handling should be provided by AMD).

    Here's the link to the original patch for catalyst 13.4: http://catalyst.wirephire.com/files/...lrx_3.10.patch

    If you need a patch for catalyst 13.6 then here's my trivially modified version: http://catalyst.wirephire.com/files/...nux_3.10.patch

  7. #37
    Join Date
    Mar 2011
    Posts
    92

    Default

    Quote Originally Posted by Vi0L0 View Post
    If you need a patch for catalyst 13.6 then here's my trivially modified version: http://catalyst.wirephire.com/files/...nux_3.10.patch
    Working great here too. Thanks!

  8. #38
    Join Date
    Jun 2012
    Location
    Kraków, Polska
    Posts
    44

    Default

    Quote Originally Posted by PsynoKhi0 View Post
    How could I know that from the info you provided in your previous pst?
    Has the bug been reported yet? I did a seearch for "mouse", "input" and "delay" on the Bugzilla and nothing turned up.
    I have not reported this bug yet, but you can see I'll have to do it :P

  9. #39
    Join Date
    May 2013
    Posts
    5

    Default

    Quote Originally Posted by ext73 View Post
    Only it is not a matter of the compositor ... I use KDE, and here both in 3d for fullscreen windows and not ... is the same ... at 13.3 beta3 is ideally ... with the beta2 13.3, 13.4 and 13.6 beta are such problems.
    I had this problem on debian but not slackware. On debian I fixed it by editing the /etc/default/grub file so the GRUB_CMDLINE_LINUX_DEFAULT line looked like this...

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet vga=792 radeon.modeset=0 nomodeset"
    "nomodeset radeon.modeset=0 vga=792" was added by me.

    Then run "sudo update-grub" and reboot.

  10. #40
    Join Date
    Jun 2012
    Location
    Kraków, Polska
    Posts
    44

    Default

    Quote Originally Posted by shazeal View Post
    I had this problem on debian but not slackware. On debian I fixed it by editing the /etc/default/grub file so the GRUB_CMDLINE_LINUX_DEFAULT line looked like this...

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet vga=792 radeon.modeset=0 nomodeset"
    "nomodeset radeon.modeset=0 vga=792" was added by me.

    Then run "sudo update-grub" and reboot.
    Unfortunately this does not work - at least in my case. This is obviously a mistake OpenGL driver - who appeared in the driver version 13.3 beta 2 - and then fixed in 13.3 beat3 and again has been "intensified" in 13.4 and 13.6 beta

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •