Page 1 of 2 12 LastLast
Results 1 to 10 of 21

Thread: Sound Blaster Z No sound

Hybrid View

  1. #1
    Join Date
    Jan 2012
    Location
    New Jersey
    Posts
    35

    Unhappy Sound Blaster Z No sound

    Well I have tried just about everything that I can think of including http://phoronix.com/forums/showthrea...106#post328106

    Code:
     Module                  Size  Used by
    snd_hda_codec_ca0132    25545  1 
    snd_hda_intel          31845  4 
    snd_seq_midi            5168  0 
    snd_hda_codec_hdmi     28594  1 
    nvidia               9364961  38 
    snd_usb_audio         111272  2 
    snd_usbmidi_lib        18764  1 snd_usb_audio
    snd_hwdep               6196  1 snd_usb_audio
    snd_rawmidi            18710  2 snd_usbmidi_lib,snd_seq_midi
    snd_hda_codec         128553  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_ca0132
    Code:
    dmesg | grep hda
    [    7.364195] hda_intel: Disabling MSI
    [    7.616018] snd_hda_intel 0000:07:00.0: enabling device (0000 -> 0002)
    [    7.616062] hda_intel: Disabling MSI
    [    7.616064] hda-intel 0000:07:00.0: Force to non-snoop mode
    [   20.686755] hda_intel: Disabling MSI
    [   20.866764] hda_intel: Disabling MSI
    [   20.866768] hda-intel 0000:07:00.0: Force to non-snoop mode
    Code:
    aplay -L
    hdmi:CARD=NVidia,DEV=0
        HDA NVidia, HDMI 0
        HDMI Audio Output
    hdmi:CARD=NVidia,DEV=1
        HDA NVidia, HDMI 1
        HDMI Audio Output
    hdmi:CARD=NVidia,DEV=2
        HDA NVidia, HDMI 2
        HDMI Audio Output
    hdmi:CARD=NVidia,DEV=3
        HDA NVidia, HDMI 3
        HDMI Audio Output
    sysdefault:CARD=Headset
        Turtle Beach PX21 Headset, USB Audio
        Default Audio Device
    front:CARD=Headset,DEV=0
        Turtle Beach PX21 Headset, USB Audio
        Front speakers
    surround40:CARD=Headset,DEV=0
        Turtle Beach PX21 Headset, USB Audio
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=Headset,DEV=0
        Turtle Beach PX21 Headset, USB Audio
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=Headset,DEV=0
        Turtle Beach PX21 Headset, USB Audio
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=Headset,DEV=0
        Turtle Beach PX21 Headset, USB Audio
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=Headset,DEV=0
        Turtle Beach PX21 Headset, USB Audio
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=Headset,DEV=0
        Turtle Beach PX21 Headset, USB Audio
        IEC958 (S/PDIF) Digital Audio Output
    sysdefault:CARD=Creative
        HDA Creative, CA0132 Analog
        Default Audio Device
    front:CARD=Creative,DEV=0
        HDA Creative, CA0132 Analog
        Front speakers
    surround40:CARD=Creative,DEV=0
        HDA Creative, CA0132 Analog
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=Creative,DEV=0
        HDA Creative, CA0132 Analog
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=Creative,DEV=0
        HDA Creative, CA0132 Analog
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=Creative,DEV=0
        HDA Creative, CA0132 Analog
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=Creative,DEV=0
        HDA Creative, CA0132 Analog
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=Creative,DEV=0
        HDA Creative, CA0132 Digital
        IEC958 (S/PDIF) Digital Audio Output
    I've built the drivers into the kernel rather than modules, I've also tried to just building support for ca0132 and excluding the hdmi and usb sound drivers. I also merged in the external firmware which is built into the kernel ( ctefx.bin ctspeq.bin)

    I've tried numerous of things over the past few days, I simply can't get this thing to produce some sound lol

    Gentoo amd64

    lspci output:
    Code:
    00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (external gfx0 port B) (rev 02)
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (external gfx0 port B)
    00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD/ATI] RD990 I/O Memory Management Unit (IOMMU)
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] RD990 I/O Memory Management Unit (IOMMU)
    00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port B)
            Kernel driver in use: pcieport
    00:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port D)
            Kernel driver in use: pcieport
    00:05.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port E)
            Kernel driver in use: pcieport
    00:06.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port F)
            Kernel driver in use: pcieport
    00:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port G)
            Kernel driver in use: pcieport
    00:09.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port H)
            Kernel driver in use: pcieport
    00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (external gfx1 port A)
            Kernel driver in use: pcieport
    00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] (rev 40)
            Subsystem: ASUSTeK Computer Inc. Device 84dd
            Kernel driver in use: ahci
    00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
            Kernel driver in use: ohci_hcd
    00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
            Kernel driver in use: ehci-pci
    00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
            Kernel driver in use: ohci_hcd
    00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
            Kernel driver in use: ehci-pci
    00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 42)
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller
    00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
    00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (rev 40)
    00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
            Kernel driver in use: ohci_hcd
    00:16.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
            Kernel driver in use: ohci_hcd
    00:16.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
            Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
            Kernel driver in use: ehci-pci
    00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 0
    00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 1
    00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 2
    00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 3
            Kernel driver in use: k10temp
    00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4
            Kernel driver in use: fam15h_power
    00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5
    01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 660 Ti] (rev a1)
            Subsystem: eVga.com. Corp. Device 3668
            Kernel driver in use: nvidia
            Kernel modules: nvidia
    01:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)
            Subsystem: eVga.com. Corp. Device 3668
            Kernel driver in use: snd_hda_intel
            Kernel modules: snd_hda_intel
    02:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01)
            Subsystem: ASUSTeK Computer Inc. Device 84b7
            Kernel driver in use: ahci
    03:00.0 Ethernet controller: Intel Corporation 82583V Gigabit Network Connection
            Subsystem: ASUSTeK Computer Inc. Device 8457
            Kernel driver in use: e1000e
    04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
            Subsystem: ASUSTeK Computer Inc. Device 8488
            Kernel driver in use: xhci_hcd
    05:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
            Subsystem: ASUSTeK Computer Inc. Device 8488
            Kernel driver in use: xhci_hcd
    06:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
            Subsystem: ASUSTeK Computer Inc. Device 8488
            Kernel driver in use: xhci_hcd
    07:00.0 Audio device: Creative Labs Device 0012 (rev 01)
            Subsystem: Creative Labs Device 0023
            Kernel driver in use: snd_hda_intel
            Kernel modules: snd_hda_intel
    Any help on this would be greatly appreciated

  2. #2
    Join Date
    May 2010
    Posts
    89

    Default

    The card is non functional on linux for now.Better thing to do is to report the bug to https://bugzilla.kernel.org/show_bug.cgi?id=55541

  3. #3
    Join Date
    Jan 2012
    Location
    New Jersey
    Posts
    35

    Default

    Quote Originally Posted by narciso View Post
    The card is non functional on linux for now.Better thing to do is to report the bug to https://bugzilla.kernel.org/show_bug.cgi?id=55541
    Thanks just added my report and myself to the cc list.

  4. #4
    Join Date
    Jan 2012
    Location
    New Jersey
    Posts
    35

    Angry Update

    Still nothing months later Creative Continues to Ignore the Linux community.

    Do not buy any of the Blaster Z series cards or the Recon3D cards you will not have any sound in Linux with these devices. I have been trying hard to pull the community together to get this resolved but it has been slow going , as far as Creative they've been silent through out this whole ordeal so the open source community is trying to get the technical specifications they need to rectify the issue as the ca0132 portion of the snd-hda-intel was pulled in but was originally written for a chrome book.

    Further details can be found on the Kernel Bugzilla here: https://bugzilla.kernel.org/show_bug.cgi?id=55541

    As well as the Creative discussion forums: http://forums.creative.com/showthread.php?t=699748

    It's labeled as II because the first thread was overrun by windows fan boys obstructively turning it into a flame war.

  5. #5
    Join Date
    Jan 2013
    Posts
    148

    Default

    From what I read, the cards should be fixed with the new audio updates coming down the pipe from Intel as the cards will get functionality as generic audio devices or something like that.

  6. #6
    Join Date
    Jan 2012
    Location
    New Jersey
    Posts
    35

    Default

    Quote Originally Posted by TheLexMachine View Post
    From what I read, the cards should be fixed with the new audio updates coming down the pipe from Intel as the cards will get functionality as generic audio devices or something like that.
    I'm not sure where you heard this but I hope it's true lol My guess it isn't coincidence though being I recently emailed Takashi and updated the Bugzilla pointing out I managed to get sound in an older kernel 3.8.11. So they may be working ona regression now looking where things went wrong in the codec for snd_hda_intel. This would be nice because the 3.8.11 doesn't have the newer DSP firmware added back in 1.25 of ALSA.

  7. #7
    Join Date
    May 2010
    Posts
    89

    Default

    Quote Originally Posted by TheLexMachine View Post
    From what I read, the cards should be fixed with the new audio updates coming down the pipe from Intel as the cards will get functionality as generic audio devices or something like that.
    Source? Creative position on linux is mute.

  8. #8

    Default Sound Blaster Z

    [QUOTE=Acidphase;330351]Well I have tried just about everything that I can think of including http://phoronix.com/forums/showthrea...106#post328106

    Hi Acidphase,

    By now you've probably have had someone help you but maybe this will help someone else.
    I'm no expert. Not even close but I can tell you what I did because mine is working fine.
    I have Sound Blaster Z and bought it when it first came out last year. I'm running Windows 7 64bit. I had the sound card installed by a computer guy and he got it running just fine. (I had Sound Blaster XFI on my computer already installed on my Dell XPS 435T/9000 PC) but XFI hadn't worked for a year or 2 because of no decent drivers!)
    After it was installed I went to the Sound BlasterZ program file, right clicked properties and took Administrative ownership of the folder, clicked okay and closed it. Then I went back, right clicked on the Security Tab Permissions added Administrative, my User name and my Owner name.
    I gave all 3 Full Control. No check mark in any little boxes. I deleted all other permissions names including System and Everyone etc so there was just my 3.
    Then I went to the Windows Firewall under Allow a program through. It gives you a list of what is already allowed through and then lets you browse to your Program and you'll find SoundBlaster Program in the Icon that's black square with red around it. self explanatory.
    I check my SounblasterZ sound AFTER each Window Update by playing a CD. Updates have caused it to stop working before so I uninstall the updates one by one until the SoundBlaster comes back.
    I don't believe there's anything faulty about the SoundBlaster Z Card or the drivers. I do believe there is a huge competition in sound programs such as ITunes and Amazon, ITunes Cloud and Amazon Cloud and 20 others!
    As far as the Device Manager and Windows Player Play back device choices, I didn't have to do one thing to update the drivers or screw with them.
    (Listed in the Sound Video and Game Controller was :
    High Definition Audio Device
    Monitor Webcam
    Nvidia Virtual Audio Device Wave Ext.WDM
    Sound Blaster Z
    Sound Blaster Z Audio Controller.


    Best of Luck ~

  9. #9
    Join Date
    May 2010
    Posts
    89

    Default

    [QUOTE=Givealittlebit;415232]
    Quote Originally Posted by Acidphase View Post
    Well I have tried just about everything that I can think of including http://phoronix.com/forums/showthrea...106#post328106

    Hi Acidphase,

    By now you've probably have had someone help you but maybe this will help someone else.
    I'm no expert. Not even close but I can tell you what I did because mine is working fine.
    I have Sound Blaster Z and bought it when it first came out last year. I'm running Windows 7 64bit. I had the sound card installed by a computer guy and he got it running just fine. (I had Sound Blaster XFI on my computer already installed on my Dell XPS 435T/9000 PC) but XFI hadn't worked for a year or 2 because of no decent drivers!)
    After it was installed I went to the Sound BlasterZ program file, right clicked properties and took Administrative ownership of the folder, clicked okay and closed it. Then I went back, right clicked on the Security Tab Permissions added Administrative, my User name and my Owner name.
    I gave all 3 Full Control. No check mark in any little boxes. I deleted all other permissions names including System and Everyone etc so there was just my 3.
    Then I went to the Windows Firewall under Allow a program through. It gives you a list of what is already allowed through and then lets you browse to your Program and you'll find SoundBlaster Program in the Icon that's black square with red around it. self explanatory.
    I check my SounblasterZ sound AFTER each Window Update by playing a CD. Updates have caused it to stop working before so I uninstall the updates one by one until the SoundBlaster comes back.
    I don't believe there's anything faulty about the SoundBlaster Z Card or the drivers. I do believe there is a huge competition in sound programs such as ITunes and Amazon, ITunes Cloud and Amazon Cloud and 20 others!
    As far as the Device Manager and Windows Player Play back device choices, I didn't have to do one thing to update the drivers or screw with them.
    (Listed in the Sound Video and Game Controller was :
    High Definition Audio Device
    Monitor Webcam
    Nvidia Virtual Audio Device Wave Ext.WDM
    Sound Blaster Z
    Sound Blaster Z Audio Controller.


    Best of Luck ~
    Don't see how that can help getting sound on linux.

    By the way, Soundblaster Z is still a lemon on linux and I don't see much interest from Creative to change that.

  10. #10
    Join Date
    Apr 2014
    Posts
    123

    Default

    Can you get the standard jacks working?
    Are you on Kernel 3.14?
    Does your Motherboard have onboard sound?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •