Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 39

Thread: Counter-Strike: GO Might Soon Be Out On Linux

  1. #21
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,762

    Default

    I avoid development kernels. And NVidia's 319 driver is buggy. It spams dmesg to death with error messages. I'm on 313.30.

    But I doubt it's a kernel or driver issue. To me it looks like a Source engine issue (because fps_max seems to be ignored with vsync on.)

  2. #22
    Join Date
    Mar 2009
    Posts
    130

    Default

    Quote Originally Posted by RealNC View Post
    I avoid development kernels. And NVidia's 319 driver is buggy. It spams dmesg to death with error messages. I'm on 313.30.

    But I doubt it's a kernel or driver issue. To me it looks like a Source engine issue (because fps_max seems to be ignored with vsync on.)
    I'm curious what setup (hardware + distro) you have? I've gathered that you've got an NVIDIA card obviously, but know little else. Do you have input lag in any other games? Have you tried running a non-compositing desktop just to see if it makes a difference?

    I probably can't really help much but it would be useful to know to compare with other people I know running games in Linux. I do know at least one workmate who runs ubuntu w/unity and plays UT2004 in it, and I've heard him complain about tearing without v-sync or no-tearing but too much input lag...

    Just as a side note - I did a little bit of experimenting in UT2004 (which is always my "go to" game to test performance and also input lag in Linux), and I just realised that with V-Sync enabled in the nvidia-settings I also get a _tiny_ bit of input lag. I wasn't sure, until I'd disabled it and re-ran the game. I then noticed it felt so much easier to steady a cursor on a target. I'm lucky though, since with my setup (GTX580M on driver 313.30 in ArchLinux w/Cinnamon) I don't seem to get any noticeable tearing when I disable V-Sync and go full screen. I'll have to test it on my PC at work with a GT240 though and see if it's the same.

  3. #23
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,722

    Default

    It could be the traditional Xorg issue. Do you still have lag when run under its own X server? No WM, no DE, no other X clients.

  4. #24
    Join Date
    Mar 2009
    Posts
    130

    Default

    Quote Originally Posted by curaga View Post
    It could be the traditional Xorg issue. Do you still have lag when run under its own X server? No WM, no DE, no other X clients.
    Traditional Xorg issue? Are you referring to standard X rendering lag? e.g. Daniel Stone's presentation where they measured rtt for rendering elements in X. If so, I didn't think that would that still apply when using direct rendering?

  5. #25
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,722

    Default

    No, I refer to X's input lag, where it can ignore the game for some ms, in favor of some other X client. This can't happen if the game is the only X client.

    This has been known ever since the Q3 days, for my recent-ish meeting with it google "slow xquerypointer".

  6. #26
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,762

    Default

    How do I run the game in this mode?

  7. #27
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,722

    Default

    Ask your distro

    Me, being the old-fashioned grumpy luddite, would do something like "startx game -- :1".

  8. #28
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,762

    Default

    Quote Originally Posted by curaga View Post
    Ask your distro

    Me, being the old-fashioned grumpy luddite, would do something like "startx game -- :1".
    Just tried that. I've shut down current X server first to be sure there's no conflicts. Then:

    startx /usr/bin/steam

    Sure enough, Steam came up on an otherwise totally black screen. I started CSCZ and it came up, but it doesn't work. I get a small window at the center of the screen and can't select anything with the mouse.

    Edit:
    Anyway, since there's 0 mouse lag with vsync disabled, I doubt it's the issue you're talking about, since if that were true, disabling vsync wouldn't help.
    Last edited by RealNC; 04-15-2013 at 02:24 PM.

  9. #29
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,762

    Default

    Quote Originally Posted by Kamikaze View Post
    I'm curious what setup (hardware + distro) you have? I've gathered that you've got an NVIDIA card obviously, but know little else.
    I'm on Gentoo ~amd64 with KDE 4.10.2. CPU is an i5 2500K, with a GTX 560 Ti GPU and 16GB RAM. Pretty typical mid-range gaming machine.

    Do you have input lag in any other games?
    Don't know if World of Goo qualifies, given that it's not an FPS, but no mouse lag in that one when moving the cursor around.

    Have you tried running a non-compositing desktop just to see if it makes a difference?
    Doesn't help.

  10. #30
    Join Date
    Oct 2012
    Posts
    134

    Default

    Quote Originally Posted by RealNC View Post
    Without vsync I get heavy tearing, which I can't stand at all.

    Btw, ignore my previous info about fps_max. It turns out that the lag is the same, regardless of whether I use 59, 60, or 200. It has zero effect. I can set it to 40 or even 30 or 20, but the game still runs at 60. So I suppose that under Linux, when vsync is enabled, fps_max does absolutely nothing. At least for me.

    I can't really play CS like that. For now, I'm playing under Windows, which is very sad :-(
    If you want max_fps to work, turn off sync to Vblank in Nvidia settings and also turn off gl_vsync in game then try setting max_fps

    gl_vsync 1 = capped at monitor refresh rate, gl_vsync 0 = capped at fps_max.

    SEt fps_max at 60 have things improved ?
    Last edited by DDF420; 04-16-2013 at 03:34 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •