Quote Originally Posted by j2723 View Post
Thanks for your post! Yes, it feels kind of "floaty"...
Well if you ever try Gnome again, here's how to fix it:

set the environment variable: "CLUTTER_VBLANK=none" (or add "export ..." to your startup file), then restart Gnome-Shell (Alt-F2, 'r', enter). IDK what kind of options area available to FLOSS radeon (I need Catalyst for Blender), but with Catalyst's AMD Control Center you have two areas of control. If you enable "Tear-free Desktop" it adds tripple buffering to the system (except on full-screen OpenGL windows), and eliminates tearing. The other area "quality control" or something like that, controls the settings for full-screen OpenGL applications. Usually I just leave the VSync slider in that area to "Off unless requested".

There are two ways to get good performance tear-free graphics. Usually you don't need to set "CLUTTER_VBLANK=none" with newer Radeon (HD 4xxx +) cards. Just leave is as default, and disable "Tear free" in the AMDCCC. Remember to adjust the "VSync quality slider" away from "always off", or full-screen games wont use VSynce at all. I've found this to be the best option, but you will get tearing if you have two monitors that are different resolutions, unfortunately.

The other way is to set the clutter_vblank var and enable Tear-Free. That works well (though not quite as good in my experience), and wont ever have tears.