Results 1 to 4 of 4

Thread: How to downgrade xorg from 1.13 to 1.12

  1. #1
    Join Date
    Nov 2011
    Posts
    257

    Default How to downgrade xorg from 1.13 to 1.12

    In order to install Catalyst it is necessary to downgrade to xorg 1.12. I used this method https://ask.fedoraproject.org/questi...gacy-chipsets/ but it doesn't seem to work anymore. I get (~$command / ### error >>> my action):
    Code:
    ~$rpm -Uvh xorg-x11-server-*.fc17.src.rpm
    ###warning: xorg-x11-server-1.12.4-2.fc17.src.rpm: Header V3 RSA/SHA256 Signature, key ID 1aca3465: NOKEY
    Updating / installing...
       1:xorg-x11-server-1.12.4-2.fc17    ################################# [100%]
    warning: user mockbuild does not exist - using root
    warning: group mockbuild does not exist - using root
    ...
    warning: group mockbuild does not exist - using root
    >>> ignored

    Code:
    rpmbuild -bb $(rpm --eval %_topdir)/SPECS/xorg-x11-server.spec
    ### 
    error: Failed build dependencies:
    	systemtap-sdt-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	xorg-x11-xtrans-devel >= 1.2.2-1 is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libXfont-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libxkbfile-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libXres-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libfontenc-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libXdmcp-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libXinerama-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libXt-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libdmx-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libXmu-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libXrender-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libXpm-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libXaw-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libXv-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	openssl-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	audit-libs-devel is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    	libselinux-devel >= 2.0.86-1 is needed by xorg-x11-server-1.12.4-2.fc18.x86_64
    >>>
    Code:
    sudo yum install systemtap-sdt-devel xorg-x11-xtrans-devel libXfont-devel libxkbfile-devel libXres-devel libfontenc-devel libXdmcp-devel libXinerama-devel libXt-devel libdmx-devel libXmu-devel libXrender-devel libXpm-devel libXaw-devel libXv-devel openssl-devel audit-libs-devel libselinux-devel

    Code:
    rpmbuild -bb $(rpm --eval %_topdir)/SPECS/xorg-x11-server.spec
    ###
    + rm -rf + rm -rf /root/rpmbuild/BUILDROOT/xorg-x11-server-1.12.4-2.fc18.x86_64
    + exit 0
    /root/rpmbuild/BUILDROOT/xorg-x11-server-1.12.4-2.fc18.x86_64
    + exit 0
    >>> seemed ok


    Code:
    sudo yum install $(rpm --eval %_topdir)/RPMS/x86_64/xorg-x11-server-devel-*.fc18.x86_64.rpm
    ### Examining /root/rpmbuild/RPMS/x86_64/xorg-x11-server-devel-1.12.4-2.fc18.x86_64.rpm: xorg-x11-server-devel-1.12.4-2.fc18.x86_64
    /root/rpmbuild/RPMS/x86_64/xorg-x11-server-devel-1.12.4-2.fc18.x86_64.rpm: does not update installed package.
    Error: Nothing to do
    >>> ignored


    Code:
    for i in xorg-x11-drv-*.src.rpm; do sudo yum-builddep $i; rpm -Uvh $i; rpmbuild -bb $(rpm --eval %_topdir)/SPECS/$(rpm -qp --queryformat '%{name}\n' $i).spec;done;
    ###RPM build errors:    Bad exit status from /var/tmp/rpm-tmp.vTT2FR (%build)
    ###in second run### make[1]: Leaving directory `/root/rpmbuild/BUILD/xf86-video-vmware-12.0.2'
    make: *** [all] Error 2
    error: Bad exit status from /var/tmp/rpm-tmp.Odl8ei (%build)
    
    
    RPM build errors:
        Bad exit status from /var/tmp/rpm-tmp.Odl8ei (%build)
    >>> ignored



    Code:
    cd $(rpm --eval %_topdir)/RPMS/x86_64
    sudo yum downgrade xorg-x11-server* xorg-x11-drv*
    ###--> Finished Dependency Resolution
    Error: Package: xorg-x11-drv-ati-7.0.0-0.9.20121015gitbd9e2c064.fc18.x86_64 (@updates)
               Requires: xserver-abi(videodrv-13) >= 1
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(videodrv-13) = 1
               Downgraded By: xorg-x11-server-Xorg-1.13.0-11.fc18.x86_64 (fedora)
                   xserver-abi(videodrv-13) = 0
    Error: Package: xorg-x11-drv-modesetting-0.4.0-1.fc18.x86_64 (/xorg-x11-drv-modesetting-0.4.0-1.fc18.x86_64)
               Requires: xserver-abi(videodrv-13) >= 1
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(videodrv-13) = 1
               Downgraded By: xorg-x11-server-Xorg-1.13.0-11.fc18.x86_64 (fedora)
                   xserver-abi(videodrv-13) = 0
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    >>> fail


    Then I tried the ZREPO script:
    gmrand.blogspot.it/2013/02/how-to-fedora-18-and-ati-catalyst-131.html
    but I got a lot of dependency errors
    Code:
    [root@localhost xxx]# yum --disablerepo="*" --enablerepo="zrepo" downgrade \xorg-x11-server-common-1.12.4-3.fc18.x86_64 \xorg-x11-server-Xorg-1.12.4-3.fc18.x86_64
    Loaded plugins: langpacks, presto, refresh-packagekit
    Resolving Dependencies
    --> Running transaction check
    ---> Package xorg-x11-server-Xorg.x86_64 0:1.12.4-3.fc18 will be a downgrade
    ---> Package xorg-x11-server-Xorg.x86_64 0:1.13.3-3.fc18 will be erased
    ---> Package xorg-x11-server-common.x86_64 0:1.12.4-3.fc18 will be a downgrade
    ---> Package xorg-x11-server-common.x86_64 0:1.13.3-3.fc18 will be erased
    --> Finished Dependency Resolution
    Error: Package: xorg-x11-drv-vmware-12.0.2-3.20120718gite5ac80d8f.fc18.x86_64 (@koji-override-0/$releasever)
               Requires: xserver-abi(videodrv-13) >= 0
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(videodrv-13) = 1
               Downgraded By: xorg-x11-server-Xorg-1.12.4-3.fc18.x86_64 (zrepo)
                   Not found
    Error: Package: xorg-x11-drv-fbdev-0.4.3-3.fc18.x86_64 (@koji-override-0/$releasever)
               Requires: xserver-abi(videodrv-13) >= 0
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(videodrv-13) = 1
               Downgraded By: xorg-x11-server-Xorg-1.12.4-3.fc18.x86_64 (zrepo)
                   Not found
    Error: Package: xorg-x11-drv-ati-7.0.0-0.9.20121015gitbd9e2c064.fc18.x86_64 (@updates)
               Requires: xserver-abi(videodrv-13) >= 1
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(videodrv-13) = 1
               Downgraded By: xorg-x11-server-Xorg-1.12.4-3.fc18.x86_64 (zrepo)
                   Not found
    Error: Package: xorg-x11-drv-synaptics-1.6.3-3.fc18.x86_64 (@updates)
               Requires: xserver-abi(xinput-18) >= 0
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(xinput-18) = 0
               Downgraded By: xorg-x11-server-Xorg-1.12.4-3.fc18.x86_64 (zrepo)
                   Not found
    Error: Package: xorg-x11-drv-vmmouse-13.0.0-1.fc18.x86_64 (@updates)
               Requires: xserver-abi(xinput-18) >= 0
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(xinput-18) = 0
               Downgraded By: xorg-x11-server-Xorg-1.12.4-3.fc18.x86_64 (zrepo)
                   Not found
    Error: Package: xorg-x11-drv-modesetting-0.6.0-1.fc18.x86_64 (@updates)
               Requires: xserver-abi(videodrv-13) >= 0
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(videodrv-13) = 1
               Downgraded By: xorg-x11-server-Xorg-1.12.4-3.fc18.x86_64 (zrepo)
                   Not found
    Error: Package: xorg-x11-drv-vesa-2.3.2-2.fc18.x86_64 (@koji-override-0/$releasever)
               Requires: xserver-abi(videodrv-13) >= 0
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(videodrv-13) = 1
               Downgraded By: xorg-x11-server-Xorg-1.12.4-3.fc18.x86_64 (zrepo)
                   Not found
    Error: Package: xorg-x11-drv-evdev-2.7.3-5.fc18.x86_64 (@updates)
               Requires: xserver-abi(xinput-18) >= 0
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(xinput-18) = 0
               Downgraded By: xorg-x11-server-Xorg-1.12.4-3.fc18.x86_64 (zrepo)
                   Not found
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

  2. #2
    Join Date
    Oct 2010
    Posts
    90

    Default

    This step:

    Code:
    sudo yum install $(rpm --eval %_topdir)/RPMS/x86_64/xorg-x11-server-devel-*.fc18.x86_64.rpm
    fails because you have a newer xorg-x11-server-devel installed. So instead, run:

    Code:
    sudo yum downgrade $(rpm --eval %_topdir)/RPMS/x86_64/xorg-x11-server-devel-*.fc18.x86_64.rpm
    Then continue the rest of the steps.

  3. #3
    Join Date
    Nov 2011
    Posts
    257

    Default

    Quote Originally Posted by chenxiaolong View Post
    This step:

    Code:
    sudo yum install $(rpm --eval %_topdir)/RPMS/x86_64/xorg-x11-server-devel-*.fc18.x86_64.rpm
    fails because you have a newer xorg-x11-server-devel installed. So instead, run:

    Code:
    sudo yum downgrade $(rpm --eval %_topdir)/RPMS/x86_64/xorg-x11-server-devel-*.fc18.x86_64.rpm
    Then continue the rest of the steps.
    I still get errors
    Code:
    $ cd $(rpm --eval %_topdir)/RPMS/x86_64
    $ sudo yum downgrade xorg-x11-server* xorg-x11-drv*
    [sudo] password for xxx: 
    Loaded plugins: langpacks, presto, refresh-packagekit
    Examining xorg-x11-server-1.12.4-2.fc17.src.rpm: xorg-x11-server-1.12.4-2.fc17.src
    Cannot add package xorg-x11-server-1.12.4-2.fc17.src.rpm to transaction. Not a compatible architecture: src
    Examining xorg-x11-server-common-1.12.4-2.fc18.x86_64.rpm: xorg-x11-server-common-1.12.4-2.fc18.x86_64
    Examining xorg-x11-server-debuginfo-1.12.4-2.fc18.x86_64.rpm: xorg-x11-server-debuginfo-1.12.4-2.fc18.x86_64
    No Match for available package: xorg-x11-server-debuginfo-1.12.4-2.fc18.x86_64
    Examining xorg-x11-server-devel-1.12.4-2.fc18.x86_64.rpm: xorg-x11-server-devel-1.12.4-2.fc18.x86_64
    Examining xorg-x11-server-Xdmx-1.12.4-2.fc18.x86_64.rpm: xorg-x11-server-Xdmx-1.12.4-2.fc18.x86_64
    No Match for available package: xorg-x11-server-Xdmx-1.12.4-2.fc18.x86_64
    Examining xorg-x11-server-Xephyr-1.12.4-2.fc18.x86_64.rpm: xorg-x11-server-Xephyr-1.12.4-2.fc18.x86_64
    No Match for available package: xorg-x11-server-Xephyr-1.12.4-2.fc18.x86_64
    Examining xorg-x11-server-Xnest-1.12.4-2.fc18.x86_64.rpm: xorg-x11-server-Xnest-1.12.4-2.fc18.x86_64
    No Match for available package: xorg-x11-server-Xnest-1.12.4-2.fc18.x86_64
    Examining xorg-x11-server-Xorg-1.12.4-2.fc18.x86_64.rpm: xorg-x11-server-Xorg-1.12.4-2.fc18.x86_64
    Examining xorg-x11-server-Xvfb-1.12.4-2.fc18.x86_64.rpm: xorg-x11-server-Xvfb-1.12.4-2.fc18.x86_64
    No Match for available package: xorg-x11-server-Xvfb-1.12.4-2.fc18.x86_64
    Examining xorg-x11-drv-ati-6.14.4-6.20120602git930760942.fc17.src.rpm: xorg-x11-drv-ati-6.14.4-6.20120602git930760942.fc17.src
    Cannot add package xorg-x11-drv-ati-6.14.4-6.20120602git930760942.fc17.src.rpm to transaction. Not a compatible architecture: src
    Examining xorg-x11-drv-ati-6.14.4-6.20120602git930760942.fc18.x86_64.rpm: xorg-x11-drv-ati-6.14.4-6.20120602git930760942.fc18.x86_64
    Examining xorg-x11-drv-ati-debuginfo-6.14.4-6.20120602git930760942.fc18.x86_64.rpm: xorg-x11-drv-ati-debuginfo-6.14.4-6.20120602git930760942.fc18.x86_64
    No Match for available package: xorg-x11-drv-ati-debuginfo-6.14.4-6.20120602git930760942.fc18.x86_64
    Examining xorg-x11-drv-evdev-2.7.3-5.fc17.src.rpm: xorg-x11-drv-evdev-2.7.3-5.fc17.src
    Cannot add package xorg-x11-drv-evdev-2.7.3-5.fc17.src.rpm to transaction. Not a compatible architecture: src
    Examining xorg-x11-drv-evdev-2.7.3-5.fc18.x86_64.rpm: xorg-x11-drv-evdev-2.7.3-5.fc18.x86_64
    Examining xorg-x11-drv-evdev-debuginfo-2.7.3-5.fc18.x86_64.rpm: xorg-x11-drv-evdev-debuginfo-2.7.3-5.fc18.x86_64
    No Match for available package: xorg-x11-drv-evdev-debuginfo-2.7.3-5.fc18.x86_64
    Examining xorg-x11-drv-evdev-devel-2.7.3-5.fc18.x86_64.rpm: xorg-x11-drv-evdev-devel-2.7.3-5.fc18.x86_64
    No Match for available package: xorg-x11-drv-evdev-devel-2.7.3-5.fc18.x86_64
    Examining xorg-x11-drv-fbdev-0.4.2-8.fc17.src.rpm: xorg-x11-drv-fbdev-0.4.2-8.fc17.src
    Cannot add package xorg-x11-drv-fbdev-0.4.2-8.fc17.src.rpm to transaction. Not a compatible architecture: src
    Examining xorg-x11-drv-fbdev-0.4.2-8.fc18.x86_64.rpm: xorg-x11-drv-fbdev-0.4.2-8.fc18.x86_64
    Examining xorg-x11-drv-fbdev-debuginfo-0.4.2-8.fc18.x86_64.rpm: xorg-x11-drv-fbdev-debuginfo-0.4.2-8.fc18.x86_64
    No Match for available package: xorg-x11-drv-fbdev-debuginfo-0.4.2-8.fc18.x86_64
    Examining xorg-x11-drv-modesetting-0.4.0-1.fc17.src.rpm: xorg-x11-drv-modesetting-0.4.0-1.fc17.src
    Cannot add package xorg-x11-drv-modesetting-0.4.0-1.fc17.src.rpm to transaction. Not a compatible architecture: src
    Examining xorg-x11-drv-modesetting-0.4.0-1.fc18.x86_64.rpm: xorg-x11-drv-modesetting-0.4.0-1.fc18.x86_64
    Examining xorg-x11-drv-modesetting-debuginfo-0.4.0-1.fc18.x86_64.rpm: xorg-x11-drv-modesetting-debuginfo-0.4.0-1.fc18.x86_64
    No Match for available package: xorg-x11-drv-modesetting-debuginfo-0.4.0-1.fc18.x86_64
    Examining xorg-x11-drv-synaptics-1.6.3-1.fc17.src.rpm: xorg-x11-drv-synaptics-1.6.3-1.fc17.src
    Cannot add package xorg-x11-drv-synaptics-1.6.3-1.fc17.src.rpm to transaction. Not a compatible architecture: src
    Examining xorg-x11-drv-synaptics-1.6.3-1.fc18.x86_64.rpm: xorg-x11-drv-synaptics-1.6.3-1.fc18.x86_64
    Examining xorg-x11-drv-synaptics-debuginfo-1.6.3-1.fc18.x86_64.rpm: xorg-x11-drv-synaptics-debuginfo-1.6.3-1.fc18.x86_64
    No Match for available package: xorg-x11-drv-synaptics-debuginfo-1.6.3-1.fc18.x86_64
    Examining xorg-x11-drv-synaptics-devel-1.6.3-1.fc18.x86_64.rpm: xorg-x11-drv-synaptics-devel-1.6.3-1.fc18.x86_64
    No Match for available package: xorg-x11-drv-synaptics-devel-1.6.3-1.fc18.x86_64
    Examining xorg-x11-drv-vesa-2.3.1-1.fc17.src.rpm: xorg-x11-drv-vesa-2.3.1-1.fc17.src
    Cannot add package xorg-x11-drv-vesa-2.3.1-1.fc17.src.rpm to transaction. Not a compatible architecture: src
    Examining xorg-x11-drv-vesa-2.3.1-1.fc18.x86_64.rpm: xorg-x11-drv-vesa-2.3.1-1.fc18.x86_64
    Examining xorg-x11-drv-vesa-debuginfo-2.3.1-1.fc18.x86_64.rpm: xorg-x11-drv-vesa-debuginfo-2.3.1-1.fc18.x86_64
    No Match for available package: xorg-x11-drv-vesa-debuginfo-2.3.1-1.fc18.x86_64
    Examining xorg-x11-drv-vmmouse-12.8.0-1.fc17.src.rpm: xorg-x11-drv-vmmouse-12.8.0-1.fc17.src
    Cannot add package xorg-x11-drv-vmmouse-12.8.0-1.fc17.src.rpm to transaction. Not a compatible architecture: src
    Examining xorg-x11-drv-vmmouse-12.8.0-1.fc18.x86_64.rpm: xorg-x11-drv-vmmouse-12.8.0-1.fc18.x86_64
    Examining xorg-x11-drv-vmmouse-debuginfo-12.8.0-1.fc18.x86_64.rpm: xorg-x11-drv-vmmouse-debuginfo-12.8.0-1.fc18.x86_64
    No Match for available package: xorg-x11-drv-vmmouse-debuginfo-12.8.0-1.fc18.x86_64
    Examining xorg-x11-drv-vmware-12.0.2-1.fc17.src.rpm: xorg-x11-drv-vmware-12.0.2-1.fc17.src
    Cannot add package xorg-x11-drv-vmware-12.0.2-1.fc17.src.rpm to transaction. Not a compatible architecture: src
    Examining xorg-x11-drv-vmware-12.0.2-1.fc18.x86_64.rpm: xorg-x11-drv-vmware-12.0.2-1.fc18.x86_64
    Examining xorg-x11-drv-vmware-debuginfo-12.0.2-1.fc18.x86_64.rpm: xorg-x11-drv-vmware-debuginfo-12.0.2-1.fc18.x86_64
    No Match for available package: xorg-x11-drv-vmware-debuginfo-12.0.2-1.fc18.x86_64
    Resolving Dependencies
    --> Running transaction check
    ---> Package xorg-x11-drv-ati.x86_64 0:6.14.4-6.20120602git930760942.fc18 will be a downgrade
    ---> Package xorg-x11-drv-ati.x86_64 0:7.0.0-0.9.20121015gitbd9e2c064.fc18 will be erased
    ---> Package xorg-x11-drv-fbdev.x86_64 0:0.4.2-8.fc18 will be a downgrade
    ---> Package xorg-x11-drv-fbdev.x86_64 0:0.4.3-3.fc18 will be erased
    ---> Package xorg-x11-drv-modesetting.x86_64 0:0.4.0-1.fc18 will be a downgrade
    ---> Package xorg-x11-drv-modesetting.x86_64 0:0.6.0-1.fc18 will be erased
    ---> Package xorg-x11-drv-synaptics.x86_64 0:1.6.3-1.fc18 will be a downgrade
    ---> Package xorg-x11-drv-synaptics.x86_64 0:1.6.3-3.fc18 will be erased
    ---> Package xorg-x11-drv-vesa.x86_64 0:2.3.1-1.fc18 will be a downgrade
    ---> Package xorg-x11-drv-vesa.x86_64 0:2.3.2-2.fc18 will be erased
    ---> Package xorg-x11-drv-vmmouse.x86_64 0:12.8.0-1.fc18 will be a downgrade
    ---> Package xorg-x11-drv-vmmouse.x86_64 0:13.0.0-1.fc18 will be erased
    ---> Package xorg-x11-drv-vmware.x86_64 0:12.0.2-1.fc18 will be a downgrade
    ---> Package xorg-x11-drv-vmware.x86_64 0:12.0.2-3.20120718gite5ac80d8f.fc18 will be erased
    ---> Package xorg-x11-server-Xorg.x86_64 0:1.12.4-2.fc18 will be a downgrade
    ---> Package xorg-x11-server-Xorg.x86_64 0:1.13.3-3.fc18 will be erased
    ---> Package xorg-x11-server-common.x86_64 0:1.12.4-2.fc18 will be a downgrade
    ---> Package xorg-x11-server-common.x86_64 0:1.13.3-3.fc18 will be erased
    --> Finished Dependency Resolution
    Error: Package: xorg-x11-drv-evdev-2.7.3-5.fc18.x86_64 (@updates)
               Requires: xserver-abi(xinput-18) >= 0
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(xinput-18) = 0
               Downgraded By: xorg-x11-server-Xorg-1.12.4-2.fc18.x86_64 (/xorg-x11-server-Xorg-1.12.4-2.fc18.x86_64)
                   Not found
               Available: xorg-x11-server-Xorg-1.13.0-11.fc18.x86_64 (fedora)
                   xserver-abi(xinput-18) = 0
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    [xxx@localhost x86_64]$ ls 
    xorg-x11-drv-ati-6.14.4-6.20120602git930760942.fc17.src.rpm               xorg-x11-drv-modesetting-debuginfo-0.4.0-1.fc18.x86_64.rpm  xorg-x11-drv-vmware-12.0.2-1.fc18.x86_64.rpm
    xorg-x11-drv-ati-6.14.4-6.20120602git930760942.fc18.x86_64.rpm            xorg-x11-drv-synaptics-1.6.3-1.fc17.src.rpm                 xorg-x11-drv-vmware-debuginfo-12.0.2-1.fc18.x86_64.rpm
    xorg-x11-drv-ati-debuginfo-6.14.4-6.20120602git930760942.fc18.x86_64.rpm  xorg-x11-drv-synaptics-1.6.3-1.fc18.x86_64.rpm              xorg-x11-server-1.12.4-2.fc17.src.rpm
    xorg-x11-drv-evdev-2.7.3-5.fc17.src.rpm                                   xorg-x11-drv-synaptics-debuginfo-1.6.3-1.fc18.x86_64.rpm    xorg-x11-server-common-1.12.4-2.fc18.x86_64.rpm
    xorg-x11-drv-evdev-2.7.3-5.fc18.x86_64.rpm                                xorg-x11-drv-synaptics-devel-1.6.3-1.fc18.x86_64.rpm        xorg-x11-server-debuginfo-1.12.4-2.fc18.x86_64.rpm
    xorg-x11-drv-evdev-debuginfo-2.7.3-5.fc18.x86_64.rpm                      xorg-x11-drv-vesa-2.3.1-1.fc17.src.rpm                      xorg-x11-server-devel-1.12.4-2.fc18.x86_64.rpm
    xorg-x11-drv-evdev-devel-2.7.3-5.fc18.x86_64.rpm                          xorg-x11-drv-vesa-2.3.1-1.fc18.x86_64.rpm                   xorg-x11-server-Xdmx-1.12.4-2.fc18.x86_64.rpm
    xorg-x11-drv-fbdev-0.4.2-8.fc17.src.rpm                                   xorg-x11-drv-vesa-debuginfo-2.3.1-1.fc18.x86_64.rpm         xorg-x11-server-Xephyr-1.12.4-2.fc18.x86_64.rpm
    xorg-x11-drv-fbdev-0.4.2-8.fc18.x86_64.rpm                                xorg-x11-drv-vmmouse-12.8.0-1.fc17.src.rpm                  xorg-x11-server-Xnest-1.12.4-2.fc18.x86_64.rpm
    xorg-x11-drv-fbdev-debuginfo-0.4.2-8.fc18.x86_64.rpm                      xorg-x11-drv-vmmouse-12.8.0-1.fc18.x86_64.rpm               xorg-x11-server-Xorg-1.12.4-2.fc18.x86_64.rpm
    xorg-x11-drv-modesetting-0.4.0-1.fc17.src.rpm                             xorg-x11-drv-vmmouse-debuginfo-12.8.0-1.fc18.x86_64.rpm     xorg-x11-server-Xvfb-1.12.4-2.fc18.x86_64.rpm
    xorg-x11-drv-modesetting-0.4.0-1.fc18.x86_64.rpm                          xorg-x11-drv-vmware-12.0.2-1.fc17.src.rpm
    Me, struggling...
    Code:
    [xxx@localhost x86_64]$ sudo yum downgrade /xorg-x11-server* /xorg-x11-drv*
    [sudo] password for xxx: 
    Loaded plugins: langpacks, presto, refresh-packagekit
    fedora/filelists_db                                                                                                                                                                      |  25 MB  00:00:12     
    rpmfusion-free/filelists_db                                                                                                                                                              | 319 kB  00:00:00     
    rpmfusion-free-updates/filelists_db                                                                                                                                                      | 170 kB  00:00:00     
    rpmfusion-nonfree/filelists_db                                                                                                                                                           | 246 kB  00:00:00     
    rpmfusion-nonfree-updates/filelists_db                                                                                                                                                   | 196 kB  00:00:00     
    updates/filelists_db                                                                                                                                                                     |  13 MB  00:00:07     
    No package /xorg-x11-server* available.
    No package /xorg-x11-drv* available.
    Error: Nothing to do
    [xxx@localhost x86_64]$ sudo yum downgrade /xorg-x11-server*
    Loaded plugins: langpacks, presto, refresh-packagekit
    No package /xorg-x11-server* available.
    Error: Nothing to do
    [xxx@localhost x86_64]$ sudo yum downgrade /xorg-x11-server-*
    Loaded plugins: langpacks, presto, refresh-packagekit
    No package /xorg-x11-server-* available.
    Error: Nothing to do
    [xxx@localhost x86_64]$ sudo yum downgrade "xorg-x11-server-*"
    Loaded plugins: langpacks, presto, refresh-packagekit
    No Match for available package: xorg-x11-server-Xdmx-1.13.0-11.fc18.x86_64
    No Match for available package: xorg-x11-server-Xephyr-1.13.0-11.fc18.x86_64
    No Match for available package: xorg-x11-server-Xnest-1.13.0-11.fc18.x86_64
    No Match for available package: xorg-x11-server-Xspice-0.0.22-5.20120718gitde6620788.fc18.x86_64
    No Match for available package: xorg-x11-server-Xvfb-1.13.0-11.fc18.x86_64
    Only Upgrade available on package: xorg-x11-server-devel-1.13.0-11.fc18.x86_64
    No Match for available package: xorg-x11-server-source-1.13.0-11.fc18.noarch
    Resolving Dependencies
    --> Running transaction check
    ---> Package xorg-x11-server-Xorg.x86_64 0:1.13.0-11.fc18 will be a downgrade
    ---> Package xorg-x11-server-Xorg.x86_64 0:1.13.3-3.fc18 will be erased
    ---> Package xorg-x11-server-common.x86_64 0:1.13.0-11.fc18 will be a downgrade
    ---> Package xorg-x11-server-common.x86_64 0:1.13.3-3.fc18 will be erased
    ---> Package xorg-x11-server-utils.x86_64 0:7.5-14.fc18 will be a downgrade
    ---> Package xorg-x11-server-utils.x86_64 0:7.5-16.fc18 will be erased
    --> Finished Dependency Resolution
    Error: Package: xorg-x11-drv-ati-7.0.0-0.9.20121015gitbd9e2c064.fc18.x86_64 (@updates)
               Requires: xserver-abi(videodrv-13) >= 1
               Removing: xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64 (@updates)
                   xserver-abi(videodrv-13) = 1
               Downgraded By: xorg-x11-server-Xorg-1.13.0-11.fc18.x86_64 (fedora)
                   xserver-abi(videodrv-13) = 0
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    Last edited by Bucic; 05-12-2013 at 05:24 AM.

  4. #4
    Join Date
    Oct 2010
    Posts
    90

    Default

    Ahh...I hate yum. Try this:

    Code:
    sudo rpm -Uvh --force --nodeps xorg-x11-server* xorg-x11-drv*
    instead of

    Code:
    sudo yum downgrade xorg-x11-server* xorg-x11-drv*
    Fedora is introducing a new package manager, dnf, in Fedora 19 or Feodra 20. It better work better than yum.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •