Results 1 to 4 of 4

Thread: pts/espeak, pts/povray & pts/qgears2 fail to build on latest Arch Linux x64

  1. #1
    Join Date
    Nov 2012
    Location
    France
    Posts
    4

    Default pts/espeak, pts/povray & pts/qgears2 fail to build on latest Arch Linux x64

    Hi all,

    I installed pts/universe test suite and 3 tests really fail to build on latest Arch Linux x64 (in fact 3 more tests failed to build : pts/encode-wavpack, pts/sqlite, pts/tiobench but i found how to solve the problem for each of them on this forum ... thanks ;-)).

    -> pts/povray build log is complaining about many things like libpng : my distro has libpng 1.5 and i installed libpng 1.4 too in /usr/local, there is no conflict between them. When building pts/povray from stock test profile it uses libpng 1.5 and stops early; the log file is shorter but similar as the log file which is produced by the use of the libpng 1.4 library (i modified the "install.sh" file in the test profile by exporting libpng 1.4 environment variables). Here are the last lines of the log file produced when using libpng 1.4 :

    Code:
    png_pov.cpp:1678:21: warning: 'png_struct_def::color_type' is deprecated (declared at /usr/local/include/libpng14/png.h:1255) [-Wdeprecated-declarations]
    make[2]: *** [png_pov.o] Error 1
    make[2]: Leaving directory `/home/gandalf75/.phoronix-test-suite/installed-tests/pts/povray-1.0.0/povray-3.6.1/source'
    make[1]: *** [install-recursive] Error 1
    make[1]: Leaving directory `/home/gandalf75/.phoronix-test-suite/installed-tests/pts/povray-1.0.0/povray-3.6.1/source'
    make: *** [install-recursive] Error 1
    ... thanks for helping me out :-)

    -> pts/espeak and pts/qgears2 are not building either but it is less important because i don't intend to use them for now ... can i attach the log files to this post ? i did not found a way to do so ...

    I use phoronix-test-suite 4.0.1 and tried 4.2.0m2. My last question for now is : Is it really important to satisfy all the dependencies that phoronix-test-suite "needs" : i mean ... when pts "wants" openal, i install it and it still complains about it; i know that it's often because of the "file check" item located in the xml file (distro specific or generic) in the external-test-dependencies folder of pts so i create symlinks to solve the warning message, is it useless or not when the needed package is installed ?

    ... thanks again for your help ...

  2. #2
    Join Date
    Nov 2012
    Location
    France
    Posts
    4

    Default

    Hi again,

    I have some good news ... i used libpng 1.2 this time : the build process is much longer but it still fails ... the log file ends now like this :

    Code:
    make[1]: Entering directory `/home/gandalf75/.phoronix-test-suite/installed-tests/pts/povray-1.0.0/povray-3.6.1/unix'
    g++  -pipe -Wno-multichar -O3 -msse -mfpmath=sse -msse2 -march=k8 -mtune=k8 -malign-double -minline-all-stringops  -Wno-write-strings  -L/usr/local/libpng12/lib -lpng12 -o povray  svga.o unix.o xwin.o ../source/libpovray.a ../source/base/libbase.a ../source/frontend/libfrontend.a  -ltiff -ljpeg -lz -lXpm   -lSM -lICE -lX11 -lm 
    ../source/libpovray.a(png_pov.o): In function `pov::PNG_Image::~PNG_Image()':
    png_pov.cpp:(.text+0xd1f): undefined reference to `png_write_finish_row'
    collect2: error: ld returned 1 exit status
    make[1]: *** [povray] Error 1
    make[1]: Leaving directory `/home/gandalf75/.phoronix-test-suite/installed-tests/pts/povray-1.0.0/povray-3.6.1/unix'
    make: *** [install-recursive] Error 1
    As you understood i'm not a professional developper, i only have basics ... and google ;-) It seems that the problem now has something with qt4 because of the "collect2: error: ld returned 1 exit status", at last that's what i understood from the different posts around the Web ... am i wrong ?

    I have qt4 development libraries installed but at this point i really don't know what to do ... any ideas folks ?

    Thanks
    Last edited by skine0z; 11-12-2012 at 02:24 PM.

  3. #3
    Join Date
    Nov 2012
    Location
    France
    Posts
    4

    Default

    Apparently the problem i have at last has nothing to do with qt4 because there is no reference for qt4 library in the build process. I "googled" this problem a little bit more and it seems that's because of "march" and "mtune" set to "k8" -> my CPU is an INTEL Corei7. The makefile is involved of course ... i've posted a message on the POV-Ray forum ... i'll let you know ...

    Best Regards

  4. #4
    Join Date
    Nov 2012
    Location
    France
    Posts
    4

    Talking Solved !

    Hello,

    The POV-Ray forum gave me the solution : it's simple ... just add "--disable-lib-checks" to the configure command line (by editing "install.sh" located in ".../test-profiles/pts/povray-1.0.0") in order to force the configure script to use the libraries bundled in the POV-Ray source package and it will build successfully when running "phoronix-test-suite install pts/povray" from the console !

    Regards

    NB : it seems that an update has been released for qgears2 test profile because the test now installs itself without a problem ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •