Quote Originally Posted by Kano View Post
You got it completely wrong, you can ship current libs but the libc6 used must be old enough to allow other distros run the code, that's the main dependency of a system. Some HIB games come out and only ran with Ubuntu and not Debian, that's definitely wrong. Partly only the installer was compiled against that new code - manually extracting helped but that's not user friendly. The Linux world does not only consists of Ubuntu only - they just intend to ship always a very new libc6...
There is no reason that game developers should have to stick to ancient toolchains to accommodate the few who want to use distros who have a strange hatred for halfway recent packages. Also, if they shipped the used glibc with the package it would work on litteraly /any/ linux system. Third party developers really need to ship their libraries on linux like they do on windows.