Page 7 of 7 FirstFirst ... 567
Results 61 to 63 of 63

Thread: Raspberry Pi GPU Driver Turns Out To Be Crap

  1. #61
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,020

    Default

    I don't think there is another X driver ready yet. But at least two are in development. One requires quite some patches to the kernel with dma and stuff and is not released completely yet and another one tries to use glamor.

    1: http://www.raspberrypi.org/phpBB3/viewtopic.php?t=4649
    2: https://github.com/Factoid/xf86-video-rpi

    I don't think the glamor one would work on archlinux arm since it uses X.org 1.13 and as far as I know glamor doesn't work on 1.13 yet.

  2. #62
    Join Date
    Nov 2011
    Location
    France
    Posts
    52

    Default

    Quote Originally Posted by ChrisXY View Post
    I don't think there is another X driver ready yet. But at least two are in development. One requires quite some patches to the kernel with dma and stuff and is not released completely yet and another one tries to use glamor.

    1: http://www.raspberrypi.org/phpBB3/viewtopic.php?t=4649
    2: https://github.com/Factoid/xf86-video-rpi

    I don't think the glamor one would work on archlinux arm since it uses X.org 1.13 and as far as I know glamor doesn't work on 1.13 yet.
    Hello,

    Thanks taking time to anwser.
    Those are indeed promising XFree driver, however I wonder how the various XBMC distribs manage the videos : using straight SDL ? or OpenGL without X ?
    I have tried without success to compile this GL sample.
    So far, I'm stuck with :
    libEGL.so: undefined reference to `glxx_<whatever function>
    Beside display, sound "sounds" like also an issue :

    Code:
    # modprobe snd_bcm2835
    # alsaplayer
    Nothing outputs to speakers throught the analog jack connection !

  3. #63
    Join Date
    Nov 2011
    Location
    France
    Posts
    52

    Default Not so bad, actually

    I did port the GLES version of RollerCoaster here and programmed a Cube sample there, the GPU is doing fine till the code does not rely too much on the CPU.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •