Page 4 of 4 FirstFirst ... 234
Results 31 to 34 of 34

Thread: Wayland 1.0 Officially Released

  1. #31
    Join Date
    May 2010
    Posts
    163

    Default

    Quote Originally Posted by Rigaldo View Post
    @Ancurio

    You're right, it's old .. From April.
    Hope I can find a newer one. Maybe I'll try Rebecca Black, although this is also outdated(but has scripts to build the newer version IIRC).
    Yes there are scripts on the SVN. I can't release a new ISO right now because Weston isn't working on Mesa with software rendering (it seems it's going to need a patch in Mesa)

    Also Qtwayland needs to be ported to the updated protocol, as well as the xwayland server, and sdl.

    Once these work, I'll push a new ISO for Wayland 1.0 of RBOS

    Edit: even if you use the current RBOS, there's a cheatsheet that appears as a dialog if you click on the I icon that has all of the key bindings and whatnot within weston.
    Last edited by nerdopolis; 10-25-2012 at 12:05 PM.

  2. #32
    Join Date
    Aug 2012
    Posts
    245

    Default

    Thanks nerdopolis. I was just trying the current one. XWayland apps acted weird in some cases. One problem annoyed me the most, my screen turning off when closing certain XWayland applications with Super+K with apparently no way of recovery, aside from manual reboot.
    But other than "some" glitches it worked ok, as good as I'd expect so to say.
    Hopefully all those are being/have been worked on on upstream Wayland, I hope it's somewhat usable within a few months.(Maybe not for casual users, but be in a state for testers to be able to run it for extended periods of time )

    I guess I'll wait for you to release the new version. If it doesn't work for you, I doubt it will for me anyways. Thanks for your efforts!

  3. #33
    Join Date
    May 2010
    Posts
    163

    Default

    Quote Originally Posted by Rigaldo View Post
    Thanks nerdopolis. I was just trying the current one. XWayland apps acted weird in some cases. One problem annoyed me the most, my screen turning off when closing certain XWayland applications with Super+K with apparently no way of recovery, aside from manual reboot.
    But other than "some" glitches it worked ok, as good as I'd expect so to say.
    Hopefully all those are being/have been worked on on upstream Wayland, I hope it's somewhat usable within a few months.(Maybe not for casual users, but be in a state for testers to be able to run it for extended periods of time )

    I guess I'll wait for you to release the new version. If it doesn't work for you, I doubt it will for me anyways. Thanks for your efforts!
    The super key + k command on xwayland apps was a bug in Weston. I reported it, it got fixed a while back. basically, what happens is weston owns the xwayland windows, and it kills itself.

    The wlshm driver for the xwayland server is also glitchy, so that's why the windows appear garbled

  4. #34
    Join Date
    Aug 2012
    Posts
    245

    Default

    It was expected they'd have done something to fix one or two bugs since then. Hopefully with the newer version XWayland will become less glitchy too.
    Wonder when initial proprietary support will appear.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •