Page 7 of 23 FirstFirst ... 5678917 ... LastLast
Results 61 to 70 of 225

Thread: AMD Catalyst 8.01 Linux Driver

  1. #61
    Join Date
    Dec 2007
    Posts
    3

    Default 8.01 first impressions

    8.01 first impressions: (Thinkpad T60, X1400, Kubuntu Gutsy)

    - installation was straightforward:

    ati-driver-installer-8-01-x86.x86_64.run --buildpkg Ubuntu/gutsy
    dpkg -i xorg-driver-fglrx_8.452.1-1_i386.deb fglrx-kernel-source_8.452.1-1_i386.deb fglrx-amdcccle_8.452.1-1_i386.deb
    restart X

    (I had all the other stuff like compiler tools and restricted modules settings already in place from previous installs)

    - everything that worked in 7.12 still works, including suspend/resume
    - the screen corruption when dragging icons around on the desktop is gone
    - the resolution issues are fixed
    - I didn't run benchmarks but my main 3D app googleearth runs about the same as before, certainly not worse
    - video playing is essentially the same as before: kind of ok with GL, some flickering with xv. With compositing enabled, video playing is not usable with either GL or xv: too much flicker
    - two out of the three issues that remained for me in 7.12 have been resolved: good going ATI!

    Overall, for me this is the best fglrx I've used to date. Now make video and compositing work together and I'll be hard pressed to find something else to ask for.

    Ah and before I forget, here's my ceterum censeo: ATI please write up a document on what options this driver takes in xorg.conf and what they mean. I know there are some documents out there on the web people put together but it would be really nice to have a complete listing of options from the authoritative source.
    Last edited by chrisg; 01-18-2008 at 04:24 PM. Reason: typo, some formatting problems

  2. #62
    Join Date
    Nov 2007
    Posts
    19

    Default remove, reboot, reinstall

    Quote Originally Posted by Isaac702 View Post
    Well I'm dead in the water. I have updated to 8.1 but it crashes when ever I try to configure Xorg through Yast (My old settings don't work either Xorg crashes)
    [...]
    Try the three R!

    I had a similar problem, and it went away after uninstalling the 8.45 rpm, installing the 8.40 rpm, uninstalling that and installing 8.45 again, with reboots inserted in this procedure generously. Feels like windows...

    Having another terminal to ssh into the machine under surgery helps to get around all those black screens on the way. If that's not possible, be sure to boot into runlevel 3 by entering a 3 into the boot options at the prompt.

    But in the end it worked for me, and I have a widescreen with 1680x1050 and fast 3D running.

    Cheers, shamooki

    Lenovo T60
    Mobility Radeon X1300
    OpenSUSE 10.3 x84_64

  3. #63

    Default

    Quote Originally Posted by jackkerouac View Post
    Well, after installing this driver, I cannot even get into the GDM login screen. I just get a blank, black screen with nothing else. ALT-CTRL-F1 or F2 doesn't work. I have to hard-reset.

    ATI X1650 Pro, Gutsy 7.10

    Here is my Xorg.0.log:


    Any ideas on why this is happening? 8.40.4 works just fine. It's what I am using now in place of any of the new drivers. Any driver after 8.40.4 gives me the same problems.

    Any help would be really appreciated.
    From what I see it tries to load an old fglrx(8.37.6). Have you blacklisted the ubuntu's fglrx? info


    Quote Originally Posted by chrisg
    ati-driver-installer-8.443.1-x86.x86_64.run --buildpkg Ubuntu/gutsy
    dpkg -i xorg-driver-fglrx_8.452.1-1_i386.deb fglrx-kernel-source_8.452.1-1_i386.deb fglrx-amdcccle_8.452.1-1_i386.deb
    restart X
    I think you mean
    ati-driver-installer-8-01-x86.x86_64.run --buildpkg Ubuntu/gutsy
    EDIT: You fixed it already!!!

  4. #64
    Join Date
    Aug 2007
    Posts
    56

    Default

    any x200 experiences???

  5. #65
    Join Date
    Oct 2007
    Location
    Brussels, Belgium
    Posts
    28

    Default

    Any chances to have an hotfix for not working cards? It's the 3rd unusable version in a row for me (memory leak, resolution issue and now not even 3d acceleration)?

  6. #66
    Join Date
    Apr 2007
    Location
    The Netherlands
    Posts
    31

    Default

    Quote Originally Posted by Michael View Post
    For the Fedora packaging bug, I'll push updated scripts to Phorogit for it tonight once I get back to my hotel.
    Thanks Michael, I would appreciate that. Do you know why this does not work:

    1) unpack driver into tempdir
    2) cd tempdir (and fix missing file in the spec file template)
    3) ./ati-installer.sh --buildpkg Fedora/F8

    Step 3 always comes back with this error: Unrecognized parameter '' to ati-installer.sh

    Am I doing something wrong or is it a bug? Thanks.

  7. #67
    Join Date
    Aug 2007
    Posts
    6,634

    Default

    You forget to use the "real" version as first option to ati-installer.sh. That's NOT 8-01 but 8.452.1. Example from my script:

    bash ati-installer.sh $VER --buildpkg $DISTRIB_ID/$DISTRIB_CODENAME

  8. #68
    Join Date
    Oct 2007
    Posts
    46

    Default

    Summary for my Inspiron 6400, Radeon Mobility X1400, Ubuntu/gutsy:
    - 1440x900 supported once more.
    - suspend not working again (7.12 was fine).
    - unable to end an X session; system crashes.
    - VLC will not play videos with the OpenGL output plug-in.
    - most things noticeably slower.

    Too bad, really.

  9. #69
    Join Date
    Aug 2007
    Posts
    6,634

    Default

    As there are very big compatibity issues especially with lastest Intel G33/P35 chipset (board used: Gigabyte GA-G33-DS3R) I would highly advice ATI to use this for testing, especially RV410 and those cases:

    a) switch from ati oss to fglrx
    b) switch from fglrx to another version
    c) ctrl+alt+backspace - will often result in a state that kdm is still running and new x is therefore not started
    d) oss driver with latest xorg + compiz fusion: enable water + enable snow effect + rotate cube
    e) add a modeline

    Many of those cases force crash the xserver or even the hole system (no ssh login possible anymore).

  10. #70
    Join Date
    Oct 2007
    Posts
    12

    Default

    I haven't seen anything mentioned regarding the issue with aiglx under xserver 1.4.

    Can anyone enlighten me on wether this is fixed? If not, I'll put upgrading on hold for a while.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •