Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: 304.48 pre-release for Linux/Solaris/FreeBSD

  1. #1
    Join Date
    Jul 2009
    Posts
    27

    Post 304.48 pre-release for Linux/Solaris/FreeBSD

    Please refer to this post for more information.

    Thanks,
    - Pierre-Loup
    NVIDIA Linux Graphics
    Last edited by Plagman; 09-11-2012 at 07:50 PM.

  2. #2
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,796

    Default

    Thanks.

    It's been a long time since the KDE VDPAU problem was confirmed. Any plans on fixing that? VDPAU is unusable right now (and has been for a long time.)

  3. #3
    Join Date
    Sep 2006
    Posts
    210

    Default

    Really? I use both KDE and mplayer+vdpau daily and they work just fine together.
    Occasionally mplayer locks up due to some vdpau quirk, but that's it.

  4. #4
    Join Date
    Jun 2006
    Posts
    352

    Default

    @Plagman: looks like you are now the nVidia Linux mascot. We need you in a head to head with Linus!
    Any news on the *official * nVidia Linux forum?

  5. #5
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,796

    Default

    Quote Originally Posted by mlau View Post
    Really? I use both KDE and mplayer+vdpau daily and they work just fine together.
    Occasionally mplayer locks up due to some vdpau quirk, but that's it.
    VDPAU has never worked for me. It's this bug:

    http://www.nvnews.net/vbulletin/showthread.php?t=173519

    It was confirmed by NVidia back then. But still no fix till this day.

  6. #6
    Join Date
    Jul 2009
    Posts
    27

    Default

    Still working on the forums; we realize how unfortunate the current situation is right now and are trying to work it out as soon as possible.

    As for the VDPAU / KWin interaction problems, we're currently looking into it and discussing potential solutions with the KWin developers.

    Thanks!

  7. #7
    Join Date
    May 2010
    Posts
    89

    Default

    Some progess, regarding a tear free desktop shoud be top priority, because most opengl DE shows tearing in the upper portion of the screen (KWIN, COMPIZ), using nvidia drivers.

  8. #8
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,796

    Default

    Quote Originally Posted by narciso View Post
    Some progess, regarding a tear free desktop shoud be top priority, because most opengl DE shows tearing in the upper portion of the screen (KWIN, COMPIZ), using nvidia drivers.
    This is because the GPU switches to an extremely low power mode (50Mhz) and stays there. The "PowerMizer" thing simply refuses to unstuck itself from the 50Mhz mode, even if you produce activity on the desktop. The only thing that seems to wake it up is launching a 3D app or something like Firefox and scroll around in a page. And even then, it's too slow to adapt. Worst of all, you can't change the settings in a meaningful way (like disable only the 50Mhz mode and leave the others as they are.)

    I had to force the GPU to a higher mode because of that, or else the desktop (KDE) sucks major (heavy tearing and jerky animations.) This, however, disables automatic power mode switching, so now I'm stuck with just one mode (the middle one, between extremely low and full throttle.)

    This thing should have never made it past QA, IMO. It's annoying as hell.
    Last edited by RealNC; 09-12-2012 at 06:08 PM.

  9. #9
    Join Date
    Feb 2011
    Posts
    45

    Default

    Great, I hope this fixes my problem with the lastest driver hanging the X server about when my mouse randomly skips. It only happens when I'm gaming in 3d. When the same thing happend 2 years ago, I replaced my mouse thinking that was the issue (skips but not lockups) eventually a nvidia driver update fixed it. As it stands now, when it locks up I gotta hard reset or ssh in and kill/restart the X server manually.

  10. #10
    Join Date
    May 2010
    Posts
    89

    Default

    Quote Originally Posted by RealNC View Post
    This is because the GPU switches to an extremely low power mode (50Mhz) and stays there. The "PowerMizer" thing simply refuses to unstuck itself from the 50Mhz mode, even if you produce activity on the desktop. The only thing that seems to wake it up is launching a 3D app or something like Firefox and scroll around in a page. And even then, it's too slow to adapt. Worst of all, you can't change the settings in a meaningful way (like disable only the 50Mhz mode and leave the others as they are.)

    I had to force the GPU to a higher mode because of that, or else the desktop (KDE) sucks major (heavy tearing and jerky animations.) This, however, disables automatic power mode switching, so now I'm stuck with just one mode (the middle one, between extremely low and full throttle.)

    This thing should have never made it past QA, IMO. It's annoying as hell.
    The problem is not the powermizer, but the way nvidia deals with vsync. Compiz latest development release implemented a fix for tearing on nvidia, Kwin dev's passed the ball to nvidia drivers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •