Results 1 to 10 of 23

Thread: 8.44 problems in creating debs for debian unstable

Hybrid View

  1. #1
    Join Date
    Jan 2008
    Posts
    13

    Default 8.44 problems in creating debs for debian unstable

    Hi all,
    I've just joined the forum, found while searching for posts about the new installer ati 7.12 - 8.443. I'm using Debian Sid which uses Xorg 7.3 and kernel 2.6.23. I had to upgrade the system due to problems concerning the WM. In my previous configuration, Sid was using Xorg 7.2 and kernel 2.6.22. In that system I was able to install fglrx by creating the debs packages from the installer, then installed the module and edited the xorg.conf. The installer 8.40 worked properly.

    After the upgrade I used 8.443 installer that should be working fine with X 7.3 and kernel 2.6.23 but fails in creating the debs:

    smoke@debian:/video/documents/ATI$ sudo ./ati-driver-installer-8.443.1-x86.x86_64.run --buildpkg Debian/unstable


    dh_installdeb
    LD_PRELOAD= dh_shlibdeps --exclude=emul
    dpkg-shlibdeps: warning: symbol _XFlush used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextAddDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol _XReply used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextRemoveDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextCreateExtension used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextFindDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libpthread.so.0 (it uses none of its symbols).
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with librt.so.1 (it uses none of its symbols).
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libdl.so.2 (it uses none of its symbols).
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libm.so.6 (it uses none of its symbols).
    dpkg-shlibdeps: warning: symbol _XFlush used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextAddDisplay used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol _XReply used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextRemoveDisplay used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextCreateExtension used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextFindDisplay used by debian/fglrx-driver/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/glesx.so shouldn't be linked with libdl.so.2 (it uses none of its symbols).
    dpkg-shlibdeps: failure: couldn't find library libfglrx_gamma.so.1 needed by debian/fglrx-driver/usr/bin/fglrx_xgamma (its RPATH is '').
    Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
    To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
    dh_shlibdeps: command returned error code 512
    make: *** [binary] Error 1
    dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
    Removing temporary directory: fglrx-install.lo8585
    Has anyone experienced the same problem? Any help will be very appreciated!

    The old installer 8.40 isn't reporting this error while building the packages but as it's not compatible with 2.6.23, I cannot fulfill the installation of fglrx.

    Thanks to everyone in advance

  2. #2
    Join Date
    Apr 2007
    Location
    Michigan
    Posts
    51

    Default

    try kanotix rc7, ive had success with ATI drivers using it.

  3. #3
    Join Date
    Jan 2008
    Posts
    13

    Default

    Isn't kanotix a different distro of Linux? In general I feel at home in Debian, more than in others deb-based distros mostly because is the one I always used. I don't absolutely want to be harsh, but you know, reinstalling Linux changing the distro even if quite similar isn't that great (I've been using ubuntu for a short time and found several differences between them). fglrx worked fine on Debian till a week ago on older packages. This thing I'm experiencing has a few matches on web but I didn't realized what exactly is the solution. The only hint was a missing dependency but sounds strange that 8.40 installer isn't reporting this problem. As a matter of fact it doesn't seem to be the answer to the problem because no one posted the solution in the forum where the matter was questioned.

    I actually have the direct rendering and OpenGL support because Xorg 7.3 has correctly detected the Video Card but the results are very poor (let's say half the stats I had on 2.6.22 with fglrx 8.40).

    Hope I've been kind and not too confused (as I'm in reality because fglrx seems to be the doom of ATI's owners even if they told things would have changed)

    Thanks anyway

  4. #4
    Join Date
    Apr 2007
    Posts
    99

    Default

    dist-upgrade and try again, I had the same error yesterday. For some reason it works again tho.

  5. #5
    Join Date
    Jan 2008
    Posts
    13

    Default

    Quote Originally Posted by damentz View Post
    dist-upgrade and try again, I had the same error yesterday. For some reason it works again tho.
    That's a great news but I hope you'll assist me: unfortunately I've just launched a dist-upgrade and found 23 packages to be upgraded, related to pango and sylpheed (no good...). After rebooting, the ati installer keeps returning that error. Do you have any idea on what kind of problem we are figuring?

    I really thank you for your help, at least I'm not alone!

  6. #6
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    Put ati-installer(s) into /usr/src then you don't need to dl it again and just execute my script - presinstalled with Kanotix but should work for Debian and Ubuntu too.

    http://kanotix.com/files/install-fglrx-debian.sh

    You can go back to 7-11 using

    -v 7-11

    option. Same works for many older versions and kernel 2.6.23, for 2.6.24 only 8.39.4 and newer works [there is a check included that it will not even tried on wrong kernel].

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •