Page 4 of 4 FirstFirst ... 234
Results 31 to 35 of 35

Thread: Linux Kernel: "Drop Support For x86-32"

  1. #31
    Join Date
    Jan 2009
    Posts
    191

    Default

    Quote Originally Posted by Ex-Cyber View Post
    So... uh... Michael pretty much admits that he wrote this article to troll the forums. Huh.
    and, surprisingly, it looks like his most well-written article too.
    go figure.

  2. #32
    Join Date
    Jun 2012
    Posts
    340

    Default

    Quote Originally Posted by adler187 View Post
    Personally, I was surprised that Windows 7 supported 32 bit processors at all, considering the system requirements for Vista. They improved things quite a bit from Vista, but I still think 7 should have been 64-bit only. Windows 8, definitely should have been 64-bit only (on x86). I'm guessing they left the support in for 32-bit tablets.
    MSFT made it clear they wanted Win8 to support everything 7 did. Same NT 6.1 Kernel too, so no real reason to force that issue. I fully expect Win8 to be the last 32bit OS by MSFT though. Which makes me wonder if MSFT will get around to re-coding a LOT of the legacy stuff thats still in Windows...

    But for an OS like Linux? No reason to force the issue. Totally different user base.

  3. #33
    Join Date
    Jun 2012
    Posts
    340

    Default

    Quote Originally Posted by GreatEmerald View Post
    A user of such device says hi!

    Yea, dropping 32-bit is just plain stupid. That said, what would be a good thing for Microsoft to do is drop WOW64 by not having it installed by default. Perhaps offer it as a download. That would be enough to motivate developers to do a proper 64-bit build.
    And ever single SW maker would go balistic if they did. If performance demands it, devs will make 64-bit builds.

    Quote Originally Posted by elanthis View Post
    Ancient 32-bit apps run on Windows x64 just fine in most cases, just like most ancient 32-bit apps run on Linux x86_64 just fine (assuming you install the 32-bit userland). The only things that need to be upgraded/replaced are drivers (and the odd program whose authors did something stupid).
    More or less on the spot.

  4. #34
    Join Date
    Sep 2007
    Posts
    51

    Post SPARC is not old, SPARC is the only server CPU freed under GPL

    SPARC is not old architecture it is present.

    There is Ultrasparc T2 CPU that is GLP'ed for Microprocessor definition
    and is free to develop, manufacture adn enhance in open.: www.opensparc.net

    As there are old - x86 CPUs, there is also old SPRCs but that does not say whole architecture is old or something.
    It evolves and is being developed further, same for x86 ,SPARC and POWER.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •