Go to http://www.coupons.com and here is what you'll get:

We're Sorry

The internet browser you are using is not supported.
Go to http://www.smartsource.com and you run into a similar situation. It does appear to look like someone over there is wanting to make it work, but they aren't there yet. I attempted to quote what it says on screen, but it doesn't flow right in the cut and paste.(it looks fine on smartsource) It does recognize linux, recognizes JRE 1.7, but says it's too low and I need a higher version.

Go to http://coupons.walmart.com and the result is the same.

Your computer operating system or internet browser is not supported.

We support the following configurations, please try printing again in a supported platform.
So how about it? Where do you go for coupons?