Page 11 of 34 FirstFirst ... 91011121321 ... LastLast
Results 101 to 110 of 340

Thread: AMD Catalyst 7.12 Linux Driver -- The Baby's In Surgery

  1. #101
    Join Date
    Nov 2007
    Posts
    19

    Default

    Oh man, this just cannot be true... I mean, what kind of company is AMD that they think they can afford such a behavior?

    I was hoping to be finally able to use the xrandr 1.2 extensions with this release, so I could dynamically add displays to my laptop. Of course I also expected them to fix all the flickering and mouse pointer corruption bugs for good with this release. Ha, how could I have been so naive...

    Ironically, I just ordered a 22" widescreen for work, with 1680x1050 - bingo! The reason for choosing a widescreen instead of one with 1600x1200 was that with the widescreen I don't need a second panel. Now they break widescreen support. And to make things even worse, they break the native 1400x1050 in my thinkpad t60! And this is supposed to be a bug fix release? How sarcastic can it get?

    The pain with the ATI driver is going on for so long now... I mean, what was all the fuss with the new codebase about? What's that new codebase good for, if the driver breaks more stuff with every release, and the useful features (e.g. xrandr) still not working properly?

    Finally, what kind of customer support does ATI think they are giving? Michael sends them an email to make sure they get bug reports, no one is replying to my bugs filed on ati.cchtml.com, while NVIDIA has a forum and staff that replies, files a bug number and seems to care?

    Sorry ATI, you lost me as a customer. Too bad I can't change the gfx card in my T60. But in my entire department at work, no ATI card will get installed ever again. I just can't afford wasting my time with unusable driver releases anymore.

    I'm looking forward to the day when I finally get a new laptop with an NVIDIA or Intel chip, and every time a new ATI driver is released, I'll read the first three pages in the forum on phoronix and smile, while my gfx card just works.

  2. #102

    Default Really regretting buying AMD laptop right now

    Based on all the great announcements on Phoronix and an ignorant assumption that ATI would at least have to put out something comparable to NVIDIAs binary driver, I bought a notebook with an HD2600 in it. The stability level of the fglrx driver has been pathetic compared to NVIDIA. With each new release I cross my fingers. This morning I installed the "christmas present", 7.12 and my machine is F&#(!d. Scrolling is the slowest yet , possibly worse than the vesa driver. The fans won't shut off (in the past two versions it was okay). AMD should handover their driver to radeonHD, this is a joke. Now I'll be even more emphatic that friends buying machines to run Linux get an NVIDIA based card.

  3. #103
    Join Date
    Oct 2007
    Posts
    28

    Default

    can someone tell me where to find the libglx.so ??
    i just have a symbolic link to a libglx.so that doesn't exist!

  4. #104
    Join Date
    Dec 2007
    Posts
    4

    Default

    Hi,

    I brought a Sapphire Radeon HD 3870, along with a new computer, hoping things were improving, notably with the radeonhd open source driver (and also because it was a bit cheaper than the 8800 GT, for about the same price/performance ratio, and I don't need the additional performances, as I don't play games much).

    I had to wait a few weeks, for this new fglrx driver, because 7.11 didn't seem to work with my 3870.

    Now it's out, the only serious problem I had, was the PreInitDAL failed error, when starting Xorg (and I had to deactivate my framebuffer, to workaround it).

    I get a proper 1920x1200 resolution, `glxinfo` and `glxgears` both seem ok, and xv seems to work with mplayer (although it is really blocky, as the changelog is noting, so I guess I'll just use gl2 output, for now).

    I didn't test Beryl/Compiz (but I probably won't use them anyway), nor any game, though.


    Well, I guess I don't regret buying an ATI card again, although I do hope things will rapidly continue improving -I do need my framebuffer- :) (including the open source driver ^_^).


    Thanks to everyone working on all this, and good luck to those with more important problems.


    Bye.

  5. #105
    Join Date
    Nov 2007
    Posts
    7

    Default Dual-head screen resolution issues

    I'm running a Radeon HD 2600 XT with 7.12 on gutsy x86_64. Dual-headed 'one big desktop' was working just fine with 8.42.3 on these two. Since installing the new driver, however, my widescreen area comes up as 2560x1024, and I'm left with non-native resolution on both of my screens. There doesn't seem to be a way to change this either via aticonfig yields
    Code:
    aticonfig --resolution=2880x900
    Error: Section # expected
    aticonfig: parsing the command-line failed.
    The release notes didn't indicate a problem at this resolution. Anyone have any suggestions? My xorg.conf hasn't changed since 8.42.3, though I've messed around with creating new ones with poor results.

  6. #106
    Join Date
    Sep 2006
    Location
    PL
    Posts
    909

    Default

    can someone tell me where to find the libglx.so ??
    find /usr/lib -name "libglx.so"

    i remember it was something like /usr/lib/xorg/extensions/(...) or something along the lines on my gentoo.

  7. #107
    Join Date
    Oct 2007
    Posts
    73

    Default

    Quote Originally Posted by Michael View Post
    No, it's not a random number generator...
    The 8.443 is the old style fglrx version. The .1 is interesting, I think it must be the result of the delayed released. It seems ATI did do some last minute changes.

  8. #108
    Join Date
    Dec 2007
    Posts
    5

    Thumbs up

    A good point for this driver :

    suspend and hibernation (on Ubuntu gutsy) are back with the SLUB support integrated in the release. And this is far more important than Compiz ...

  9. #109
    Join Date
    Oct 2007
    Posts
    28

    Default

    i found: /usr/lib/xorg/modules/extensions/libglx.so
    but its yust a symlink:
    lrwxrwxrwx 1 root root 42 Dec 15 18:33 libglx.so -> //usr//lib/opengl/ati/extensions/libglx.so

    but the destination doesn't exist!
    the whole ati/extensions directory is empty!

  10. #110
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by benneque View Post
    can someone tell me where to find the libglx.so ??
    i just have a symbolic link to a libglx.so that doesn't exist!
    usually it is: /usr/lib/opengl/ati/extensions/libglx.so

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •