Page 9 of 9 FirstFirst ... 789
Results 81 to 88 of 88

Thread: XAA In X.Org Has Finally Met Its Executioner

  1. #81
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,541

    Default

    Thanks. At first glance it appears that you still have kernel modesetting enabled...

    [ 15.105271] [drm] radeon kernel modesetting enabled.
    [ 15.105454] radeon 0000:01:05.0: power state changed by ACPI to D0
    [ 15.105461] radeon 0000:01:05.0: power state changed by ACPI to D0
    [ 15.106056] ACPI: PCI Interrupt Link [LNK0] enabled at IRQ 10
    [ 15.112590] [drm] initializing kernel modesetting (RS200 0x1002:0x4337 0x103C:0x0850).
    [ 15.112638] [drm] register mmio base: 0xC0300000
    [ 15.112641] [drm] register mmio size: 65536
    [ 15.113036] agpgart-ati 0000:00:00.0: AGP 2.0 bridge
    [ 15.113060] agpgart-ati 0000:00:00.0: putting AGP V2 device into 4x mode
    [ 15.113110] radeon 0000:01:05.0: putting AGP V2 device into 4x mode
    [ 15.113117] radeon 0000:01:05.0: GTT: 64M 0xC4000000 - 0xC7FFFFFF
    [ 15.113126] radeon 0000:01:05.0: VRAM: 128M 0x0000000038000000 - 0x000000003FFFFFFF (128M used)
    [ 15.113140] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
    [ 15.113144] [drm] Driver supports precise vblank timestamp query.
    [ 15.113166] [drm] radeon: irq initialized.
    [ 15.116172] [drm] Detected VRAM RAM=128M, BAR=256M
    [ 15.116177] [drm] RAM width 64bits DDR
    [ 15.118158] [TTM] Zone kernel: Available graphics memory: 445888 kiB
    [ 15.118164] [TTM] Zone highmem: Available graphics memory: 449700 kiB
    [ 15.118167] [TTM] Initializing pool allocator
    [ 15.118228] [drm] radeon: 128M of VRAM memory ready
    [ 15.118232] [drm] radeon: 64M of GTT memory ready.
    [ 15.118273] [drm] radeon: ib pool ready.
    [ 15.141641] radeon 0000:01:05.0: WB disabled
    [ 15.141654] [drm] fence driver on ring 0 use gpu addr 0xc4000000 and cpu addr 0xf8024000
    [ 15.141816] [drm] Loading R100 Microcode
    ... despite booting with modeset=0 (is this maybe the wrong syntax for current drivers ?)...

    [ 425.714] Current Operating System: Linux Microknoppix 3.4.9 #34 SMP PREEMPT Fri Aug 17 06:30:04 CEST 2012 i686
    [ 425.714] Kernel command line: ramdisk_size=100000 lang=en apm=power-off initrd=minirt.gz nomce libata.force=noncq hpsa.hpsa_allow_any=1 loglevel=1 tz=localtime BOOT_IMAGE=linux radeon.modeset=0
    ... and you're using the fbdev X driver rather than radeon (-ati)...

    [ 425.725] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [ 425.725] (II) Module fbdev: vendor="X.Org Foundation"
    [ 425.725] compiled for 1.12.1, module version = 0.4.2
    [ 425.725] ABI class: X.Org Video Driver, version 12.0
    [ 425.725] (II) FBDEV: driver for framebuffer: fbdev
    [ 425.725] (++) using VT number 5

    [ 425.746] (II) Loading sub module "fbdevhw"
    [ 425.746] (II) LoadModule: "fbdevhw"
    [ 425.746] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [ 425.747] (II) Module fbdevhw: vendor="X.Org Foundation"
    [ 425.747] compiled for 1.12.3, module version = 0.0.2
    [ 425.747] ABI class: X.Org Video Driver, version 12.0
    [ 425.747] (**) FBDEV(0): claimed PCI slot 1@0:5:0
    [ 425.747] (II) FBDEV(0): using default device
    [ 425.747] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
    [ 425.747] (==) FBDEV(0): RGB weight 888
    [ 425.747] (==) FBDEV(0): Default visual is TrueColor
    [ 425.747] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
    [ 425.747] (II) FBDEV(0): hardware: radeondrmfb (video memory: 3072kB)
    [ 425.747] (II) FBDEV(0): checking modes against framebuffer device...
    [ 425.747] (II) FBDEV(0): checking modes against monitor...
    [ 425.747] (--) FBDEV(0): Virtual size is 1024x768 (pitch 1024)
    [ 425.747] (**) FBDEV(0): Built-in mode "current"
    [ 425.747] (++) FBDEV(0): DPI set to (96, 96)
    [ 425.747] (II) Loading sub module "fb"
    [ 425.747] (II) LoadModule: "fb"
    [ 425.748] (II) Loading /usr/lib/xorg/modules/libfb.so
    [ 425.748] (II) Module fb: vendor="X.Org Foundation"
    [ 425.748] compiled for 1.12.3, module version = 1.0.0
    [ 425.748] ABI class: X.Org ANSI C Emulation, version 0.4
    [ 425.748] (**) FBDEV(0): using shadow framebuffer
    [ 425.748] (II) Loading sub module "shadow"
    [ 425.748] (II) LoadModule: "shadow"
    [ 425.750] (II) Loading /usr/lib/xorg/modules/libshadow.so
    [ 425.756] (II) Module shadow: vendor="X.Org Foundation"
    [ 425.757] compiled for 1.12.3, module version = 1.1.0
    [ 425.757] ABI class: X.Org ANSI C Emulation, version 0.4
    [ 425.757] (==) Depth 24 pixmap format is 32 bpp
    [ 425.838] (==) FBDEV(0): Backing store disabled
    [ 425.839] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
    [ 425.839] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
    [ 425.839] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
    [ 425.839] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
    [ 425.839] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument

  2. #82
    Join Date
    Jul 2012
    Location
    SuperUserLand
    Posts
    538

    Default

    whenever I try to manually set driver "radeon" and restart X, X doesn't restart it keeps failing until you are back to X with fbdev


    What I know is that the X.org radeon driver doesn't work with this radeon card, and that is that. I can't figure out how to enable XAA, at this point I don't think it's even possible.

    But since that other guy with the really recent card couldn't also get it to work at least I know It's not just me... it seems that old and new radeons are not supported...

    sorry but this ati radeon shit is just a fk'ng headache and I'm giving up

    radeon.modeset=o and it detects your card as a generic VESA or something, at least it won't lag you

  3. #83
    Join Date
    Dec 2007
    Posts
    2,402

    Default

    XAA doesn't work with KMS. You need to disable KMS. The UMS code in the ddx also does not work when KMS is enabled. To disable KMS, set radeon.modeset=0 (zero not o) on the kernel command line in grub. Then you can use the UMS support (and XAA) in the radeon driver to control the card.

  4. #84
    Join Date
    Feb 2008
    Posts
    1,223

    Default

    In Debian you have radeon-kms.conf in /etc/modprobe.d

    Code:
    options radeon modeset=1
    set that to 0 and reboot.

    I assume Knoppix is the same there .
    Last edited by dungeon; 09-05-2012 at 01:08 PM.

  5. #85
    Join Date
    Oct 2010
    Posts
    331

    Default

    If he's using a livecd reboot is not an option as the setting will get lost. According to the Debian wiki nomodeset should do the trick from the kernel command line: http://wiki.debian.org/KernelModesetting#Disabling_KMS

  6. #86
    Join Date
    Jul 2012
    Location
    SuperUserLand
    Posts
    538

    Default

    I have tried

    knoppix radeon.modeset=0

    knoppix nomodeset

    knoppix radeon.modeset=o (this one seems to be the one that effectively shuts down compiz and the other thing)

    I seriously don't think it's possible to turn XAA on despite what everyone says

  7. #87
    Join Date
    Feb 2008
    Posts
    1,223

    Default

    Quote Originally Posted by Pallidus View Post
    I have tried
    knoppix radeon.modeset=o (this one seems to be the one that effectively shuts down compiz and the other thing)
    That is UMS/EXA. For XAA you need to further edit your xorg.conf, log-out & log-in.

  8. #88
    Join Date
    Feb 2012
    Posts
    502

    Default

    Quote Originally Posted by Pallidus View Post
    I seriously don't think it's possible to turn XAA on despite what everyone says
    Oh, I'm very sure it is. You're just not approaching the whole thing correctly. Every time you set something, you have to be aware exactly what the state of the system is, instead of just typing random options and hoping for the best. /var/log/Xorg.0.log and dmesg are your friends.

    It would also really, really help if you actually made an install instead of playing with a live distro. Then you'd boot into commandline mode, check if the radeon module loaded the way you want it to, adjust things and reboot if not. Then start X from there with a specific X config. Then leave X, change the config and start X again. Each time checking the logs to know the state of the system.

    If this sounds complicated, it's really not. I could have all sorts of combinations tested in like 10 minutes, and would know exactly what effect each option has.
    Last edited by Gusar; 09-08-2012 at 05:47 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •