Page 7 of 7 FirstFirst ... 567
Results 61 to 64 of 64

Thread: AGP PCI-E Issues (Rialto chip) No Interupt (IRQ) assigned, Poor performance.

  1. #61
    Join Date
    Dec 2007
    Posts
    2

    Default

    Hi ppl! I'm running Fedora 8 x86_64. My system is AMD 64 on Asus K8V motherboard. I using x1950pro AGP video. My system was work with 7.11 fglrx and kernel 2.6.23.8-63 .Today i upgraded kernel to 2.6.23.9-85 and ati driver to 7.12. Now when i started X, the computer suspends totally with the black screen. Here my xorg.conf

    # Xorg configuration created by livna-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"

    EndSection

    Section "Module"
    Load "dbe"
    Load "fbdevhw"
    Load "GLcore"
    Load "record"
    Load "freetype"
    Load "type1"
    Load "glx"
    Load "dri"
    Load "extmod"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us+inet"
    EndSection

    Section "Monitor"
    Identifier "CRT"
    VendorName "Hitachi"
    ModelName "CM769ET"
    HorizSync 75.0 - 127.0
    VertRefresh 85.0 - 150.0
    EndSection

    Section "Device"
    Identifier "radeon"
    Driver "fglrx"
    Option "UseInternalAGPGART" "on"
    Option "AGPv3Mask" "0x00000001"
    Option "BusType" "AGP"
    Option "KernelModuleParm" "agpgart=0"
    Option "MaxGARTSize" "256"
    Option "XAANoOffscreenPixmaps"
    Option "AccelMethod" "xaa"
    Option "ForceGenericCPU" "on"
    Option "Centermode" "on"
    Option "PseudoColorVisuals" "off"
    Option "no_accel" "no"
    Option "no_dri" "no"
    Option "ForceMonitors" "notv"
    Option "TexturedXrender" "true"
    Option "UseFastTLS" "0"
    Option "BlockSignalsOnLock" "on"
    Option "OpenGLOverlay" "off"
    Option "VideoOverlay" "on"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "radeon"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Group "video"
    Mode 0666
    EndSection

    Section "Extensions"
    Option "XVideo" "Enable"
    Option "DAMAGE" "true"
    Option "RENDER" "true"
    Option "Composite" "Enable"
    EndSection

  2. #62
    Join Date
    Jan 2007
    Posts
    418

    Default

    I had the preINit error aswell with this new driver initially, but lowerd me gart in the bios to 256 (from 512) and used the 'other' DVI port on my dual dvi ported card and it appears to be working as expected. Finally x1950Pro AGP support!

    Code:
    fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
    [fglrx] Maximum main memory to use for locked dma buffers: 1898 MBytes.
    [fglrx] ASYNCIO init succeed!
    [fglrx] PAT is enabled successfully!
    [fglrx] module loaded - fglrx 8.44.3 [Dec 19 2007] on minor 0
    ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 20
    [fglrx] Internal AGP support requested, but kernel AGP support active.
    [fglrx] Have to use kernel AGP support to avoid conflicts.
    [fglrx] AGP detected, AgpState   = 0x1f000a1b (hardware caps of chipset)
    agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
    agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
    agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode
    [fglrx] AGP enabled,  AgpCommand = 0x1f000312 (selected caps)
    [fglrx] Reserve Block - 0 offset =  0X1fffb000 length = 0X5000
    [fglrx] Reserve Block - 1 offset =  0X0 length = 0X1000000
    [fglrx] Reserve Block - 2 offset =  0Xff80000 length = 0X80000
    Code:
    (II) fglrx(0): Depth moves disabled by default
    (==) fglrx(0): Capabilities: 0x00000000
    (==) fglrx(0): CapabilitiesEx: 0x00000000
    (==) fglrx(0): cpuFlags: 0x4000001f
    (==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
    (**) fglrx(0): ATI GART size: 256 MB
    (II) fglrx(0): [pci] find AGP GART
    (II) fglrx(0): [agp] Mode=0x1f000a1b bridge: 0x1106/0x0282
    (II) fglrx(0): [agp] AGP v1/2 disable mask 0x00000000
    (II) fglrx(0): [agp] AGP v3 disable mask   0x00000000
    (II) fglrx(0): [agp] enabling AGP with mode=0x1f000b1a
    (II) fglrx(0): [agp] Remapping MC AGP space (new MCAGPBase = 0xd0000000)
    (II) fglrx(0): [agp] AGP protocol is enabled for graphics board. (cmd=0x1f000312)
    (II) fglrx(0): [agp] graphics chipset has AGP v3.0 (native mode)
    (II) fglrx(0): [pcie] 262144 kB allocated
    (II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 65536
    Last edited by oliver; 12-29-2007 at 11:24 AM.

  3. #63
    Join Date
    Nov 2007
    Posts
    8

    Default

    Hi
    I have Radeon HD2600 Pro AGP and I have only one problem. I think that is too slow.

    ~]$ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 2600 Pro AGP
    OpenGL version string: 2.1.7170 Release

    ~]$ glxinfo | grep direct
    direct rendering: Yes

    ~]$ dmesg | grep fglrx
    fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
    [fglrx] Maximum main memory to use for locked dma buffers: 431 MBytes.
    [fglrx] ASYNCIO init succeed!
    [fglrx] PAT is enabled successfully!
    [fglrx] module loaded - fglrx 8.44.3 [Dec 19 2007] on minor 0
    [fglrx] Internal AGP support requested, but kernel AGP support active.
    [fglrx] Have to use kernel AGP support to avoid conflicts.
    [fglrx] AGP detected, AgpState = 0x1f004a1b (hardware caps of chipset)
    [fglrx] AGP enabled, AgpCommand = 0x1f004312 (selected caps)
    [fglrx] Reserve Block - 0 offset = 0X1fffc000 length = 0X4000
    [fglrx] Reserve Block - 1 offset = 0X0 length = 0X1000000
    [fglrx] Reserve Block - 2 offset = 0Xfeff000 length = 0X100000
    [fglrx] interrupt source 60000001 successfully enabled
    [fglrx] enable ID = 0x00000006
    [fglrx] Receive enable interrupt message with irqEnableMask: 60000001
    [fglrx] interrupt source 00000040 successfully enabled
    [fglrx] enable ID = 0x00000007
    [fglrx] Receive enable interrupt message with irqEnableMask: 00000040
    [fglrx] interrupt source ff00002c successfully enabled
    [fglrx] enable ID = 0x00000008
    [fglrx] Receive enable interrupt message with irqEnableMask: ff00002c
    [fglrx] interrupt source ff00002d successfully enabled
    [fglrx] enable ID = 0x00000009
    [fglrx] Receive enable interrupt message with irqEnableMask: ff00002d
    [fglrx] interrupt source 20000400 successfully enabled
    [fglrx] enable ID = 0x0000000A
    [fglrx] Receive enable interrupt message with irqEnableMask: 20000400
    [fglrx:firegl_free_mutex] *ERROR* mutex id 0x00000004 not found in mutex list
    [fglrx:firegl_free_mutex] *ERROR* mutex id 0x00000005 not found in mutex list

    ost ~]$ glxgears
    4155 frames in 5.0 seconds = 830.870 FPS
    4255 frames in 5.0 seconds = 850.967 FPS

  4. #64
    Join Date
    Jan 2007
    Posts
    418

    Default

    Quote Originally Posted by wojak View Post
    Hi
    I have Radeon HD2600 Pro AGP and I have only one problem. I think that is too slow.

    ~]$ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 2600 Pro AGP
    OpenGL version string: 2.1.7170 Release

    ~]$ glxinfo | grep direct
    direct rendering: Yes

    ~]$ dmesg | grep fglrx
    fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
    [fglrx] Maximum main memory to use for locked dma buffers: 431 MBytes.
    [fglrx] ASYNCIO init succeed!
    [fglrx] PAT is enabled successfully!
    [fglrx] module loaded - fglrx 8.44.3 [Dec 19 2007] on minor 0
    [fglrx] Internal AGP support requested, but kernel AGP support active.
    [fglrx] Have to use kernel AGP support to avoid conflicts.
    [fglrx] AGP detected, AgpState = 0x1f004a1b (hardware caps of chipset)
    [fglrx] AGP enabled, AgpCommand = 0x1f004312 (selected caps)
    [fglrx] Reserve Block - 0 offset = 0X1fffc000 length = 0X4000
    [fglrx] Reserve Block - 1 offset = 0X0 length = 0X1000000
    [fglrx] Reserve Block - 2 offset = 0Xfeff000 length = 0X100000
    [fglrx] interrupt source 60000001 successfully enabled
    [fglrx] enable ID = 0x00000006
    [fglrx] Receive enable interrupt message with irqEnableMask: 60000001
    [fglrx] interrupt source 00000040 successfully enabled
    [fglrx] enable ID = 0x00000007
    [fglrx] Receive enable interrupt message with irqEnableMask: 00000040
    [fglrx] interrupt source ff00002c successfully enabled
    [fglrx] enable ID = 0x00000008
    [fglrx] Receive enable interrupt message with irqEnableMask: ff00002c
    [fglrx] interrupt source ff00002d successfully enabled
    [fglrx] enable ID = 0x00000009
    [fglrx] Receive enable interrupt message with irqEnableMask: ff00002d
    [fglrx] interrupt source 20000400 successfully enabled
    [fglrx] enable ID = 0x0000000A
    [fglrx] Receive enable interrupt message with irqEnableMask: 20000400
    [fglrx:firegl_free_mutex] *ERROR* mutex id 0x00000004 not found in mutex list
    [fglrx:firegl_free_mutex] *ERROR* mutex id 0x00000005 not found in mutex list

    ost ~]$ glxgears
    4155 frames in 5.0 seconds = 830.870 FPS
    4255 frames in 5.0 seconds = 850.967 FPS
    how is it too slow? what framerates do you get in ET or ET:QW for example? Doom3? UT? Anything? glxgears is NOT a benchmark, so pasting your glxgears framerate is totally pointless and useless.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •