Results 1 to 7 of 7

Thread: ASPM Kernel Power Fix Won't Land Until Linux 3.3

  1. #1
    Join Date
    Jan 2007
    Posts
    15,629

    Default ASPM Kernel Power Fix Won't Land Until Linux 3.3

    Phoronix: ASPM Kernel Power Fix Won't Land Until Linux 3.3

    For those still wondering about the patches that appeared last month to mimic the power management behavior of Windows within the Linux kernel as a proper fix to the well known ASPM Linux kernel power regression, here's an update on the matter...

    http://www.phoronix.com/vr.php?view=MTAyMjk

  2. #2
    Join Date
    Dec 2007
    Location
    Edinburgh, Scotland
    Posts
    597

    Default

    I'm surprised this isn't applied to all the kernels in a point release. It genunely is a regression fix

  3. #3

    Default

    The original commit that caused this problem was also "just a fix", and see where it got us.

  4. #4
    Join Date
    Mar 2009
    Location
    in front of my box :p
    Posts
    840

    Default

    Well, I am rather happy here with my system and I use pcie_aspm=force on all machines w. PCIE without hassles. Still it would be nice to have it fixed in Kernel but maybe devs want to check out faulty hardware first to blacklist it. Otherwise people might end up with strange results with the next official kernel.

    It's always astonishing to me how much hardware bugs/flaws become visible and public during FOSS driver development.

  5. #5
    Join Date
    Sep 2008
    Location
    Vilnius, Lithuania
    Posts
    2,664

    Default

    Aww, that's too bad, so it definitely won't make it to Plasma Active Two... Ah well, I guess I can always use a workaround as well, for the time being.

  6. #6
    Join Date
    Nov 2011
    Posts
    296

    Angry

    Can you believe that in the meantime douches like this one pop up here and there? http://www.fewt.com/2011/09/about-ke...sion-myth.html

  7. #7

    Default

    Quote Originally Posted by Bucic View Post
    Can you believe that in the meantime douches like this one pop up here and there? http://www.fewt.com/2011/09/about-ke...sion-myth.html
    Quote Originally Posted by Bucic View Post
    You're making a mistake of even trying to discuss with his... assessments. The bug has been confirmed on launchpad.net by ubuntu devs plus there's a dedicated ubu wiki page for this particular issue and there some sorry #%@ specialist pop up like the issue itself wasn't PITA enough. It's not worth discussing here.
    So, I'm the guy that wrote the article and I have more experience with the issue than you can ever pretend to comprehend. You can discount it all you want, but I have proven the regression false on multiple occasions.

    For example:

    A T420 with the "regression" - 7 watts. - http://www.fuduntu.org/forum/viewtopic.php?f=13&t=1282

    An ASUS U56E Laptop with the "regression" - 7 watts - http://www.fuduntu.org/forum/viewtopic.php?f=13&t=1520

    The bug has been confirmed by people that don't comprehend the basics of configuration and testing, it is not a kernel problem it is a configuration problem. Is there room for power optimization in the kernel? Sure. Is there a regression? No.

    If you look at the following data set with the claimed fix - you will find that the "fix" really didn't amount to much except in the case of a small number of machines - as I implied.

    https://wiki.ubuntu.com/Kernel/PowerManagementASPM

    Check out the T420 thinkpads with the "fix", 14.89W - 9.14W - 19.54W, see the pattern? They are all using too much power because they are all configured wrong. If I can make them use 7 watts with a simple configuration change. Hmm..

    The test procedure isn't valid either, they should reboot the computer before testing for the baseline, and test with no apps running. Then do the same with the new kernel. They don't do that though, so there is no telling what was running before and what is running after.

    There is also no collection of data used to gather the metrics so it can't be analyzed, meaning unfortunately that it is all invalid. Amateur test cases at best.

    My ASUS (linked above) with the regression is currently sitting at 38 degrees Celsius, with Chromium, Thunderbird, Pidgin and a bunch of other apps running while connected to AC power.

    I can see now how it is a kernel problem though, thanks for pointing it out, genius.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •