Results 1 to 10 of 10

Thread: openSUSE 12.1 Boot Performance

  1. #1
    Join Date
    Jan 2007
    Posts
    15,399

    Default openSUSE 12.1 Boot Performance

    Phoronix: openSUSE 12.1 Boot Performance

    While yesterday I put out openSUSE 12.1 benchmarks for those interested in the performance of this updated Linux distribution, questions have arose about the boot performance, in particular due to openSUSE moving towards systemd and making other advancements...

    http://www.phoronix.com/vr.php?view=MTAxNzA

  2. #2
    Join Date
    Jul 2009
    Posts
    27

    Default

    This is to be expected, considering I don't believe any of the init scripts were converted to native systemd services for 12.1. This was done since there wasn't enough time to test both the new init system and rewriting and testing all the init scripts. I think this was a good decision and allows a seamless two-step change. First ensure the new init system didn't break anything and allow those to use the old init system as a fallback. Once that has gotten more testing, in 12.2 update the init scripts to native systemd services and hopefully will see some boot speed increases.

    Also, just because it doesn't boot faster doesn't mean systemd doesn't offer other useful features.

  3. #3
    Join Date
    Apr 2010
    Posts
    99

    Default

    Please, try to do some tests with +5yo PC's too (single core, old hdd, etc).

  4. #4

    Default

    Quote Originally Posted by DeiF View Post
    Please, try to do some tests with +5yo PC's too (single core, old hdd, etc).
    I don't keep such things around.

  5. #5
    Join Date
    Jun 2011
    Posts
    57

    Default

    I don't see the point in testing the boot speed for Fedora and OpenSUSE. They're not concentrating on boot speeds.

    If you want some interesting results, try Exherbo/Gentoo systemd vs Ubuntu Upstart. Preferably Exherbo since its scripts were written from scratch with systemd in mind.

    Generate a kernel/initrd and make sure both systems have the same services running.

  6. #6
    Join Date
    Jan 2010
    Location
    Portugal
    Posts
    945

    Default

    Quote Originally Posted by DeiF View Post
    Please, try to do some tests with +5yo PC's too (single core, old hdd, etc).
    No need. If it's the same as in 11.4 as demonstrated in the article then it will be very very slow on +5yo PCs. I used to have openSuse 11.4 on an Atom N270 netbook and I guarantee it is slow. It used to take something close to 2min before I could do anything. OpenSuse is just slow at booting. Even when running on an Athlon XP 2400+ that doesn't go into X it takes a considerable amount of time to boot.

  7. #7
    Join Date
    Apr 2010
    Posts
    99

    Default

    I was talking in general.

    Almost all the computers I see in a normal day (at university, at work, etc) are XP-era PC's. I have only seen i7's in shops.
    We know that i7's are fast, no matter what OS you throw at them. But what about those old comps that millions of people use?
    Do they benefit from Linux or what?

    I'm more interested in those benchmarks than state-of-the-art-computer ones.

  8. #8
    Join Date
    Nov 2008
    Location
    Madison, WI, USA
    Posts
    881

    Default

    Quote Originally Posted by DeiF View Post
    I was talking in general.

    Almost all the computers I see in a normal day (at university, at work, etc) are XP-era PC's. I have only seen i7's in shops.
    We know that i7's are fast, no matter what OS you throw at them. But what about those old comps that millions of people use?
    Do they benefit from Linux or what?

    I'm more interested in those benchmarks than state-of-the-art-computer ones.
    Biggest problem I've got with the Athlon-XP era computers is the intel ones. I've got a P4 laptop with i820 video that only runs using the VESA driver now. It boots into Unity 2D just fine, but video playback is horribly slow because there's no acceleration (KMS doesn't work on the i820, so the intel driver doesn't work). Even DVD playback is iffy. Maybe this weekend I'll set it up and run some boot time numbers.

  9. #9
    Join Date
    Aug 2007
    Posts
    6,645

    Default

    That boottime must be a joke for a ssd. I did bootchart tests a while ago with a 40 gb ssd and got 5s to kdm. even with a few years only 1 tb hd with 1 extra partition additional to / mounted i only need 31 s (which kdm autologin), checked with this in .kde/Autostart:
    Code:
    cat /proc/uptime > ~/uptime.txt
    Btw. my ssd test charts can still be found there:

    http://kanotix.com/files/fix/bootcha...i7-880-ssd.png

    note that was an untuned install without swap enabled. adding swap is a boot performance killer - the bigger it is, the slower it boots:

    http://kanotix.com/files/fix/bootcha...sd-6g-swap.png

    A current kanotix testimage booted via USB 2 (!!!) on my i7-2600 needs about 27s till full kde4 desktop is displayed (manually stopped). Why would somebody need an ssd to beat 44s boottime
    Last edited by Kano; 11-18-2011 at 10:49 AM.

  10. #10
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,587

    Default

    Quote Originally Posted by adler187 View Post
    This is to be expected, considering I don't believe any of the init scripts were converted to native systemd services for 12.1. This was done since there wasn't enough time to test both the new init system and rewriting and testing all the init scripts. I think this was a good decision and allows a seamless two-step change. First ensure the new init system didn't break anything and allow those to use the old init system as a fallback. Once that has gotten more testing, in 12.2 update the init scripts to native systemd services and hopefully will see some boot speed increases.

    Also, just because it doesn't boot faster doesn't mean systemd doesn't offer other useful features.
    This is true, the systemd integration is still a WIP and comes with some gotchas yet. NFS mounts for example take forever because if the mount attempts being made before the service actually starts (save yourself some trouble if you are mounting NFS shares in the fstab and fall back to sysvinit by installing the sysvinit-init package). This happens with a few items I have noticed where the services try to start before the daemons are even initialized which cause it to retry, retry, retry slowing the whole boot process down. On my systems I have quite a few NFS mounts and reverting back to sysvinit resulted in decreasing the boot time from 1 1/2 minutes to ~ 25 seconds (post Grub of course, initializing and detecting all my drives and sata cards takes a while).
    Last edited by deanjo; 11-21-2011 at 10:15 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •