Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Xorg 7.3 install guide

  1. #11
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    Quote Originally Posted by TheIcebreaker View Post
    can you just post an ls -R of your build directory
    No. Why would you want it? Here's the script diff though (I'm assuming this is want you really want).

  2. #12
    Join Date
    Oct 2007
    Location
    Mumbai India
    Posts
    39

    Default

    Well the install went well.
    Everything was built except some input drivers and video-glide.
    But as you said i dont need that.

    Problem now is that I tried to install the fglrx driver on the new Xorg after symlinking and all that.
    installer said everything ok.

    But there were no Libfglrx files inside and no aticonfig
    it only copied a dri module in X11R7.3/modules/dri

    but modules are supposed to be in xorg/modules I suppose.
    In the end expectedly the fglrx module did not load and X could not start.
    any ideas.

  3. #13
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    Quote Originally Posted by TheIcebreaker View Post
    But there were no Libfglrx files inside and no aticonfig
    it only copied a dri module in X11R7.3/modules/dri
    I can't know for sure, as I don't know how your system is set up. In my experience, the ati installer puts its files in /usr/lib/{dri,xorg} which are symlinks to /usr/X11/lib/{modules/dri,xorg} respectively. You should check that those links are not broken, or the installer will just abandon.

    Quote Originally Posted by TheIcebreaker
    but modules are supposed to be in xorg/modules I suppose.
    On my system, only libfglrxdrm.so and fglrx_drv.so are in xorg/modules/{linux,drivers}.

  4. #14
    Join Date
    Oct 2007
    Location
    Mumbai India
    Posts
    39

    Default

    are plz give me your ls -R X11R7.3
    I need to verify wat all is missing.


    I dont have many programs in bin like
    1 xterm
    2 glxinfo
    3 glxgears

    etc

  5. #15
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    Quote Originally Posted by TheIcebreaker View Post
    I dont have many programs in bin like
    1 xterm
    2 glxinfo
    3 glxgears

    etc
    That's because they come from different packages. xterm from xterm (obviously) and glxinfo&gears from MesaDemos.

    I considered for a moment pasting ls -R somewhere, but it's 5000 something lines. Here's ls /usr/X11/bin though:

    Code:
    # ls /usr/X11R7.3_old/bin/
    X@            dga*          inw@          oclock*     smproxy*                    xconsole*    xfindproxy*  xkbvleds*    xmore*                xset*         xvinfo*
    Xnest*        editres*      ioport*       outb@       startx*                     xcursorgen*  xfontsel*    xkbwatch*    xon*                  xsetmode*     xwd*
    Xorg*         fontname.sh*  lbxproxy*     outl@       sxpm*                       xcutsel*     xfs*         xkill*       xorgconfig*           xsetpointer*  xwininfo*
    Xvfb*         fontprop.sh*  listres*      outw@       twm*                        xdbedizzy*   xfsinfo*     xload*       xphelloworld*         xsetroot*     xwud*
    appres*       fonttosfnt*   lndir*        pcitweak*   viewres*                    xditview*    xft-config*  xlogo*       xplsprinters*         xsm*
    atobm*        fslsfonts*    luit*         proxymngr*  x11perf*                    xdm*         xfwp*        xlsatoms*    xpr*                  xstdcmap*
    bdftopcf*     fstobdf*      makedepend*   revpath*    x11perfcomp*                xdmshell*    xgamma*      xlsclients*  xprehashprinterlist*  xtrapchar*
    beforelight*  gccmakedep*   makeg*        rstart*     xauth*                      xdpr*        xgc*         xlsfonts*    xprop*                xtrapin*
    bitmap*       gtf*          makestrs*     rstartd*    xauth_switch_to_sun-des-1*  xdpyinfo*    xhost*       xmag*        xpsimplehelloworld*   xtrapinfo*
    bmtoa*        iceauth*      mergelib*     scanpci*    xbiff*                      xdriinfo*    xinit*       xman*        xpxthelloworld*       xtrapout*
    ccmakedep*    ico*          mkdirhier*    sessreg*    xcalc*                      xedit*       xkbbell*     xmessage*    xrandr*               xtrapproto*
    cleanlinks*   imake*        mkfontdir*    setxkbmap*  xclipboard*                 xev*         xkbcomp*     xmh*         xrdb*                 xtrapreset*
    cvt*          inb@          mkfontscale*  showfont*   xclock*                     xeyes*       xkbevd*      xmkmf*       xrefresh*             xtrapstats*
    cxpm*         inl@          mkhtmlindex*  showrgb*    xcmsdb*                     xfd*         xkbprint*    xmodmap*     xrx*                  xvidtune*
    If you followed the instructions, and only some drivers failed, then you *have* everything.
    Last edited by Xipeos; 10-31-2007 at 08:47 AM.

  6. #16
    Join Date
    Oct 2007
    Location
    Mumbai India
    Posts
    39

    Default

    i dont have the dmx* binaries as well
    though i have the libdmx libs in X11R7.3/lib

  7. #17
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    Quote Originally Posted by TheIcebreaker View Post
    i dont have the dmx* binaries as well
    though i have the libdmx libs in X11R7.3/lib
    That's because you didn't compile Xdmx. You most likely do not need it (it provides means to use multi-displays, with each display connected to a different computer).

    I've updated my previous post to reflect the contents of a vanilla X11R7.3 build.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •