Page 55 of 56 FirstFirst ... 54553545556 LastLast
Results 541 to 550 of 554

Thread: AMD 8.42.3 Driver Released -- The Baby Is Born!

  1. #541
    Join Date
    Aug 2007
    Posts
    56

    Default

    Quote Originally Posted by kingttx View Post
    I tried the 8.42 driver on my Compaq V2000 under Ubuntu 7.10 and it didn't work. After figuring out the composite issue, I tried running a 3D game (BZ Flag) and all it did was cause the laptop to shutdown due to overheating the card or CPU. After trying it a couple of times with the same results, I decided to revert back to the fglrx in the repositories and not try any 3D on my laptop for now.

    I was excited when I read last month that Mobility would be supported. Oy!
    in my ubuntu 7.10 didn't work
    in my suse 10.3 it works fine (i do not use compiz)
    in my gentoo it works fine (included all issues we all know: slow aiglx scroll, high CPU hunger, etc).

    by the way any news about next release?

  2. #542
    Join Date
    Apr 2007
    Location
    Mexico City, Mexico
    Posts
    906

    Default

    More importantly what could we actually expect of the Novemeber release. We knew that 8.42 would feature AIGLX along with the new OpenGL code, what could we expect of the next one? Which problems will be addressed, and what will remain?

  3. #543
    Join Date
    Oct 2007
    Posts
    14

    Default Hanve you tried...

    Quote Originally Posted by kingttx View Post
    I tried the 8.42 driver on my Compaq V2000 under Ubuntu 7.10 and it didn't work. After figuring out the composite issue, I tried running a 3D game (BZ Flag) and all it did was cause the laptop to shutdown due to overheating the card or CPU. After trying it a couple of times with the same results, I decided to revert back to the fglrx in the repositories and not try any 3D on my laptop for now.

    I was excited when I read last month that Mobility would be supported. Oy!
    Have you tried any of the closed-source games (quake3/4, doom3)? These ran fine for me, bu I have had some issues trying to run OS 3d games (chromium locks up my xserver hard). What was the output of fglrxinfo under your configuration?

  4. #544
    Join Date
    Oct 2007
    Posts
    46

    Default

    Quote Originally Posted by Thetargos View Post
    More importantly what could we actually expect of the Novemeber release. We knew that 8.42 would feature AIGLX along with the new OpenGL code, what could we expect of the next one?
    Well, I'd hope that ATI would've managed to get rid of the horrible memory leak in the OpenGL code in 8.42, for a start...

  5. #545
    Join Date
    Nov 2007
    Posts
    7

    Default Gutsy amd64 Radeon HD 2600HT

    Ok, so I've had a few problems with this process, but have something that remotely works.

    I mostly followed method 2 of this guide:
    http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    I was able to manually create the packages and install them using the Ubuntu/gutsy patch described near the bottom of the guide.

    I now have two problems:
    1) I need to manually insmod the module every time I reboot, then restart X (good ol' Ctrl+Alt+Backspace). Modifying /etc/rc.local as described in the guide did not work. Perhaps gdm is messing with this stuff?

    2) Unsure whether or not this is related, but amdcccle doesn't seem to do anything when I change settings (even as sudo, and it updates xorg.conf)... It will change the display settings for the current session, but when I logout and log back in (with gdm), this goes away. (e.g. I change settings to use my dual-headed displays as one big desktop, and when I log back in it shows up mirrored). This happens with or without the the ATI driver running, which leads me to believe it's probably an X issue.

    Any suggestions/questions/comments?

    This is functional but I am definitely waiting on AMD for the next update (hopefully) with gutsy support. Compviz works but not great.. choppy hi-res videos are unacceptable.

  6. #546
    Join Date
    Oct 2007
    Posts
    14

    Default Why, oh why...

    I finally got this card running stably without desktop artifacts, only to discover that, while 3D framerates are much improved, this driver leaks memory like a firehose (glx_gears using 500 MB after about 2 minutes). Why, oh why didn't I pay more for the (technically inferior, but apparently better supported) GeForce 7300?

    OpenSuse 10.2 on Dell e1505 / Ati MX1400
    Last edited by happycampers; 11-16-2007 at 04:55 PM.

  7. #547
    Join Date
    Nov 2007
    Posts
    7

    Default

    Quote Originally Posted by gmplague View Post
    Ok, so I've had a few problems with this process, but have something that remotely works.

    I mostly followed method 2 of this guide:
    http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    I was able to manually create the packages and install them using the Ubuntu/gutsy patch described near the bottom of the guide.

    I now have two problems:
    1) I need to manually insmod the module every time I reboot, then restart X (good ol' Ctrl+Alt+Backspace). Modifying /etc/rc.local as described in the guide did not work. Perhaps gdm is messing with this stuff?

    2) Unsure whether or not this is related, but amdcccle doesn't seem to do anything when I change settings (even as sudo, and it updates xorg.conf)... It will change the display settings for the current session, but when I logout and log back in (with gdm), this goes away. (e.g. I change settings to use my dual-headed displays as one big desktop, and when I log back in it shows up mirrored). This happens with or without the the ATI driver running, which leads me to believe it's probably an X issue.

    Any suggestions/questions/comments?

    This is functional but I am definitely waiting on AMD for the next update (hopefully) with gutsy support. Compviz works but not great.. choppy hi-res videos are unacceptable.
    So I figured out my own problem here.
    http://www.phoronix.com/forums/showthread.php?t=6017

    Following the steps prescribed by Ren Hoek seems to have worked, at least with problem 1. I'm working remotely, so we'll see about problem 2.

  8. #548
    Join Date
    Oct 2007
    Posts
    44

    Default

    Interesting.
    The last xserver update in slackware seems to have partially fixed the "first gl program hangs" issue here. Two programs that still do that are glxinfo and amdcccle. Could be that there are more but the games I tried worked fine.

    All the update included was that the xserver was rebuilt against a newer mesa and that xmdx was disabled. I guess the mesa update may have done it.
    Last edited by chefkoch; 11-18-2007 at 03:04 PM.

  9. #549
    Join Date
    Nov 2007
    Posts
    5

    Default

    Has anyone else had the lastest Quake4 freeze their system with these drivers?

  10. #550
    Join Date
    Nov 2007
    Posts
    4

    Default little success

    Hej givemesugarr, hej all,

    finally I had the chance to spend some time into the DualHead-project - had a lot of work during the last weeks....

    Following the thoughts of givemesugarr from his entry (11-04-2007) I tried to find out wich modules require kernel agpgart. How can I find out which are the ones? So, I put agpgart and intel_agp in /etc/modprobe.d/blacklist and after that, I get

    nl-ws-boris: lsmod | grep agp
    agpgart 31912 1 fglrx

    and in syslog this:

    Nov 21 18:10:42 nl-ws-boris kernel: [fglrx] module loaded - fglrx 8.42.3 [Oct 19 2007] on minor 0
    Nov 21 18:10:56 nl-ws-boris kernel: [fglrx] IRQ_MGR is disabled untill GART_CACHABLE memory will be implemented<6>[fglrx] Internal AGP is not supported in 2.6 kernel.

    BUT the X-server is running!!

    Yes, it is running but with a lot of trouble:
    I have both monitors with one X each, but on the left one the moused pointer is not viewable. On the right one the mouse pointer is a pixel square. Also the grafics are VERY slow. At last, switching to tty1 by CTRL+ALT+F1 freezes the whole system (no longer pingable from other box) and the monitors are blinking with 1 Hz and zoomed frozen background pics from my desktop.

    I could post more logs and confs but find that to be misplaced here because that could be a lot of data. Anybody suggesting a good place (upload server)?

    Boris
    Last edited by BruderB; 11-21-2007 at 04:06 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •