Page 27 of 56 FirstFirst ... 17252627282937 ... LastLast
Results 261 to 270 of 554

Thread: AMD 8.42.3 Driver Released -- The Baby Is Born!

  1. #261
    Join Date
    Oct 2007
    Posts
    3

    Default

    Quote Originally Posted by SteviOS View Post
    Still mesa instead of ati
    Code:
    fglrxinfo
    display: :0.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (2.1 Mesa 7.0.1)
    Any ideas?
    Finally I got it working on my Toshiba Satellite Pro A100 (ATI Mobility Radeon X1400). In a few words:
    • I did a clean install of Gutsy
    • Installed the driver manually via method 2 (--buildpkg Ubuntu/7.10 / !blocked fglrx in restricted drivers!)
    • Added the fglrx to compiz whitelist

    Thx ATI. I realized some bugs but I think it's a great driver compared to those I had to use before 8.41.X.

  2. #262
    Join Date
    Aug 2007
    Posts
    6

    Default

    i'm wondering is this new driver works with 2.6.22.9

  3. #263
    Join Date
    Oct 2007
    Posts
    54

    Default

    Quote Originally Posted by gummybearx View Post
    yea, im curious of how they got their setups working so flawlessly, to say the least.

    maybe its the years of configging x servers for their living that makes them so good at it...^^

    but seriously, a writeup for howtos for different distros would be fantabulastic.
    They never said that compiz runs with decent scrollings, and without flickering while playing videos.

  4. #264
    Join Date
    Oct 2007
    Posts
    10

    Default Serious issues with 8.42.3

    Hi,

    My OS is Ubuntu Gutsy 7.10 and hardware is Lenovo Thinkpad T60 (wide screen) with dual head configuration. Graphics adapter is Mobility Radeon X1400.

    I'm succesfully running compiz-fusion and truecombat (as well as other gl software) with the new drivers.

    However there are a few irritating things:

    1. Poor compiz performance when Mozilla software (thunderbird / firefox) has focus. If such software is visible but without focus, rotating the cube or expo works flawlessly. I'm not sure whether this is a compiz issue, but this doesn't happen on nvidia hardware and nvidia proprietary driver.

    2. Crashes! I'm not sure if dualhead conifguration makes the crashes more frequent. During the five hours I've been testing the new drivers now there has been about a dozen of crashes (X dies unexpectedly) and gdm restarts it). One of the best ways to make it crash is to make e.g. rhythmbox window so wide it reaches from one display to another. Either rhythmbox window goes blank (=black) or the whole X goes down.

  5. #265
    Join Date
    Aug 2007
    Posts
    6,641

    Default

    For etch you can alway use my script to correctly install the driver:

    http://kanotix.com/files/install-fglrx-debian.sh

    As there are 2 watermarks possible you don't have got /etc/ati/control or /etc/ati/signature. If the first is missing you get unsupported hardware, if the second is missing you get ATI testing watermark. Hotfix would be:

    sh ati-driver-installer-8.42.3-x86.x86_64.run --extract ati
    cp ati/common/etc/ati/{control,signature} /etc/ati/

    Then restart X server.

  6. #266
    Join Date
    Oct 2007
    Posts
    10

    Default

    Hi everyone,

    Many experiences yet as I can see. I am really sad to have discovered this great news only this morning when I can not test it on my Ubuntu 7.10.
    Hopefully tonight I'll post my experience

    Jeff

  7. #267
    Join Date
    Oct 2007
    Posts
    10

    Default

    Oops I forgot:

    I have not found a good how-to for Ubuntu for this driver. Do anyone have a link or a quick step-by-step ?


    Thanks and regards, Jeff.

  8. #268
    Join Date
    Oct 2007
    Posts
    3

    Default

    Quote Originally Posted by jeffjoker View Post
    Oops I forgot:

    I have not found a good how-to for Ubuntu for this driver. Do anyone have a link or a quick step-by-step ?


    Thanks and regards, Jeff.

    How about this one , it s on Ubuntu forums

    http://ubuntuforums.org/showthread.php?t=589075

  9. #269
    Join Date
    Aug 2007
    Posts
    6,641

    Default

    Disable restricted modules and start my script, it works with Debian and Ubuntu:

    http://kanotix.com/files/install-fglrx-debian.sh

    Then just change the whitelist to support fglrx.

  10. #270
    Join Date
    Oct 2007
    Location
    Holland
    Posts
    24

    Default

    I'm as happy as a little child at a fair. My X1950Pro has stopped collecting dust in my drawer and is now instead collecting dust within my pc ( which is a better place to collect dust imho )

    AIGLX works, not really fast, but it's ok. performance has increased.

    The only strange thing is:
    I play WoW using Cedega until a few weeks ago. For some reason WoW got terribly slow ( 1 -3 fps ). I hoped the new driver would fix this. The strange thing however is that 8.42 did not really fix this. WoW still runs at 3 fps except when I enable compiz. Then WoW leaps to 80-100 fps. But now I have texture corruption... Disabling compiz removes the texture corruption but also drops the framerate back to 3 fps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •