Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 56

Thread: Sampling info about that mouse freeze bug

  1. #11
    Join Date
    Aug 2011
    Posts
    29

    Default

    Quote Originally Posted by tcv90 View Post
    Affected by the bug: Yes
    Graphics card: ATI 5770 1GB
    Number of displays: 1
    Distribution (name, version, architecture): Ubuntu 11.04 64bit
    Desktop environment: Gnome
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: 11.5 - 11.7
    fglrx version(s) I've used on that distribution, without that bug: 11.4
    ATI Catalyst Control Center settings: Default
    Things I've tried to solved it (if affected): SWCursor will fix it, but it doesn't work very well, the cursor disappears, playing games you can't even see the cursor... Tried turning v-sync off, tear free off, doesn't fix it.
    Mine is very similar:
    Graphics card: ATI 5770 1GB
    Number of displays: 1
    Distribution (name, version, architecture): Ubuntu 10.10 64-bit, Ubuntu 11.04 64bit
    Desktop environment: Gnome 2.x, Unity
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: 11.5 - 11.6
    fglrx version(s) I've used on that distribution, without that bug: 11.4
    ATI Catalyst Control Center settings: Default

    I did not install the drivers outside of X. I downloaded the ATI drivers and then followed these steps in Ubuntu:
    1. Open terminal
    2. sudo bash (enter password)
    3. cd /home/(my account)/Downloads
    4. chmod 744 ati-driver-installer-11-6-x86.x86_64.run
    5. ./ati-driver-installer-11-6-x86.x86_64.run
    Follow prompts, restart.

    If anyone can seriously suggest that installing the new driver outside of X is better, I'll give it a go. I'm not sure how to shut down X in Ubuntu. In Debian I go to a tty and do "init 3". Anyone know the Ubuntu equivalent off hand?

    I didn't try 11.7 because I see no reason to do it when other people are still reporting the bug.

  2. #12
    Join Date
    Aug 2011
    Posts
    81

    Default

    Code:
    Affected by the bug: Yes
    Graphics card: ATI HD 5750
    Number of displays: 2 or 1
    Distribution (name, version, architecture): Fedora 15; kernel 2.6.38 - 3.0
    Desktop environment: XFCE
    Compositing: On
    fglrx version(s) I've used on that distribution, with that bug: 1.5+
    fglrx version(s) I've used on that distribution, without that bug: 1.4-
    ATI Catalyst Control Center settings: default
    Things I've tried to solved it (if affected): SWCursor set to true (breaks certain games), Downgrading to 1.4
    Fortunately, RPMFusion provides a downgraded package for the Catalyst driver at 1.4.
    Unfortunately, Fedora 15 now uses Linux 3.0 as of August 4, 2011. The earliest known catalyst driver able to handle that is 1.7 which contains the bug.
    Thankfully, Fedora keeps several fallback images :3
    Last edited by computerquip; 08-05-2011 at 01:37 AM.

  3. #13
    Join Date
    Feb 2010
    Posts
    519

    Default

    For those of you using Ubuntu Natty, could you please specify if the 11.4 version that works is the Ubuntu-repo one or from external sources? Thanks.

  4. #14
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    @Michael_S

    NEVER use the installer without creating deb packages for anything newer than lucid. That kills the system, at least parts of it that you wont be able to switch back to oss drivers your way even when you install it correctly later.

  5. #15

    Default

    Quote Originally Posted by PsynoKhi0 View Post
    For those of you using Ubuntu Natty, could you please specify if the 11.4 version that works is the Ubuntu-repo one or from external sources? Thanks.
    Both the repo version and the one from AMD's site works fine.

  6. #16
    Join Date
    May 2011
    Posts
    353

    Default

    So far it seems a Gnome problem with 11.5+
    Openbox also seems to be problematic but there's only 1 report.

    For me, it's:
    Affected: No
    Card: NVidia GeForce 8400M GS

  7. #17
    Join Date
    Nov 2008
    Location
    Old Europe
    Posts
    906

    Default

    Affected by the bug: No
    Graphics card: Radeon HD 4850
    Number of displays: 2
    Distribution (name, version, architecture): Gentoo, Kernel 3.0.1, amd64
    Desktop environment: KDE 4.7
    Compositing: On (kwin)
    fglrx version(s) I've used on that distribution, with that bug: none
    fglrx version(s) I've used on that distribution, without that bug: 11.6, 11.7
    ATI Catalyst Control Center settings: 'Tear Free' enabled
    Things I've tried to solved it (if affected): none

  8. #18
    Join Date
    Aug 2011
    Posts
    29

    Default

    Quote Originally Posted by Kano View Post
    @Michael_S

    NEVER use the installer without creating deb packages for anything newer than lucid. That kills the system, at least parts of it that you wont be able to switch back to oss drivers your way even when you install it correctly later.
    Kano,
    I'll remember that in the future, thanks. If you install it the regular way without having it build the appropriate .deb file, it puts an uninstaller shell script at /usr/share/ati/fglrx-uninstaller.sh that seemed to work fine for me. Whenever I was uninstalling the driver and reverting to the open source drivers (which I did frequently when I first encountered this mouse bug) I used that and it seemed to work fine.

    But this thread has made think I should have installed the XFCE desktop and the KDE desktop and see if they're affected the same way on my machine.

    I also wonder if the version of X.org is a factor.

  9. #19
    Join Date
    Aug 2011
    Posts
    3

    Default

    PC1
    Affected by the bug: Yes
    Graphics card: HD5750
    Number of displays: 1
    Distribution (name, version, architecture): Debian, wheezy, amd64
    Desktop environment: Xfce 4.8
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: 11-5, 11-6, 11-7
    fglrx version(s) I've used on that distribution, without that bug: 11-4
    ATI Catalyst Control Center settings: defaults
    Things I've tried to solved it (if affected): downgraded to 11-4


    PC2
    Affected by the bug: No
    Graphics card: HD4850
    Number of displays: 1
    Distribution (name, version, architecture): Debian, wheezy, i386
    Desktop environment: Xfce 4.8
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: nope
    fglrx version(s) I've used on that distribution, without that bug: 11-4, 11-6, prior versions (starting somewhere from middle of 9-th major versions)
    ATI Catalyst Control Center settings: defaults
    Things I've tried to solved it (if affected): nope, everything ok.

  10. #20
    Join Date
    Aug 2011
    Posts
    1

    Default

    Affected by the bug: No
    Graphics card: Sapphire Radeon HD5670
    Number of displays: 1
    Distribution (name, version, architecture): Ubuntu 11.04 x86
    Desktop environment: Unity
    Compositing: On
    fglrx version(s) I've used on that distribution, with that bug:
    fglrx version(s) I've used on that distribution, without that bug: as far as i know ubuntu installs 11.5 with jockey
    ATI Catalyst Control Center settings: defaults without VSync
    Things I've tried to solved it (if affected):

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •