Page 2 of 9 FirstFirst 1234 ... LastLast
Results 11 to 20 of 81

Thread: KDE SC 4.7.0 Officially Released

  1. #11
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,762

    Default

    Quote Originally Posted by smitty3268 View Post
    Which card do you have again? I seem to remember it was one of the slowest r600g cards.
    No, it's actually one of the fast flagship cards of that generation. HD4870. I have already tried every tweak mentioned here long ago. Nothing helps. KWin after KDE 4.5 was getting slower and slower. Disabling KDE's VSync in systemsettings and setting vblank_mode to 0 helped a bit, but not much.

    KWin's performance in recent versions is really crappy on my system. I once tried Compiz with KDE, but the integration sucks.
    Last edited by RealNC; 07-27-2011 at 11:20 PM.

  2. #12
    Join Date
    Mar 2010
    Posts
    158

    Default

    Quote Originally Posted by RealNC View Post
    Kernel 3.0, Mesa Git master, xf86-video-ati Git master and "raster" with Qt 4.7.3. And it stinks.
    KDE SC 4.7 recommends Qt 4.7.4 under "System Requirements".

    http://kde.org/announcements/4.7/platform.php

    System Requirements
    In order to get the most out of these releases, we strongly recommend to use the latest version of Qt, as of today 4.7.4. This is necessary in order to assure a stable experience, as some improvements made to KDE software have actually been done in the underlying Qt framework.

    In order to make full use of the capabilities of KDE's software, we also recommend to use the latest graphics drivers for your system, as this can improve the user experience substantially, both in optional functionality, and in overall performance and stability.
    If you are having a poor experience, and you are unable to meet the system requirements of KDE SC 4.7, then the easiest interim solution might be to change the desktop rendering backend to Xrender.

    For other readers, for some balance ... KDE SC 4.7 is a fantastic experience for some users:

    http://blog.martin-graesslin.com/blo...opengl-es-2-0/

    Thanks for driving my poor GeForce 6150 towards graphics nirvana. Blur works amazingly here, effects are smooth and I can still see my graphics chip throttling down to 100 MHz.

    Thanks also for enabling me to use the Lanczos shader with my GeForce 8500 GT. I never saw that feature running so smoothly in a computer.

    Now, with KDE 4.7, I can pump more effects, get more performance and, in some cases, use even less CPU than never before. Thank you, KWin performance in KDE 4.7 is, for the first time, GREAT.

  3. #13
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,762

    Default

    Quote Originally Posted by hal2k1 View Post
    KDE SC 4.7 recommends Qt 4.7.4 under "System Requirements".

    http://kde.org/announcements/4.7/platform.php
    There is no such thing right now. Latest version of Qt is 4.7.3.

    If you are having a poor experience, and you are unable to meet the system requirements of KDE SC 4.7, then the easiest interim solution might be to change the desktop rendering backend to Xrender.
    Xrender is much slower than what I currently have. So now I have slow, with Xrender I have super-slow. :-P

  4. #14
    Join Date
    Aug 2009
    Location
    south east
    Posts
    336

    Default

    save yourself some pain, use the ati provided drivers.
    the open source drivers are hit and miss.

    i just wish ati would release an updated driver to support 10.04 '$ graphics stack.
    for r300
    Quote Originally Posted by RealNC View Post
    No, it's actually one of the fast flagship cards of that generation. HD4870. I have already tried every tweak mentioned here long ago. Nothing helps. KWin after KDE 4.5 was getting slower and slower. Disabling KDE's VSync in systemsettings and setting vblank_mode to 0 helped a bit, but not much.

    KWin's performance in recent versions is really crappy on my system. I once tried Compiz with KDE, but the integration sucks.

  5. #15
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,279

    Default

    Quote Originally Posted by RealNC View Post
    ES seems to be useless with the open source r600g driver. KWin just crashes immediately.
    I didn't think GL ES support was built into the r600g driver by default, just regular GL support IIRC. Distros shipping KWin might be enabling GL ES in their builds, not sure.
    Last edited by bridgman; 07-28-2011 at 12:47 AM.

  6. #16
    Join Date
    Aug 2009
    Posts
    2,264

    Default

    I don't know if it helps, but it seems as if though disabling compatibility checks under the desktop config section not only gave me blur when everyone was crying that it didn't work with FLOSS (on Fedora with a HD5770 and HD5470), but everything went crash-free fast.

    Did you try that?

  7. #17
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,762

    Default

    Quote Originally Posted by bridgman View Post
    I didn't think GL ES support was built into the r600g driver by default, just regular GL support IIRC. Distros shipping KWin might be enabling GL ES in their builds, not sure.
    Hm, so Mesa Git master (which I'm using) does not provide ES for r600g?

  8. #18
    Join Date
    Oct 2007
    Posts
    1,183

    Default

    @RealNC: I tried KWin with OpenGL2 on Kubuntu 11.10/r600g/mesa 7.11 and it works fairly well with a RadeonHD 4550/RV710. It should be smoother on 4870. I have no idea what you're doing wrong :\

  9. #19
    Join Date
    Jun 2009
    Posts
    2,908

    Default

    Quote Originally Posted by RealNC View Post
    Hm, so Mesa Git master (which I'm using) does not provide ES for r600g?
    It does, but you will need the set the appropriate USE flag when emerging it.

  10. #20
    Join Date
    Jul 2010
    Posts
    59

    Angry Rant subject change

    Nepomuk/Strigi - i'm curious - when will be usable? Here's simple test and big fail (again).


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •