Results 1 to 3 of 3

Thread: Is there a way to disable or limit system xrandr probes?

  1. #1
    Join Date
    Jul 2011
    Posts
    2

    Default Is there a way to disable or limit system xrandr probes?

    I came across a Phoronix article on XRandR while searching for a solution to this problem. I hope this is the correct forum to post this query. Please let me know a more appropriate venue if not. [1]

    I am currently suffering from a video card related bug [2] which causes my TV screen to flicker every 10 seconds. According to a Launchpad contributor, this is probably caused by the system running a regular xrandr probe.

    Is there any way to safely disable this probe while I wait for a bugfix?

    I want to be able to:

    * run my machine as normal when the S-video cable is not plugged in
    * plug in the cable and choose to output to the TV using the Monitor Preferences tool
    * unplug the cable and switch back to normal resolution
    * (low priority) boot up with the cable plugged in and have it be detected and used
    * not mess everything up

    Is this possible? A system setting would be preferable, but a script/command to run after I've got the TV hooked up is acceptable.

    [1] I've already asked this on AskUbuntu but no answers yet http://askubuntu.com/questions/54422...-xrandr-probes

    [2] S-video output doesn't work in Ubuntu 11.04 https://bugs.launchpad.net/ubuntu/+s...el/+bug/763688

  2. #2
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    512

    Default

    if you have upowerd installed make sure that it's at least version 0.9.9 and that /etc/UPower/UPower.conf does _not_ contain PollDockDevices=true

  3. #3
    Join Date
    Jul 2011
    Posts
    2

    Default PollDockDevices=false

    Quote Originally Posted by droste View Post
    if you have upowerd installed make sure that it's at least version 0.9.9 and that /etc/UPower/UPower.conf does _not_ contain PollDockDevices=true
    I checked it out, and I have UPower 0.9.9-4 installed, and PollDockDevices=false, so it's not that. Thanks anyway droste! If you have any other suggestions I'm all ears.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •